none
Stop 0x0000007b after Windows Backup Restore to different hardware RRS feed

  • Question

  • I'm attempting to validate a disaster recovery scenario. Server 2008 R2 as AD/DC with various apps on it (Exchange 2010, Forefront, SQL, etc...)

    Original server: 200GB IDE boot drive as the C: System drive (with the 100MB System Reserved partition), plus 2 SATA drives as D: (1TB) and E: (2TB). D: holds data. Windows Backup backs C: and D: up to E:, which is the dedicated drive for Windows Backup. MSI mobo with an Intel E4600 CPU. No RAID, or ACHI.

    New server: ASUS mobo with i7 930 CPU. Again, no raid. I've tried a variety of drive configurations, but I keep getting the 0x0000007b stop error.

    Restore Attempt #1: I mounted all 3 original drives in the new box in the same order. Boot fails with 0x0000007b.

    Restore Attempt #2: I put a new blank 2TB drive as C:, mounted the original machine's dedicated Windows Backup drive as D:. After selecting to restore last full image, and WinRE finding it on D:, telling it to proceed quickly fails stating the drive cannot be found (despite me telling it to reformat the drive as necessary.) This strongly suggested to me that Restore expects the same number of physical disks.

    Restore Attempt #3: I started Windows 2008 R2 setup and partitioned the new blank 2TB drive into 2 partitions, 500GB and 1.5TB. I then let setup complete an installation of Server 2008 R2 and verified the drives to ensure the System Reserved partition was created in the 500GB partition. I then formatted the 1.5TB partition. This left the original dedicated Windows Backup drive as E:, as it was in the original system. I rebooted and went into WinRE and told it to restore the last image (which it found). It proceeded to restore C: and D: and reboot. After reboot, 0x0000007b stop error again.

    Restore Attempt #4: I wiped the new 2TB drive and left it as C:. I mounted the original 1TB drive as D:, as it was in the original system. The original dedicated Windows Backup drive was again E:. Restore says it completes, but upon reboot, I still get the 0x0000007b stop message.

    After that last restore attempt I put the original disks back into the original hardware. Startup failed. So I did a restore which succeeded. The original box is working fine now.

    This leads me to believe that there are problems restoring an IDE boot drive to a SATA drive. I have noticed that when you go into a command prompt via WinRE, the drive order is incorrect. That is, it does not match the drive priority list given in the system BIOS. The SATA drives are showing up as C: and D:, and the IDE is showing up as E:. I don’t know if this is why it keeps failing or not. This may be a peculiarity of the ASUS board, since this isn’t a problem with the MSI board.

    What surprises me is that there is no feature in WinRE that lets you assign backed up drives/partitions to new partitions (or to create partitions accordingly but allowing you to specify which is the boot partition.)

    Wednesday, September 1, 2010 3:39 PM

Answers