none
DFS is not working anymore.

    Question

  • DFS was configured and working fine on Server 2008 STD, but now it's no longer replicating.  Here are some of the errors I am seeing:

    ---------------------------------------------------------------------------------------
    - Due to the following error, the DFS Replication reporting mechanism cannot access the WMI (Windows Management Instrumentation) namespace to retrieve certain reporting information. Error ID: 0x80041002.

    - DFS Replication cannot replicate with partner <server name> for replication group <domain>\<name space>\<share>. The partner did not recognize the connection or the replication group configuration. The DFS Replication service used partner DNS name <server name>, IP address <the server ip>, and WINS address <server name> but failed with error ID: 9026 (The connection is invalid). Event ID: 5012

    AND

    - The DFS Replication service is stopping communication with partner <server name> for replication group Domain System Volume due to an error. The service will retry the connection periodically.
     
    Additional Information:
    Error: 1726 (The remote procedure call failed.)
    Connection ID: 580D7FC3-873F-48CC-AFC1-73E96DFADCE2
    Replication Group ID: ACA5FC8A-AA2E-4D40-8ECC-3A0A8F45E5F8
    ---------------------------------------------------------------------------------------

    I also have noticed that there is a disabled sysvol in the replication area which belongs to an decommissioned server.  Not sure if that would mess anything up or not since it is disabled (and not needed), but I can't get rid of it.

    Tuesday, September 30, 2008 10:44 PM

Answers

  • Hi Rollinz,

     

    According to the research, the issue maybe occur because the DFS servers do not have the permission to read AD information on themselves or their partners.

     

    1. Please open the ADSIedit.msc console to verify the "Authenticated Users" is set with the default READ permission on the following object:

     

    a. The computer object of the DFS server

     

    b. The DFSR-LocalSettings object under the DFS server computer object

     

    2. After the permissions is set correct, please run "DFSRDIAG POLLAD" to pick up the changes.

     

    Another possible reason is that FSRM is configured as some types of files are blocked from DFS replication. When the DFSR filters are not set to match FSRM screens by extension and the files exist on the server before screening, this can lead to degraded DFSR performance and the files will never replicate.

     

    If possible, please remove file screening and reconfigure it to remove files by extension or set a comparable DFSR filter rule to prevent replication attempts.

     

    Hope it helps.


    David Shen - MSFT
    • Marked as answer by Rollinz Tuesday, October 07, 2008 4:32 PM
    Friday, October 03, 2008 9:14 AM

All replies

  • Hi Rollinz,

     

    According to the research, the issue maybe occur because the DFS servers do not have the permission to read AD information on themselves or their partners.

     

    1. Please open the ADSIedit.msc console to verify the "Authenticated Users" is set with the default READ permission on the following object:

     

    a. The computer object of the DFS server

     

    b. The DFSR-LocalSettings object under the DFS server computer object

     

    2. After the permissions is set correct, please run "DFSRDIAG POLLAD" to pick up the changes.

     

    Another possible reason is that FSRM is configured as some types of files are blocked from DFS replication. When the DFSR filters are not set to match FSRM screens by extension and the files exist on the server before screening, this can lead to degraded DFSR performance and the files will never replicate.

     

    If possible, please remove file screening and reconfigure it to remove files by extension or set a comparable DFSR filter rule to prevent replication attempts.

     

    Hope it helps.


    David Shen - MSFT
    • Marked as answer by Rollinz Tuesday, October 07, 2008 4:32 PM
    Friday, October 03, 2008 9:14 AM
  • You are the man David!

    A few side notes for anyone else looking for a fix here:

    - The file permissions were already set correctly in my case.
    - I went into adsiedit.msc and updated the schema as well as verified in my Domain Controller list that DFS replication was good.
    - I then ran the suggested "DFSRDIAG POLLAD".

    One last critical step I had to do because I had deleted my DFS replication groups was to not only recreate them, but to first delete the "DfsPrivate" hidden folders that were left behind.  For some reason mine were either corrupt, or the server never noticed they needed to be recreated.  I got the following message in my event logs before deleting the DfsPrivate folders:

    ------------------------------------------------------------

    The DFS Replication service failed to communicate with partner <server name> for replication <group_name>. The partner did not recognize the connection or the replication group configuration.
     
    Partner DNS Address: <server.domain>
     
    Optional data if available:
    Partner WINS Address: <server>
    Partner IP Address: x.x.x.x
     
     
    The service will retry the connection periodically.
     
    Additional Information:
    Error: 9026 (The connection is invalid)
    Connection ID: EE4A57A7-CC40-4156-BB08-1CE6B9348208
    Replication Group ID: DFAC71DA-A412-4C10-8A6B-0D6198AEFD6B
    Tuesday, October 07, 2008 4:32 PM
  • Hi Rollinz,

    Thank you for the knowledge sharing on this issue. The other community members could get benefit from it.

    Thanks again.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Saturday, May 23, 2009 2:08 PM
  • Hi,

    I have had a similar issue while setting up DFS Replication and the replication reporting issued the Error ID: 0x80041002 and also Error: 9026 (The connection is invalid).

    In my case I was able to resolve it by registering the MicrosoftDFS WMI namespace (I don't know if or why it has been de-registered or somehow stepped on).

    Anyway maybe this helps you if you have the same issue

    Open a CMD prompt in %windir%\system32\wbem

    type mofcomp dfsrprovs.mof

    net stop winmgmt
    net start winmgmt
    net start iphlpsvc
    net stop dfsr
    net start dfsr

    Now it works (for me) and I hope for you !

    Raymond
    Sunday, July 12, 2009 10:29 PM
  • Thanks Raymond,

    Your solution worked for me!

    Thursday, June 02, 2011 2:07 AM
  • I m still gettting the error. 

     

    - The DFS Replication service is stopping communication with partner <server name> for replication group Domain System Volume due to an error. The service will retry the connection periodically. 
     
    Additional Information: 
    Error: 1726 (The remote procedure call failed.) 
    Connection ID: 580D7FC3-873F-48CC-AFC1-73E96DFADCE2 
    Replication Group ID: ACA5FC8A-AA2E-4D40-8ECC-3A0A8F45E5F8

     


    This was verified and its the same on the two DFS servers. 

    1. Please open the ADSIedit.msc console to verify the "Authenticated Users" is set with the default READ permission on the following object:

     

    a. The computer object of the DFS server

     

    b. The DFSR-LocalSettings object under the DFS server computer object

     

    2. After the permissions is set correct, please run "DFSRDIAG POLLAD" to pick up the changes.

     

     

    The below filters are not in use.

     

    Another possible reason is that FSRM is configured as some types of files are blocked from DFS replication. When the DFSR filters are not set to match FSRM screens by extension and the files exist on the server before screening, this can lead to degraded DFSR performance and the files will never replicate.

     

    If possible, please remove file screening and reconfigure it to remove files by extension or set a comparable DFSR filter rule to prevent replication attempts.

     

     

    Any suggestions. Thanks Cliford,


    Monday, October 31, 2011 6:29 AM
  • Another possible reason... the files exist on the server before screening... and the files will never replicate.


    David Shen - MSFT

    This ended up being my issue in the end; the folders already existed with files inside them on server1.  I tested this out by un-sharing the folderA on both servers, moving it on both servers, and deleted the DfsrPrivate folders.  Created a new replication group which created the folderA on both servers.  Once that was done, I tested it by creating a blank TXT file called Test.txt.  For the sake of being a bit thorough, I restarted DFS service on both servers via command prompt "net stop dfs" "net start dfs".  Had to add the replication group to the display of server2 and then went to the Connections tab and right-clicked on my sending member connection that had the test.txt.  Told it to "replicate now..." and a few seconds later the file appeared on server2.

    All that remains now is moving the contents of my folder into the newly created folder and making sure my permissions are correct.  Then share it again.

    It's a bit of a hassle but at least it's working.  I also verifed everthing else that David Shen mentioned about ADSIedit, but didn't know where to find the filters and didn't try looking before this fixed it for me.

    Wednesday, August 08, 2012 7:45 PM
  • I faced similiar problems with one of my domain controllers that is in the cloud. We were having some networking difficulties with a new cloud server we spun up and contacted our cloud vendor who was attempting to troubleshoot our problem.  

    Turns out that the vendor had changed our Windows firewall rules on us and then didn't notify us. So be sure to check your firewall rules as well. 

    Once I fixed my firewall rules AD replication started working again.

    Wednesday, November 13, 2013 2:59 PM
  • I'm having a problem finding Authenticated Users... is it still in Server 2012 R2?
    Saturday, December 21, 2013 12:53 AM
  • DFS was configured and working fine on Server 2008 STD, but now it's no longer replicating.  Here are some of the errors I am seeing:

    ---------------------------------------------------------------------------------------
    - Due to the following error, the DFS Replication reporting mechanism cannot access the WMI (Windows Management Instrumentation) namespace to retrieve certain reporting information. Error ID: 0x80041002.

    - DFS Replication cannot replicate with partner <server name> for replication group <domain>\<name space>\<share>. The partner did not recognize the connection or the replication group configuration. The DFS Replication service used partner DNS name <server name>, IP address <the server ip>, and WINS address <server name> but failed with error ID: 9026 (The connection is invalid). Event ID: 5012

    AND

    - The DFS Replication service is stopping communication with partner <server name> for replication group Domain System Volume due to an error. The service will retry the connection periodically.
     
    Additional Information:
    Error: 1726 (The remote procedure call failed.)
    Connection ID: 580D7FC3-873F-48CC-AFC1-73E96DFADCE2
    Replication Group ID: ACA5FC8A-AA2E-4D40-8ECC-3A0A8F45E5F8
    ---------------------------------------------------------------------------------------

    I also have noticed that there is a disabled sysvol in the replication area which belongs to an decommissioned server.  Not sure if that would mess anything up or not since it is disabled (and not needed), but I can't get rid of it.

    Just to give you all a different view, RPC problems are often also caused by firewall and RPC configuration problems. I have a Cisco ASA 5505 connected to a TMG 2010. DFSR was being a total failure, with only these warnings, until I in TMG "Configure RPC Protocol", where i uncheck the box "Enforce strict RPC compliance". Seems like WMI Control isn't per default under "strict complaince" for some reason. I suggest you to try connect to "WMI Control" using MMC to see whether WMI Connection works or not.
    Tuesday, January 28, 2014 2:28 PM