IE compatibility mode not applying via Group Policy


  • Just wondering if anyone out there has had a similar issue to my own.

    I've made a change to GPO to allow a particular url to run in compatibility mode when launched. I've run gpresult/rsop and confirmed that the policy is definitely being applied, however it simply doesn't run in compatibility mode when I go to the url. I have also tested against multiple url's.

    Policy being modified is "user config>Admin templates>Windows components>Internet Explorer>compatibility view".

    I have tested this on multiple desktops (win 7) and servers (win 2k8r2) within the scope of the gpo to no avail. Tested on ie8 & 9.


    Thank you


    Tuesday, December 20, 2011 11:09 PM


All replies

  • Hi,

    1.    The site has to be added with a top level domain name and should not be added fully. When added the site using Top level domain, it loaded correctly in the compatibility mode but these sites added through the group policy was not visible in the Compatibility View Settings

    2.    Please configure the "Turn on Internet Explorer Standards mode for Local Intranet" policy and set it to disable.

    3.    For the “Use Policy List of Internet Explorer 7 sites” policy: You need to add Top level domain names in the policy settings.

    4.    Both the IE compatibility view list in the IE UI and the "Use Policy List of Internet Explorer 7 Sites" group policy seems to only allow the use of TLD (Top Level Domain) i.e., which means the sub-domain name are not allowed or be ignored.

    Please refer to the below links for more details:

    Introducing Compatibility View

    A Compatibility View list update that is dated March 19, 2009 is available for Windows Internet Explorer 8

    IEAK 8 screencast demo and PM interview

    Compatibility List FAQ

    Hope this helps.

    Best Regards,

    Yan Li

    Yan Li

    TechNet Community Support

    Wednesday, December 21, 2011 2:43 AM
  • Of course, this solution sucks if you are in a country like United Kingdom, where a TLD id * (for example).

    So you have to compat or trust *all* those domains? Nice.

    MS has known for years that this is an issue, but clearly doesn't shive a git. They're too busy removing features from ie.

    Wednesday, February 26, 2014 9:27 PM
  • Cute. Couldn't even wait four hours, could you fanboi?

    Wednesday, February 26, 2014 9:32 PM
  • Hi,

    OK, so I'm a couple of years behind, but I just did some troubleshooting on this myself as I too was having the same issue.

    We just updated to IE11 and have opted to use Compatibly Mode rather than Enterprise Mode. After adding the sites to the group policy, I too wasn't seeing them listed in in the dialog in IE. But I have discovered that it is working.

    Double check by using the F12 developer tool, and it correctly says correctly that it's using IE7

    • Proposed as answer by BMan_au Thursday, September 4, 2014 3:59 AM
    Thursday, September 4, 2014 3:58 AM