none
Anyone knows silsvc RRS feed

  • Question

  • This server is upgraded from 2012 Essentials to standard. I find there is an error shown in server management.  The silsvc service should start automatically but it is stopped.  I check the directory but I can't find this file.  What's wrong?

    WHS is ready!

    Monday, November 19, 2012 3:30 PM

Answers

  • OK it looks to me like a bug, that the transmog process is not clearing out the Software Infrastructure License Service, just opening a bug and will check on a fix.

    I imagine it will be ok to simply delete this service from the registry.

    I had to edit the registry by booting to the recovery tools as i had access denied errors on that registry key.


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk


    Tuesday, November 20, 2012 12:47 PM
    Moderator

All replies

  • How did you perform the upgrade?

    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Monday, November 19, 2012 3:50 PM
    Moderator
  • How did you perform the upgrade?

    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    input the standard key

    WHS is ready!

    Tuesday, November 20, 2012 12:16 AM
  • Hi,

    I think you need to follow the article below to do the migration:

    Title: Transition from Windows Server 2012 Essentials to Windows Server 2012 Standard

    URL: http://technet.microsoft.com/en-us/library/jj247582.aspx

    Just input the WinSrv2012 Standard doesn't make sense to complete the upgrade.

    Regards,

    James


    James Xiong

    TechNet Community Support

    Tuesday, November 20, 2012 2:43 AM
    Moderator
  • Did you run a transmog or did you boot off the media and chose upgrade?

    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Tuesday, November 20, 2012 11:26 AM
    Moderator
  • Did you run a transmog or did you boot off the media and chose upgrade?

    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Execute “dism /online /set-edition:ServerStandard /accepteula /productkey:Product Key

    WHS is ready!

    Tuesday, November 20, 2012 11:56 AM
  • Just confirmed i have the same issue on a LAB Box.

    Ill see if i can find out anything.


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Tuesday, November 20, 2012 12:38 PM
    Moderator
  • OK it looks to me like a bug, that the transmog process is not clearing out the Software Infrastructure License Service, just opening a bug and will check on a fix.

    I imagine it will be ok to simply delete this service from the registry.

    I had to edit the registry by booting to the recovery tools as i had access denied errors on that registry key.


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk


    Tuesday, November 20, 2012 12:47 PM
    Moderator
  • OK it looks to me like a bug, that the transmog process is not clearing out the Software Infrastructure License Service, just opening a bug and will check on a fix.

    I imagine it will be ok to simply delete this service from the registry.


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    BTW,  is this service something related to the media streaming function that is no available on standard version?

    WHS is ready!

    Tuesday, November 20, 2012 1:21 PM
  • No i believe this service functions when the box is in it's limited 25 user mode.

    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Tuesday, November 20, 2012 1:46 PM
    Moderator
  • Hi Robert

    "I had to edit the registry by booting to the recovery tools as I had access denied errors on that registry key"
    I have encountered the same issue on my server regarding access to this key, even logged in as the administrator.

    Can ask, how you "booted into the recovery tools" and edited the registry?

    Thanks

    Joe

    Thursday, November 22, 2012 12:48 PM
  • Sure, boot the system using the ISO or DVD for Essentials / Server 12.

    Chose repair computer and then chose to use the tools.

    Use the cmd prompt to open regedit.

    Chose to load a hive, and browse the c drive to the system32\config folder and find the system hive folder.

    browse through that loaded hive to HKLM>System>CurrentControlSet1>services

    Find the service key and delete it. You might want to export first, or do a backup of the system.


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Thursday, November 22, 2012 1:51 PM
    Moderator
  • I was able to take ownership of the key and delete it directly from within regedit. HKLM>System>CurrentControlSet1>services>silsvc.

    Lets get it done...


    • Edited by jwr51 Thursday, April 18, 2013 4:40 PM
    Thursday, April 18, 2013 4:38 PM
  • i have the same issue too, i think it is an over kill to edit the registry if it is not affecting the server, but the link provided by Susan is a dead link.
    Friday, April 26, 2013 5:29 PM
  • It's not dead, you just can't get access to it.  There's still no good resolution.
    Friday, April 26, 2013 5:36 PM
  • Sure, boot the system using the ISO or DVD for Essentials / Server 12.

    Chose repair computer and then chose to use the tools.

    Use the cmd prompt to open regedit.

    Chose to load a hive, and browse the c drive to the system32\config folder and find the system hive folder.

    browse through that loaded hive to HKLM>System>CurrentControlSet1>services

    Find the service key and delete it. You might want to export first, or do a backup of the system.


    Robert Pearman SBS MVP | www.titlerequired.com | www.itauthority.co.uk

    Please explain why, when I try this, it's greyed out and I can't choose to load a hive?  It simply loads a generic hive by default and will not let me choose one.

    My system however is using a software raid, and the OS is installed on drive D from repair tools point of view. Even if I browse to D:\Windows and run regedit from there, it still does the same thing..  Thanks!

    Monday, January 20, 2014 3:33 PM
  • Never mind, I figured it out.  You must first click on the HKLM key before trying to load a module..
    Tuesday, January 21, 2014 6:35 PM