Windows Modules Installer service terminated unexpectedly?

    General discussion




    I have this problem on Windows 2008 R2, i can not install updates, programs etc. 


    I can also not install features or add roles, i get a error called "error".






    From event viewer:


    Log Name:      Application

    Source:        Application Error

    Date:          17-12-2010 13:16:33

    Event ID:      1000

    Task Category: (100)

    Level:         Error

    Keywords:      Classic

    User:          N/A

    Computer:      "removed"


    Faulting application name: TrustedInstaller.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc4b0

    Faulting module name: ntdll.dll, version: 6.1.7600.16385, time stamp: 0x4a5be02b

    Exception code: 0xc00000fd

    Fault offset: 0x00000000000529f0

    Faulting process id: 0x55c

    Faulting application start time: 0x01cb9de4379ed853

    Faulting application path: C:\Windows\servicing\TrustedInstaller.exe

    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll

    Report Id: 7c31a03e-09d7-11e0-a28b-e41f13316cda

    Event Xml:

    <Event xmlns="">


        <Provider Name="Application Error" />

        <EventID Qualifiers="0">1000</EventID>




        <TimeCreated SystemTime="2010-12-17T12:16:33.000000000Z" />




        <Security />





















    Log Name:      System

    Source:        Service Control Manager

    Date:          17-12-2010 13:16:33

    Event ID:      7031

    Task Category: None

    Level:         Error

    Keywords:      Classic

    User:          N/A

    Computer:      "removed"


    The Windows Modules Installer service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 120000 milliseconds: Restart the service.

    Event Xml:

    <Event xmlns="">


        <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />

        <EventID Qualifiers="49152">7031</EventID>






        <TimeCreated SystemTime="2010-12-17T12:16:33.876457700Z" />


        <Correlation />

        <Execution ProcessID="476" ThreadID="2800" />



        <Security />



        <Data Name="param1">Windows Modules Installer</Data>

        <Data Name="param2">1</Data>

        <Data Name="param3">120000</Data>

        <Data Name="param4">1</Data>

        <Data Name="param5">Restart the service</Data>






    Friday, December 17, 2010 12:43 PM

All replies

  • Please run the system update readiness tool,
    And post the output of the c:\Windows\Logs\CBS\CheckSUR.log back to the

    -- Mike Burr
    MS Technologies - Development - *nix
    Saturday, December 18, 2010 11:21 PM
  • I am having the same issue.

    Windows update 2436673 failed.  Upon reboot Trusted Modules Service fails.

    I cannot run Update Readiness Tool, just sticks at "Preparing the installation".

    I I restart BITS and WU service, it starts to install then hard reboots.

    Deleted the Software Distrubution folder too, same result.

    I have uninstalled anti-virus and any thing else that may interfere.

    I tried again and again a hard reboot.  Same deal when installing the update as a stand alone.

    Thursday, December 23, 2010 7:16 PM
  • I have the same issue.

    The update readiness tool can not be run either. It only shows "Searching for updates on this computer" and never goes further (I have it running since two days).

    Any help would be greatly appreviated.

    Sunday, December 26, 2010 8:31 PM
  • Finally I have been able to repair it. This here pointed me in the right direction:


    Basically I had to copy a number of files from a good 2008 R2 server to the broken one. The files are in


    I just seletect those files that were added recently on the good server and replaced the files on the broken one. Before I could copy I had to take ownership of the folder and allow write access (which afterwards I gave back to the SYSTEM user).


    Now it is working again.

    Monday, December 27, 2010 9:39 AM
  • Glad to hear you got it, if you run into the issue again and the SUR
    tool won't complete, you can try kicking it off manually based on my
    steps here,

    -- Mike Burr
    MS Technologies - Development - *nix
    Monday, December 27, 2010 9:24 PM