none
Win10 and HV 2016 Server - Can Not Remote Manage RRS feed

  • Question

  • Hello,

    So I got the great idea to install Hyper-V Server 2016 on my home domain server/test environment. In doing so I was hoping to recreate my domain and be able to host other VM's for projects I'm working on. However - The problem.

    No matter what I do I can't seem to get Hyper-V Manager to connect to the server. Obviously at this point there is no domain to connect to so both machines are running in WORKGROUP mode. The client is Windows 10 ENT x64

    The server Hyper-V has been added to the clients hosts file

    winrm is running on both boxes

    Group policy for fresh credentials for NTLM-Only and non NTLM is set up.

    The bottom steps here have been done on both client and server - https://msdn.microsoft.com/virtualization/hyperv_on_windows/user_guide/remote_host_management

    winrm s winrm/config/client '@{TrustedHosts="Hyper-V"}' has been run.

    I am at a loss. At this point the only viable option is to take a nap, if you know what I mean. Any help would be greatly appreciated.

    One last tid bit - I get different errors if I try to connect using hostname vs. IP address. Either way though it's an authentication issue.

    Tuesday, December 13, 2016 5:21 AM

Answers

  • The fix is in the last few lines of the article listed above. Both username and password have to be the same. The "connect as a different user" feature does not work while using a WORKGROUP.

    As soon as I created a local account on the Win10 box matching creds of a local user I created on the Hyper-V box.....boom goes the dynamite. I hope this helps someone else out. I spent 3 nights pounding my head against the desk trying to figure this out.

    My plan is now to setup the domain and join all of the machines and I don't think I'll have any more trouble with management.

    • Marked as answer by jlamson Wednesday, December 14, 2016 4:21 AM
    Wednesday, December 14, 2016 4:21 AM

All replies

  • Hi Jlamson,

    I tested in my lab and succeeded to manage remotely from Windows 10.

    When running the commands mentioned in the link, what did you enter as FQDN? I was using the hostname of the Hyper-V server as FQDN.

    Also re-check the group policy settings according to the guide.

    To test if the item added in hosts file is correct, ping Hyper-V host from Win 10 to see if the IP address is correct.

    Besides, also disable firewall temporarily.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, December 13, 2016 9:11 AM
    Moderator
  • For FQDN I tried both just the machine name - Hyper-V - and also - Hyper-V.local - neither of which yielded different results.

    I can ping Hyper-V and it does reflect the correct IP address, It's in the hosts file on the win10 client machine.

    I will try disabling the firewall on the client machine when I get home tonight.

    I really wish the guy that made the script that worked with everything up until this year would rewrite it for win10 and 2016. He wasn't kidding when he said it made this much easier.

    Tuesday, December 13, 2016 5:33 PM
  • So I tried with the firewll off on the Win10 client and ran into the same issues from last night. When using the IP to connect Hyper-V Manager I get this box. I click yes, it pops up again, I click yes, I click yes over and over and over again and it keeps coming back. Finally I click no and I get the next error.

    Clicking No Gives me this

    Using the Hostname Hyper-V Gives me this error.

    Here are the NTLM and Non NTLM settings in gpedit.msc. No idea why there are 30+ Entires for Non NTLM

    NTLM

    Wednesday, December 14, 2016 2:25 AM
  • Just to be double sure I ran them again on the client. Sadly, same errors after.

    Wednesday, December 14, 2016 3:07 AM
  • Leaving this here for myself. Could be the fix.

    http://www.ivobeerens.nl/2015/08/28/manage-hyper-v-in-a-workgroup-remotely/

    Wednesday, December 14, 2016 4:12 AM
  • The fix is in the last few lines of the article listed above. Both username and password have to be the same. The "connect as a different user" feature does not work while using a WORKGROUP.

    As soon as I created a local account on the Win10 box matching creds of a local user I created on the Hyper-V box.....boom goes the dynamite. I hope this helps someone else out. I spent 3 nights pounding my head against the desk trying to figure this out.

    My plan is now to setup the domain and join all of the machines and I don't think I'll have any more trouble with management.

    • Marked as answer by jlamson Wednesday, December 14, 2016 4:21 AM
    Wednesday, December 14, 2016 4:21 AM