none
Use netsh interface on remote machie gets Access Denied RRS feed

  • Question

  • I am trying to change the DNS entry on a client machine using NETSH.

    I enter netsh -r 192.168.1.23

    Then I type 'interface' at the netsh prompt and receive the following:

    WARNING: Could not obtain host information from machine: [192.168.1.23]. Some co
    mmands may not be available.
    Access is denied.

    I am a domain admin what permissions do I need?

    Saturday, August 14, 2010 1:08 AM

Answers

  • Ok, thanks guys, I didn't get a chance to try your suggestions. I discovered the answer b4 they came through. It turns out that this machine, when added to the domain did not get a DNS entry on the domain server which it seems is serving Domain Names. As a result it wastn able to fully athenticate itself. When I manually added the DNS entry to the Primary Domain Server all the permission problems I was having went away.

    So whereas your answers may have helped I don't know if I should mark them as answer or not.

    Again, thanks so much for your help.

    Prandall

    Tuesday, August 17, 2010 1:53 AM

All replies

  • Right click on CMD and then use the run as an administrator option. This should solve your problem.

    Best regards.

    Saturday, August 14, 2010 2:21 AM
  • Hi Paul,

    Agree with MS helper.

    Meanwhile,if the clients are all domain menbers ,please make sure the account you perform this command line is a menber of administrators group of remote computer.

    Thanks.

    Tiger Li

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, August 16, 2010 5:53 AM
  • Ok, thanks guys, I didn't get a chance to try your suggestions. I discovered the answer b4 they came through. It turns out that this machine, when added to the domain did not get a DNS entry on the domain server which it seems is serving Domain Names. As a result it wastn able to fully athenticate itself. When I manually added the DNS entry to the Primary Domain Server all the permission problems I was having went away.

    So whereas your answers may have helped I don't know if I should mark them as answer or not.

    Again, thanks so much for your help.

    Prandall

    Tuesday, August 17, 2010 1:53 AM
  • Even if you were able to solve your problem by adding a DNS entry, there is many commands that show access denied when you execute them if you don't use the run as an administrator option. So if you face another access denied problem try to use this command: It may solve your problem.

    Best regards.

    Tuesday, August 17, 2010 2:08 AM
  • Hi Paul,

    Glad you had solved issue, hope the suggestion we provided will helpful for to solve issue in future .

    Thanks.

    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 17, 2010 6:22 AM