locked
Can't copy and paste files using RDP session in server 2012 RRS feed

  • Question

  • I'm running windows 8, but I have also verified on a windows 7 machine as well. We have server 2012 installed on a machine I use remote desktop to get into. I cannot copy files from my local pc and use paste to get them to the server. I could do this with server 2008. Is there some setting I have to change or does this not work with server 2012?

    FYI, clipboard is checked when I open my remote desktop connection window. If I connect into a win server 2008 r2 machine from the same local machine, I can copy and paste files just fine.


    - Michael

    Monday, January 28, 2013 10:25 PM

Answers

  • Hi,

    I believe RDS clipboard redirection should be enabled by default also on Windows Server 2012. Is there perhaps is a Group Policy Object active that is configured to disable Clip Board Redirection? Either on the computer or the user OU. If not:

    You did not explicitly state this, but I'm assuming that you are running in Application Mode (meaning you did not install the RD Session Host role) ? If so please check the registry on the Windows Server 2012 destination server and look for:

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Winstations\RDP-Tcp\fDisableClip
    this should be set to 0, to make allow Clipboard Redirection

    Also check the key below:

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Addins\Clip Redirector

    This should have: 

    Name REG_SZRDPClip

    Type REG_DWORD0x00000003

    If you did run the RD Session Host role, and you have done so using a Scenario Based Deployment (Scenario Based Deployment of RDS in Windows Server 2012 ) you will have a Remote Desktop Management Service GUI available as pat of the Server Manager with which you can enable or disable ClipBoard Redirection from within a GUI on a Session Collection level or you can use PowerShell Using Powershell to install, configure and maintain RDS in Windows Server 2012


    Kind regards,
    Freek Berson
    The Microsoft Platform
    Twitter
    Linked-in
    Wortell company website

    • Marked as answer by Aiden_Cao Tuesday, February 5, 2013 2:12 AM
    Tuesday, January 29, 2013 12:10 PM

All replies

  • Hi,

    I believe RDS clipboard redirection should be enabled by default also on Windows Server 2012. Is there perhaps is a Group Policy Object active that is configured to disable Clip Board Redirection? Either on the computer or the user OU. If not:

    You did not explicitly state this, but I'm assuming that you are running in Application Mode (meaning you did not install the RD Session Host role) ? If so please check the registry on the Windows Server 2012 destination server and look for:

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Winstations\RDP-Tcp\fDisableClip
    this should be set to 0, to make allow Clipboard Redirection

    Also check the key below:

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Addins\Clip Redirector

    This should have: 

    Name REG_SZRDPClip

    Type REG_DWORD0x00000003

    If you did run the RD Session Host role, and you have done so using a Scenario Based Deployment (Scenario Based Deployment of RDS in Windows Server 2012 ) you will have a Remote Desktop Management Service GUI available as pat of the Server Manager with which you can enable or disable ClipBoard Redirection from within a GUI on a Session Collection level or you can use PowerShell Using Powershell to install, configure and maintain RDS in Windows Server 2012


    Kind regards,
    Freek Berson
    The Microsoft Platform
    Twitter
    Linked-in
    Wortell company website

    • Marked as answer by Aiden_Cao Tuesday, February 5, 2013 2:12 AM
    Tuesday, January 29, 2013 12:10 PM
  • I do almost all my work to my Windows Server 2012 VMs and physical machines via RDP.  I have not run into any issue whatsoever in cut/paste text/files.  My laptop is still running Windows 7.  Ensure that you are not changing any of the RDP settings from session to another.

    .:|:.:|:. tim

    Tuesday, January 29, 2013 1:27 PM
  • I am not changing any RDP settings as I have never touched them. I've always just opened it and logged in. The fDisapleClip was set to 0 but the name on the ClipRedirector was just REG_SZ, not REG_SZRDClip

    Should I change it to that, and if so, do I need to restart for this to take effect?


    - Michael

    Tuesday, January 29, 2013 3:13 PM
  • Michael,

    A space was missing in my reply, that obviously should have been:

    name: Name
    type: REG_SZ
    Data: RDPClip

    name: Type
    type: REG_DWORD
    Data: 0x00000003

    But again, by default this should be enabled.


    Kind regards,
    Freek Berson
    The Microsoft Platform
    Twitter
    Linked-in
    Wortell company website


    Tuesday, January 29, 2013 3:18 PM
  • Yea, if that's the case, then that is what I have.

    - Michael

    Tuesday, January 29, 2013 3:19 PM
  • And you're not using a RD Gateway server to connect to the RD Session Host? The RD Gateway also has options to restrict types of redirection.

    Kind regards,
    Freek Berson
    The Microsoft Platform
    Twitter
    Linked-in
    Wortell company website

    Tuesday, January 29, 2013 3:22 PM
  • I'm by no means an expert in this stuff so bear with me. I 'm not sure what you're asking. I'm using the built in remote desktop in windows 8 to connect into a windows 2012 server. My copy and paste works fine on win 2k8r2 servers. I went through all the settings between one session that works and one that doesn't and they are all the same.

    - Michael

    Tuesday, January 29, 2013 3:37 PM
  • I just ran a test to one of our Server 2012 Essentials servers.

    I had copied something prior to opening the RD session to the server. I received an error.

    So, I right clicked and COPY and then clicked into the remote session on Server 2012 and the file paste worked.

    Try Copy & Paste _after_ clicking into the session.

    Also, the adminstrator may have the feature blocked?

    Philip


    Philip Elder SBS MVP Blog: http://blog.mpecsinc.ca

    Thursday, January 31, 2013 3:14 PM
  • I had already been in the session. I tried keyboard and right clicking, neither work. This is set up in a virtual environment, but I have full admin rights to the server. Where would I look to unblock something?

    - Michael

    Thursday, January 31, 2013 3:20 PM
  • First place to check:

    Click Start --> MSTSC [Enter] --> Show Options --> Local Resources --> Clipboard

    Is that checked?

    Are you able to copy and paste text between a local and remote NotePad session?

    UPDATE: If working from an RDP file then right click and "Open With" and choose NotePad (Not Default). Verify that the copy and paste setting is "1" and not "0".

    Philip


    Philip Elder SBS MVP Blog: http://blog.mpecsinc.ca


    • Edited by Philip ElderMVP Thursday, January 31, 2013 3:33 PM RDP File add
    Thursday, January 31, 2013 3:32 PM
  • I already had the clipboard option checked. I can copy and paste text, just not a physical file. Here's what I did. Created a new text document and type test in it. Highlited the text and hit ctrl c. Went to my local and pasted and the text test did paste. Now, I went back to the remote machine and copied that physical file and tried to paste it to my local, no dice. It works the same vice versa too, going from local to rdp machine.

    - Michael

    Thursday, January 31, 2013 3:39 PM
  • Michael,

    Would there be any security structures in place that would block file transfers?

    It is quite possible that either an edge device or Group Policy setup would be preventing this.

    P.


    Philip Elder SBS MVP Blog: http://blog.mpecsinc.ca

    Thursday, January 31, 2013 4:38 PM
  • I don't suppose you ever got to the bottom of this? I'm seeing the same thing with a new Server 2012 RDS lab I've setup. The old clipboard copy/paste file transfer doesn't work unless you enable Drive Redirection, which isn't what I want to do. This used to work with RDS/Terminal in 2008 when they introduced advanced clipboard redirection, but it seems to be missing/disabled in 2012, unless someone is able to confirm it definitely works without Drive Redirection enabled? I haven't found any evidence to suggest it's been removed, but you can never tell when the product is this new. So far I've tried all the usual stuff - Clipboard Redirection is enabled both on the Gateway and for the RDS Collection, but no Drive Redirection and each RDSH has the fDisableClip option disabled as has been suggested. I can copy/paste text between client and server, but no files.

    Regards

    Wednesday, February 6, 2013 4:01 PM
  • Yup, exact same problem. I never did get to the bottom of this. If I ever do, I'll post the solution here. I'm fairly certain it's not some other device that's stopping the copy and paste, because we have a 2k8 server sitting in the same subnet of the same building in the data center and copy and paste works just fine on that.

    - Michael

    Wednesday, February 6, 2013 4:05 PM
  • HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Winstations\RDP-Tcp\fDisableClip
    this should be set to 0, to make allow Clipboard Redirection

    Also check the key below:

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Addins\Clip Redirector

    This should have: 

    Name REG_SZRDPClip

    Type REG_DWORD0x00000003


    I´m fighting with the same problem, before I had server 2008 R2 and copy - paste always worked from my W7 client machine to server. Now with 2012 paste is gray out, if I copy. This happends with every 2012 enviroment I´ve tried.

    I checked those registry values and they are the same as above, but I cannot paste.
    Friday, April 12, 2013 8:53 AM
  • Are you able to copy and paste text between a local and remote NotePad session?

    In fact, via notepads the text can be copied, but files not. In 2008 R2 there is this setting existing, I cannot find it in 2012. My 2012 has almost all RDS roles installed.


    Friday, April 12, 2013 12:31 PM
  • Additional info - in my case this has nothing to do with complex network or firewall blocking. Same behavior is seen where I have client and server both in same subnet withour any firewalls.

    Also, I can´t map my client´s drives to server, at server side drivers are not visible.

    Same client, same network, same domain, but using 2008 R2 server - works like a charm.
    Saturday, April 13, 2013 8:57 AM
  • 3 months no solution?

    Prakash Heda | Sr Infrastructure DBA | Advent Software | http://www.sqlfeatures.com

    Tuesday, April 23, 2013 6:28 PM
  • I have the same problem with same sympthoms. Please help.
    Friday, May 3, 2013 12:57 PM
  • Hi, does anyone have any solution to this problem?

    Tuesday, May 7, 2013 8:52 AM
  • I have same problem when I try to connect to Windows 8 workstation through TS-Gate (RD-Gate). Text successfully copy and paste through RDP but files does not.

    Then I find out that on TS-Gate was allowed only Clipboard redirection. For Windows 7 this configuration works fine. But in Windows 8 something has changed :)

    After I allowed Drive redirection -- it's a miracle -- all worked!

    After I allowed Support Plug and Play Devices -- RemoteFX Redirection worked.

    I've test this on Windows 2008 R2 TS-Gate and on Windows 2012 RD-Gate -- all work on both.

    • Proposed as answer by Langus Friday, October 27, 2017 2:23 AM
    Monday, June 24, 2013 2:43 PM
  • How do I allow drive redirection?

    - Michael

    Monday, June 24, 2013 2:49 PM
  • And if you're talking about drive redirection on my local machine, that's enabled. 

    - Michael

    Monday, June 24, 2013 2:51 PM
  • Hello guys I ran into this problem also after upgrading to server 2012 from server 2008r2 rdweb.  After reading what I could find out there I had to make sure the drives and clipboard was checked under the session collection client settings.  I would of thought that would used my local drives as redirected drives on the session but it does not.  It allows me to use copy and paste when connecting to windows explorer.  I can now copy files and folders from the rdsession to the desktop I opened it on. Hope this helps.
    Wednesday, June 26, 2013 4:07 PM
  • All,

    I struggled mightily with this also. I had many items configured and new software installed on a new instance of a server that I am setting up running Win Server 2012. I had only been able to copy files by sharing a folder on the C: drive and mapping to it from my system. I had researched folder redirection, had started many services, configured Firewall policies and ports all to no avail. Again I could use clipboard and copy between the two systems, and could copy and paste files on the system, just not to\from my Windows 7 system. I noted some things that put me down a path to resolving the initial issue but at the cost of more problems in my case. There appears to be a different manor of resolving users in remote desktop on WinServer than there used to be. If you go to the Task Manager via Ctrl + Shift + Esc, in previous version of the OS you would see that your NT user was logged on to the system, regardless of what credentials including a local Admin account that you used to log in via Remote Desktop. This appears not to be the case in Win Server 2012 and in my case it shows the Administrator account in use. This led me to wonder if there was some problem with the authentication. I ran into an error while researching the rdpclip issue something along the lines of Unable to access Active Directory to access or verify claimant. Upon researching claims and Active Directory I followed the advice of this link to set up Active Directory on the server: http://social.technet.microsoft.com/wiki/contents/articles/12370.step-by-step-guide-for-setting-up-windows-server-2012-domain-controller.aspx

    As I followed this and accepted the largely default settings I noticed that it slightly modified the system name by appending a zero to it. When I attempted to log back on to this system I had to use that modified name for the domain. I was able to log in given this and I was finally able to Paste files, but the affect of this was that it created a Volatile Environment <sysname>.<sysname>.local and more importantly removed the system from the domain by updating the Full computer name and Domain. So I had to demote the system on the Domain using the last system on the domain option. This caused the server to start presenting BSODs and the Win Server 2012 OS had to be reinstalled to recover.

    Can anyone provide some insight into why the Paste option is available via Remote Desktop only upon configuring Active Directory?

    Can any of the posters that have commented that they have not had any problems or ultimately got this working, detail if they have set up Active Directory so that a common thread can be established for those having success to contrast with those of us that can't seem to get this resolved?

    Should the discussion of Drive Redirection be construed as Folder Redirection? This is all that I have had success finding in the registry. Can anyone provide links to threads discussing how to configure Drive Redirection if that is the proper term?

    Self Help Answer: Drive Redirection is valid. This is one of many configurable items available via gpedit.msc. This is at Local Computer Policy >> Computer Configuration >> Administrative Templates >> Windows Components >> Remote Desktop Services >> Remote Desktop Session Host >> Device and Resource Redirection. Others in this area but not explicit path, include RemoteFX USB Redirection and Enable Remote Desktop Protocol 8.0.

    Thanks in advance,




    Tuesday, August 13, 2013 3:22 PM
  • I'm sure this probably won't work for everyone (or possibly anyone), but simply logging out of the remote session and logging back into it (note I actually had to log out, not just disconnect) fixed it for me.  However, when I would reconnect to the remote session before I logged out, the clipboard stopped working even on my local machine in addition to not being able to copy files/text through RDP.  Hope this helps someone.
    Tuesday, August 20, 2013 1:46 PM
  • The problem appears to be a new (fun and friendly!) security measure added in Windows Server 2012.  I was copying in an executable file (.msi).  To resolve the issue, I simply modified the extension to .txt and copied the file.

    However, I then renamed the file back to .msi and was able to copy it (after it failing twice before).

    Friday, August 23, 2013 12:01 AM
  • Ran into the same issue.

    Here is a link that might help

    opsconfig.com/?tag=rdp-file-copy-fail

    Monday, November 4, 2013 10:52 PM
  • Fixed this issue today, however, not totally satisfied.

    In GPO: if you set "Do not allow Drive Redirection" to Enabled, then Clipboard Redirection stops working. Even if you set "Do not allow Clipboard Redirection" to Disabled, it still doesn't work.

    Solution: set "Do not allow Clipboard Redirection" to Disabled and "Do not allow Drive Redirection" to Not Configured. Now clipboard redirection works. However, this allows a user to redirect drives if he enables it.

    • Proposed as answer by delianmc Tuesday, June 28, 2016 3:07 PM
    Friday, December 20, 2013 3:30 PM
  • This worked... cleared up a few other strange things as well.

    Thanks MS.

    Friday, January 10, 2014 1:25 PM
  • GLESSA: your solution worked for me:

    "In Windows Explorer type: \\servername\c$ and then copy your files from there. \\Ipaddress\c$ should work as well you just have to make sure windows firewall is open to file and print sharing between the two systems."

    I went into Windows Explorer on my source server (Win2012 R2), and entered in the address line "\\[server name]\c$, and it now appeared in the Network area under the server.  I right-clicked the file to copy on my source computer, selected COPY, went down to the c$ disk on my destination server, selected the correct folder, and right-clicked PASTE, and it worked.  It also asked me to confirm but I believe that is my security UA (whatever) settings.

    Maybe this will help.

    Mark-Allen

    ==


    -- Mark-Allen Tech, Old MS-MVP, London, UK

    Saturday, January 11, 2014 10:33 PM
  • Same issue here

    I had some users complaining of the fact that they couldn't use the clipboard or client
     drive mappings when using Server 2012.  In 2012 they took away the Remote
     Desktop Session Host configuration GUI.  Don't ask me why they did that!!!

    So after finding that after every 2012 server I built I couldn't use the clipboard.

    I ran the GPResult /H c:\temp\gpo.html to display all of the Policy settings from the
     domain.  And none of those were setting the clipboard or device redirection.

    I opened the local policy (GPEDIT.MSC) on the server and looked up the RDP session host
     settings since they removed the extremely useful GUI :(

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection.

    I found that every one of the items were listed as Not Configured.  This normally would be correct one would think.

    Apparently this has to be configured to either Enabled (force those features off) or DISABLED to force those features to work. If you leave at Not Configured that is the same as features are OFF.

    I made the Clipboard and Drive Redirection set to DISABLED. And now my clipboard and drives map correctly. I tested this on 4 different 2012 servers and every one of them didn't work, but after making this change they now work.

    • Edited by Ditka Wednesday, March 5, 2014 12:51 AM formatting
    • Proposed as answer by César Aubin Wednesday, March 15, 2017 4:04 PM
    Wednesday, March 5, 2014 12:50 AM
  • This is all due to the fact that MS has changed the behavior of the drive redirection policy. See the descriptive text of the GPO, it ís different from 2008 R2 to 2012 R2. in 2012 R2, it explicitely says that the drive redirection influences the clipboard behavior when it comes to file copying...

    Well done, MS. Now what can I do if I would like to deny drive redirection but at the same time allow copying and pasting of files viua RDP?

    2008 R2: possible. 2012 r2: not.

    Friday, March 7, 2014 12:55 PM
  • #Ronald Schilf

    Did you find any workaround to this ridiculous changed redirection policy from Microsoft.

    To be completely honest, I seriously consider this a huge BUG and a security risk.

    In the specific RDS environment I'm working on, I cannot deny the users clipboard redirection, or they have issues doing there job.

    At the same time I have to disable drive redirection or we will not pass/fulfill compliance check.

    You see my conundrum here! What the h*** was the mastermind of this change thinking.

    Hopefully there will be a hotfix released very soon.

    Sorry for the ranting, just a little "in awe" when I figured this out.

    Any help solving this is appreciated.

    Thanks.

    • Proposed as answer by Abhi Jalan Tuesday, July 8, 2014 5:07 PM
    Wednesday, April 2, 2014 12:59 PM
  • I am experiencing the copy and pasting problem as well. I am not concerned about drive redirection but need to get this copy and paste thing figured out. Also printer redirection is not working. Everything posted here is as it should be. GPO's, registry, etc. I can copy and paste if I rdp directly to the session host so it has to be something else. Thoughts? Thanks in advance.
    Friday, April 18, 2014 1:33 PM
  • Any workarounds yet? Has anyone opened a ticket or escalated this to Microsoft? 
    Wednesday, May 28, 2014 3:47 PM
  • @BrandurBHK

    No workaround. They will need to redesign this to its old state. I can imagine what the reason for this weird design is: if you think of "the lazy admin", he might want to disable the drive access but forgets the copy and paste capabilities ->security hole opened. So MS says, hey, why not help that guys...it's normally understandable to deny both and not have one denied and the other work.

    That said, still it was nicer before, of course. Still, we should have the choice. But to point out: denying drive redirection does NOT influence copy&pasting of text, just of files!


    Tuesday, June 3, 2014 3:26 PM
  • Hi!

    Yesterday i had a good day for us!. I was trying to resolve other issue in my rds enviroment when i found out one possible workaround for this problem.

    "¿what can I do if I would like to deny drive redirection but at the same time allow copying and pasting of files viua RDP?"

    Try to delete this entry in REGEDIT.

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\SessionInfo]

    Then you only have to make a GPO that deletes in all sesions this entry ( you can choose your scope)

    • Proposed as answer by Thias Witt Thursday, March 26, 2015 2:41 PM
    Wednesday, June 4, 2014 11:28 AM
  • Hi Eugenio.

    Please explain how that should work. It does not for me (2012 R2) after deleting, logging out and in again, no change in behavior.

    Wednesday, July 9, 2014 6:14 AM
  • I still have the same problem as the original post; nothing to do with RDP or clipboards, I cannot copy from virtual DVD drive to \\otherserver\c$\temp if the file is .msi or .msp - Server 2008R2 appears to block this copy.
    Tuesday, July 15, 2014 3:43 PM
  • #MisterD2000

    Can you copy from %SystemDrive%\temp\XXX.msi/msp to \\otherserver\c$\temp ?

    Tuesday, July 15, 2014 4:13 PM
  • faking Microsoft, nothing works !  
    Tuesday, January 13, 2015 9:26 AM
  • @MpDay, Thanks !!!
    • Edited by Gamleur84 Wednesday, April 15, 2015 9:37 PM
    Wednesday, April 15, 2015 9:36 PM
  • Thanks this works, however, to enable file copy, disable this config: fDisableCdm (Do not allow drive redirection). Text copied from gpedit.mmc.

    "If you disable this policy setting, client drive redirection is always allowed. In addition, Clipboard file copy redirection is always allowed if Clipboard redirection is allowed."

    • Proposed as answer by jcontrer Tuesday, February 5, 2019 3:32 AM
    Tuesday, August 18, 2015 9:39 AM
  • Had to activate "drive redirection" in the 2012 R2 collection properties. This makes not only local drives accessible, but also copy and paste working for files.

    HTH

    Franz

    Thursday, October 15, 2015 1:19 PM
  • This works for me by disabling both the Clipboard and Drive Redirection for both Session Host Server.
    Wednesday, November 4, 2015 11:20 PM
  • I know this is old but I think other people still have this problem. 

    This works. 

    • Run RDP. 
    • Show options. 
    • Local Resources. 
    • More
    • Drives: OS Disk C: 

      You have to use the C drive of your current computer in your remote session to be able to copy and paste the file into Server 2k12 through rdp. Reference: hacked site



    • Edited by MrMikeWilson Wednesday, November 18, 2015 3:10 PM
    Wednesday, November 18, 2015 3:09 PM
  • The way I fixed our problem was to change the RD CAP Policy on the Gateway server. Ensure that you have not disabled any device you would like redirected, like I had.

    Procedure is as follows:

    1. In Server Manager select Remote Desktop Services > Servers

    2. Right Click your Gateway server from the list and select RD Gateway Manager

    3. Expand Your Server Name Group

    4. Expand Policies

    5. Select Connection Authorization Policies

    6. Right Click your policy name and select Properties

    7. Click the Device Redirection tab

    8. Make your selections, click Apply and OK

    You should be good to go...

    • Proposed as answer by DukeOfAwesome Tuesday, December 29, 2015 6:52 AM
    Tuesday, December 29, 2015 6:51 AM
  • Unfortunately I don’t know why rdpclip stops working nor how to fix it permanently; however, there is a way to make it easier if it happens often.

    • Create a new bat file and call it whatever you want say, clipboard.bat.
    • Write the following two commands on separate lines in the new bat file
      • Taskkill.exe /im rdpclip.exe
      • Rdpclip.exe
      • Save the bat file and drag it into the toolbar quick launch section

    Now whenever your copy and paste operation fails to restore it, all you need to do is click this new batch file which will kill rdpclip and restart it. Still a workaround but at least it’s a quick procedure.

    Saturday, February 6, 2016 8:26 AM
  • worked for me.  thanks.
    Monday, May 9, 2016 11:58 PM
  • Your solution is genius for my problem.

    I have not tried to drag and drop or cut and paste full files for years as I would redirect a drive to accomplish that. Seems it might have used to work between 2 winxp computers for me

    What I lost about 3 years ago (it is now 2016) was the ability to use the clipboard between my Server 2008r2 and any remote client.  My 2008 did not suffer the same issues.

    Have tried everything I could think of and periodically search the net to see if anyone else has resolved the issue.   Once I made a change and it came back and the following day it was gone again.

    I was surprised to find the reg setting was set to enabled even though there is no domain policy or local group policy causing that. I tried toggling those settings back and forth and zip progress.

    Then I manually edited the registry and STILL NO JOY.

    Tonight I read all the way down to your post.  "I'm sure this probably won't work for everyone..." and I figured I should try it.

    Absolutely amazed.  Problem solved. I believe it may be a combination of getting the 1 out of the registry setting to disable clipboard AND log out log in.

    So you can remove the "(or possibly anyone)" thought because it resolved my issue and I am very grateful to you for posting it.  No more interoffice message of text to a different computer so I can RDP over to that one from my remote site and capture text I should just be able to cut and paste.


    Al Coberly

    Monday, September 26, 2016 3:43 AM
  • Has anyone tried Hotfix 3042841?  It claims to fix "Files cannot be copied when drive redirection is enabled in Windows 8.1 or Windows Server 2012 R2". Possibly going to give it a shot. I just get a bit nervous with some hotfixes. 

    https://support.microsoft.com/en-us/help/3042841/files-cannot-be-copied-when-drive-redirection-is-enabled-in-windows-8.1-or-windows-server-2012-r2

    Tuesday, April 11, 2017 10:51 PM
  • Can confirm that RDPClip depends in some way on the availability of Drive redirection.

    Changed our GPO to

    "Do not allow Clipboard Redirection" to Disabled
    "Do not allow Drive Redirection" to Disabled

    and RDP Filetransfer over clipboard works again. This is just a 2012 Issue. 2008 does not have the requirement of Drive redirection to be enabled.

    Sure this is only intended as "improvement of service and security"...

    Friday, August 4, 2017 1:08 PM
  • Finally an answer for my problem! As soon I allowed drive redirection it worked!
    • Proposed as answer by IrfanHussainM Monday, May 7, 2018 11:36 AM
    • Unproposed as answer by IrfanHussainM Monday, May 7, 2018 11:36 AM
    Wednesday, March 28, 2018 5:49 PM
  • If you have already checked Clipboard under Local Devices and Resources, but are still unable to copy and paste, uncheck it and connect to Remote Desktop. Now log off Remote Desktop, check the Clipboard option again under Local Devices and Resources, and reconnect to Remote Desktop. Now you will be able to copy and paste.
    Monday, May 7, 2018 11:37 AM
  • :-)

    A customer of mine had been facing the same issue and it turned out that he had the "Do not allow Drive Redirection" parameter enabled. I've disabled the parameter, logged out, logged in, tried to copy a file from their desktop and it worked like a charm.

    Thank you so much!


    V.Melnik

    Wednesday, October 17, 2018 10:31 PM