none
DHCP mshome.net

    Question

  • HI guys,

     

    Here is my problem:

    I have setup a WDS server on a Windows 2008R2 server. I have been able to deploy servers but all my attempt to join computers to the domain failed.

    I think the reason is that i have problem with my DHCP scope. The dhcp server is set locally on my WDS server. The WDS server has two NICs. The first one is configured on my AD domain and i have shared this network connection. The second NIC is configured on my deployment VLAN and thats were the DHCP server is listening.

    The weird thing is that when i install the DHCP server i cannot manage it at all. The server shows up with a name like hostname.mshome.net i can restart it but i cannot configure the scope at all. So my clients get a dhcp address, i can deploy images but i cannot configure the scope so they can get a valid default gateway, hence they cant talk with any DC and any attempt to join the domain fails.

    I tried reinstalling DHCP even though i can give the default gateway during role installation, the configuration fails.

    Why this mshome.net domain?

     

    I tried to reinstall the DHCP server without binding yet NICs. This is the error message i receive:

    DHCP Server: Installation succeeded with errors


    <Error>: Attempt to configure DHCP Server failed with error code 0x80074E54. The scope parameters are incorrect. Either the scope already exists or its subnet address and mask is inconsistent with the subnet address and mask of an existing scope.
    Please refer to the full log at: 'C:\Users\etcapacc\AppData\Local\Temp\2\ServerManager.log'
     
    The error in ServerManager.log:
     
    4568: 2010-04-12 16:45:48.196 [DHCP]                      Begin DhcpCreateSubnet, subnetAddress = 176294144, subnetInfo = {Subnet Address = 176294144, Subnet Mask = 4294967040, Subnet Name = Deployment VLAN, Primary Host = {Ip Address = 176294398, Net Bios Name = 0, Host Name = 0}, Subnet State = DhcpSubnetEnabled}
    4568: 2010-04-12 16:45:48.196 [DHCP] Error (Id=0) End DhcpCreateSubnet, error code = 20052

    Apparently problem with scope.
     
    I have a NIC with IP 10.130.9.254 thats were the DHCP should listen, the other IP is 10.130.12.x it is my production VLAN and DHCP should NOT listen there.
     
    I try to create the following scope:

    DHCP Server


    Network Connection Bindings None

    IPv4 DNS Settings

    DNS Parent Domain eu.acme.com

    DNS Servers 10.130.12.120, 10.130.12.100

    WINS Servers 10.130.12.100, 10.130.12.120

    Scopes

    Name Deployment VLAN

    Default Gateway 10.130.9.254

    Subnet Mask 255.255.255.0

    IP Address Range 10.130.9.1 - 10.130.9.100

    Subnet Type Wired (lease duration will be 8 days)

    Activate Scope Yes

    DHCPv6 Stateless Mode Enabled

    IPv6 DNS Settings

    DNS Parent Domain eu.acme.com

    DNS Servers fec0:0:0:ffff::1, fec0:0:0:ffff::2

    DHCP Server Authorization Authorize using credentials associated with NT-WITCH\etcapacc

    Tuesday, April 13, 2010 5:58 AM

Answers

  • Well I found, at least, a little quick fix to the mysterious "mshome.net" default:  Change the "hosts.ics" file in same directory as the old "hosts" file in path C:\Windows\System32\Drivers\etc.  The next time you go for that correct Authorized domain name, it sticks!  That fixed it for me:  I was able to establish my correct DHCP straight-away!  Lucky, lucky, me.  :-)    -But I'll really be happy when I find out what other little goodies are necessary to get my Server 2012 connecting correctly to the internet (not just Pinging)- good grief.  :-/
    • Proposed as answer by Jean Brandão Saturday, December 14, 2013 11:33 AM
    • Marked as answer by Thomas Vitoz Tuesday, May 27, 2014 10:29 AM
    Friday, January 25, 2013 3:05 AM

All replies

  • I am also having this issue.

    Setting up Windows 2008r server DHCP shows "servername.mshome.net" instead of my domain name.

    I have verified my network setting are accurate.

    I have deleted and recreated the DHCP service and deleted the DHCP directory (in the event it holds old entries) 

    but every time I get servername.mshome.net and everything is greyed out.

    Thank you.

    • Proposed as answer by Lucky-Lucky-Me Friday, January 25, 2013 2:58 AM
    • Unproposed as answer by Lucky-Lucky-Me Friday, January 25, 2013 2:58 AM
    Monday, December 10, 2012 8:51 PM
  • Well I found, at least, a little quick fix to the mysterious "mshome.net" default:  Change the "hosts.ics" file in same directory as the old "hosts" file in path C:\Windows\System32\Drivers\etc.  The next time you go for that correct Authorized domain name, it sticks!  That fixed it for me:  I was able to establish my correct DHCP straight-away!  Lucky, lucky, me.  :-)    -But I'll really be happy when I find out what other little goodies are necessary to get my Server 2012 connecting correctly to the internet (not just Pinging)- good grief.  :-/
    • Proposed as answer by Jean Brandão Saturday, December 14, 2013 11:33 AM
    • Marked as answer by Thomas Vitoz Tuesday, May 27, 2014 10:29 AM
    Friday, January 25, 2013 3:05 AM
  • Muito bom, consegui restaurar a capacidade de configuração do meu escopo, simplesmente editando o arquivo e reativando o servidor DHCP.

    Muito Obrigado!!!

    Saturday, December 14, 2013 11:35 AM