locked
W2k8 R2 + AD integrated DNS -- nslookup response "Default Server Unknown, Address ::1" RRS feed

  • Question

  • Hi - The domain has two 2008 R2 DCs with DNS installed on both.  DNS is AD integrated.  On each DC, the DNS server settings for its NIC point to itself and the other DC respectively.  As far as I can verify, EDNS0 is disabled, PTR records exist for both servers in the zone.  However, only on one of the servers, when I do a nslookup, I get the response listed below:

    C:\Windows\system32>nslookup
    Default Server:  UnKnown
    Address:  ::1

    Also, on this server, if I were to uncheck the IPv6 protocol in the TCP/IP properties of the NIC, this issue goes away.  But I am not sure if this is the correct fix.  Incidentally all DNS resolution works fine in the domain on the clients.

    Any help is greatly appreciated!

     

     

     

     

    Thursday, January 13, 2011 4:14 PM

Answers

  • Actually I had the same problem and it turned out that the address was entered into the settings for IPv6 on the adapter. I set it to Obtain DNS Server address automatically for v6 and it cleared up.
    • Marked as answer by jatdesi Friday, January 14, 2011 5:07 PM
    Friday, January 14, 2011 5:02 PM

All replies

  • To correct this you need to set up a reverse lookup zone on your DNS servers.  Populate the lookup zone with PTR records.  To resolve this you need to add the records for you DNS servers.

     


    Visit: anITKB.com, an IT Knowledge Base.
    Friday, January 14, 2011 1:04 AM
  • Hi,

    Post your complete TCP/IP setting by using ipconfig/all.

     

    Check the preferred DNS is not 127.0.0.1.

     

    To verify the DNS check this article.

    http://technet.microsoft.com/en-us/library/cc959303.aspx

     

    Thanks.

    Friday, January 14, 2011 6:01 AM
  • When you open an NSLOOKUP console, the app will attempt to provide you with the DNS hostname for the DNS server.  It derrives this information from the reverse lookup zone as I indicated in my earlier posting.

     


    Visit: anITKB.com, an IT Knowledge Base.
    Friday, January 14, 2011 1:13 PM
  • JM - The reverse zone exists in the domain and has an entry for the DNS server.  If I do a "ping -a IP_of_affected_server" it resolves correctly.
    Friday, January 14, 2011 4:26 PM
  • MYousufAli - You are on to something as you can see below (see the DNS Server setting section):

     

    C:\Windows\system32>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : DC1
       Primary Dns Suffix  . . . . . . . : domain.com
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : domain.com

    Ethernet adapter NIC 1:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : HP NC373i Multifunction Gigabit Server Adapter #2
       Physical Address. . . . . . . . . : 00-1B-78-73-C7-A6
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::2c33:36b9:dcae:386e%13(Preferred)
       IPv4 Address. . . . . . . . . . . : 10.10.1.23(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . : 10.10.1.1
       DHCPv6 IAID . . . . . . . . . . . : 218110840
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-11-90-2F-00-1B-78-73-C7-86
       DNS Servers . . . . . . . . . . . : ::1
                                           10.10.1.23
                                           10.10.1.22
       ---->  This is DC2 for the domain
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{B0E7756C-89DF-4489-A97A-017DECEF006A}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

     

     

    I guess somewhere in the registry the setting for a DNS server to ::1 needs to be removed.

     

    Friday, January 14, 2011 4:32 PM
  • Actually I had the same problem and it turned out that the address was entered into the settings for IPv6 on the adapter. I set it to Obtain DNS Server address automatically for v6 and it cleared up.
    • Marked as answer by jatdesi Friday, January 14, 2011 5:07 PM
    Friday, January 14, 2011 5:02 PM
  • mpalecek - Bingo!
    Friday, January 14, 2011 5:08 PM
  • Extremely helpfull. Same mysterious issue on my server.
    golden
    Wednesday, March 30, 2011 3:45 AM
  • Here's another way to stop the ::1 DNS entry:

    How to Disable RSS TCP Chimney Feature and IPv6 & Instructions to remove that "::1" IPv6 DNS address that shows up in an ipconfg /all
    Should I Disable IPv6? No, Microsoft no longer recommendeds disabling IPv6. 
    http://msmvps.com/blogs/acefekay/archive/2010/05/27/how-to-disable-rss-tcp-chimney-feature-and-ipv6.aspx

    Ace

     


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007 & Exchange 2010, Exchange 2010 Enterprise Administrator, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    Wednesday, March 30, 2011 4:05 AM
  • very, very, very interesting. I had the same error on a 2008 AD DS lab I setup. What's puzzling is that I disabled IP v6 before installing DNS on the box. So after reading MPalecek post I reenabled IP v6, went to the properties and changed it to obtain information automatically. Oh btw there was a wierd entry of "::01" as the DNS in IP v6. I applied the settings and disabled IP v6 again. Done! No more "Uknown" server. Also, a PTR entry was added in the Reverse Lookup zone for the server.

    Ncruz1980

    Monday, March 5, 2012 3:24 AM
  • very, very, very interesting. I had the same error on a 2008 AD DS lab I setup. What's puzzling is that I disabled IP v6 before installing DNS on the box. So after reading MPalecek post I reenabled IP v6, went to the properties and changed it to obtain information automatically. Oh btw there was a wierd entry of "::01" as the DNS in IP v6. I applied the settings and disabled IP v6 again. Done! No more "Uknown" server. Also, a PTR entry was added in the Reverse Lookup zone for the server.

    Ncruz1980

    Actually, you don't want to disable IPv6. Microsoft has intergrated with the OS, and may break things if you do. Read the following for specifics:

    .

    Arguments against disabling IPv6
    Demoire, [MSFT], 24 Nov 2010 12:37 AM
    http://blogs.technet.com/b/netro/archive/2010/11/24/arguments-against-disabling-ipv6.aspx

    .

    The Cable Guy - Support for IPv6 in Windows Server 2008 R2 and Windows 7, by Joseph Davies, Microsoft, Inc.
    Quoted by Joseph Davies, MSFT:
    "IPv6 is a mandatory part of the Windows operating system and it is enabled and included in standard Windows service and application testing during the operating system development process. Because Windows was designed specifically with IPv6 present, Microsoft does not perform any testing to determine the effects of disabling IPv6. If IPv6 is disabled on Windows Vista, Windows Server 2008, or later versions, some components will not function. "Moreover, applications that you might not think are using IPv6—such as Remote Assistance, HomeGroup, DirectAccess, and Windows Mail—could be."
    http://technet.microsoft.com/en-us/magazine/2009.07.cableguy.aspx

    .

    NSLOOKUP Behavior:

    As far as nslookup "unknown server" message (note: This is NOT an error), it's just trying to resolve the IP address nslookup is using in your reverse zone, but if you do not have a reverse zone for that subnet, or if you do and you do not have a PTR (reverse entry), nslookup is simply saying, I can't find the name, but let's move on and enter your query so I can resolve it for you.

    If you do not want the "::1" address to show (after you re-enable IPv6), you can simple either change the protocol order so IPv4 is chosen first, or simply remove the "::1" out of the NIC, IPv6 properties.

    .

    Read my blog above which has specifics, which I pasted below for your convenience, please:

    How to Disable RSS TCP Chimney Feature and IPv6 & Instructions to remove that "::1" IPv6 DNS address that shows up in an ipconfg /all
    Should I Disable IPv6? No, Microsoft no longer recommendeds disabling IPv6.
    http://msmvps.com/blogs/acefekay/archive/2010/05/27/how-to-disable-rss-tcp-chimney-feature-and-ipv6.aspx 

    .

    If you want to change the protocol order so IPv4 is the preferred protocol, follow the instructions in the following link. You can even use the MrFixIt, which will do it for you, eliminating any mistakes:

    How to disable IP version 6 (IPv6) or its specific components in Windows 7, in Windows Vista, in Windows Server 2008 R2, and in Windows Server 2008
    http://support.microsoft.com/kb/929852 

    .


    Ace Fekay
    MVP, MCT, MCITP Enterprise Administrator, MCTS Windows 2008 & Exchange 2007 & Exchange 2010, Exchange 2010 Enterprise Administrator, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Complete List of Technical Blogs: http://www.delawarecountycomputerconsulting.com/technicalblogs.php

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBookTwitterLinkedIn



    Monday, March 5, 2012 5:12 AM
  • Thank you for the information. Reverting my changes now. Thank you so much.

    Ncruz1980

    Monday, March 5, 2012 5:26 AM
  • You are welcome!

    .


    Ace Fekay
    MVP, MCT, MCITP Enterprise Administrator, MCTS Windows 2008 & Exchange 2007 & Exchange 2010, Exchange 2010 Enterprise Administrator, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Complete List of Technical Blogs: http://www.delawarecountycomputerconsulting.com/technicalblogs.php

    This posting is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Monday, March 5, 2012 5:53 AM
  • Finally I found your solution after spending 2 hours! Thank you.

    Monday, June 25, 2012 6:26 AM
  • Finally I found your solution after spending 2 hours! Thank you.

    Glad to hear we were helpful!

    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008/R2, Exchange 2007 & Exchange 2010, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Complete List of Technical Blogs: http://www.delawarecountycomputerconsulting.com/technicalblogs.php

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Wednesday, June 27, 2012 6:39 PM
  • Hello!

    Do you know why this could happen? I had the same issue unexpected during the weeked and the solution was change the IPv6 properties.

    Thanks,

    Tuesday, November 27, 2012 11:31 PM
  • Marcelo,

    Did the above help you?

    Or you can simply change IPv6 to automatically get an IP and DNS from DHCP to take care of it.


    Ace Fekay
    MVP, MCT, MCITP/EA, MCTS Windows 2008/R2 & Exchange 2007, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Technical Blogs & Videos: http://www.delawarecountycomputerconsulting.com/

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Wednesday, November 28, 2012 5:04 AM
  • Dear, I had same problem, I disable IP6 or do somethings but it's seem didnt change anything.

    Default server: Unknown

    I has been added a pointer to DC.

    ----------------------------------------------------------

    Visit my website: http://hyundaioto.com.vn

    Monday, December 10, 2012 4:04 AM
  • Dear, I had same problem, I disable IP6 or do somethings but it's seem didnt change anything.

    Default server: Unknown

    I has been added a pointer to DC.

    ----------------------------------------------------------

    Visit my website: http://hyundaioto.com.vn

    The post marked as Answer by "mpalecek" on 1/14/2011, provides the answer on how to take care of this.

    Also, you do not want to disable IPv6. If disabled, it will cause problems with the operating system.


    Ace Fekay
    MVP, MCT, MCITP/EA, MCTS Windows 2008/R2 & Exchange 2007, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Technical Blogs & Videos: http://www.delawarecountycomputerconsulting.com/

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Monday, December 10, 2012 6:04 AM
  • Actually I had the same problem and it turned out that the address was entered into the settings for IPv6 on the adapter. I set it to Obtain DNS Server address automatically for v6 and it cleared up.

    You are the man. Even though my IPv6 was disabled under network settings, it was still using this entry to resolve?!?!  I had to enable IPv6, go into the properties for IPv6, change the DNS setting to automatically acquire DNS server, save, and then disable IPv6 to make this go away.  Why would this be the default setting for server 2008 r2 on a brand new build?  I did the setup and I'm 100% sure I didn't set it.  Thanks for the post, you saved me some serious troubleshooting.  With IPv6 disabled, I probably wouldn't have gone into the settings to look at that for quite a while.

    Jeff

    Thursday, August 8, 2013 2:20 AM
  • Thanks boss   
    Sunday, April 5, 2015 4:34 PM
  •  I had same issue. deleted the dns address in IP6 and the issue was resolved .. thx
    Thursday, April 23, 2015 2:04 PM
  • Hi,
    Also I had this same problem. Managed to solve accessing the properties of the network networks / IPV6 protocol / And choosing the option: Get the DNS server address automatically.
    Then simply run the NSLOOKUP command.
    You must have a Reverse zone configured as well.
    I hope this helps



    Tuesday, October 27, 2015 11:22 AM
  • That is what corrected it for me.  Would have never thought to look there.  Thanks!! Email queue immediatedly emptied.
    Thursday, July 14, 2016 5:24 PM