none
NSLOOKUP resolves same ip address for every time

    Question

  • dear all,

    please help me to solve my problem in my domain...it is with nslookup .. whenever i tried to nslookup for  ".com" address, every time its resolving same wrong IP address, when i tried to resolve ".co.in" or ".net" or any other address its resolving correct IP address...  as shown..please help me to resolve this issue....

    thanks in advance.

     

    C:\Documents and Settings\host>nslookup
    Default Server:  server.domain.co.in

    Address:  10.126.130.23

    > google.com
    Server:  DC.Domain.co.in
    Address:  10.126.130.23

    Non-authoritative answer:
    Name:    com.CO.IN
    Address:  96.125.163.8
    Aliases:  google.com.CO.IN

    > yahoo.com
    Server:  DC.Domain.co.in
    Address:  10.126.130.23

    Non-authoritative answer:
    Name:    com.CO.IN
    Address:  96.125.163.8
    Aliases:  yahoo.com.CO.IN

    > ping.com
    Server:  DC.Domain.co.in
    Address:  10.126.130.23

    Non-authoritative answer:
    Name:    com.CO.IN
    Address:  96.125.163.8
    Aliases:  ping.com.CO.IN

    > google.co.in
    Server:  DC.Domain.co.in
    Address:  10.126.130.23

    Non-authoritative answer:
    Name:    google.co.in
    Address:  173.194.38.120

    > yahoo.co.in
    Server:  DC.Domain.co.in
    Address:  10.126.130.23

    Non-authoritative answer:
    Name:    yahoo.co.in
    Addresses:  68.180.206.184, 203.84.219.114

    > zedge.net
    Server:  DC.Domain.co.in
    Address:  10.126.130.23

    Non-authoritative answer:
    Name:    zedge.net
    Address:  74.54.84.200

    >

     

    And my ipconfi result is


    C:\Documents and Settings\HOST>ipconfig /all

    Windows IP Configuration

            Host Name . . . . . . . . . . . . : HOST
            Primary Dns Suffix  . . . . . . . : DOMAIN.CO.IN
            Node Type . . . . . . . . . . . . : Unknown
            IP Routing Enabled. . . . . . . . : No
            WINS Proxy Enabled. . . . . . . . : No
            DNS Suffix Search List. . . . . . : DOMAIN.CO.IN

    Ethernet adapter Local Area Connection:

            Connection-specific DNS Suffix  . :
            Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
            Physical Address. . . . . . . . . : 00-14-5E-1E-1D-1E
            Dhcp Enabled. . . . . . . . . . . : No
            IP Address. . . . . . . . . . . . : 10.126.132.236
            Subnet Mask . . . . . . . . . . . : 255.255.255.0
            Default Gateway . . . . . . . . . : 10.126.132.1
            DNS Servers . . . . . . . . . . . : 10.126.130.23
                                                        10.126.130.24

    C:\Documents and Settings\HOST>
    Friday, February 24, 2012 4:10 AM

Answers

  • Hi,

    How about we input fully quality name of the query with a trailing dot? Does the domain.co.in is a child domain of co.in domain?

    This usually appears when AD zone name has a three level name. And nslookup will use the suffix to devolve with the name of co.in. If you do not have a parent domain zone co.in, please try to create one and leave it no A record. Hope it helps.


    Best Regards,
    Aiden


    Aiden Cao

    TechNet Community Support

    Thursday, March 01, 2012 2:09 AM
    Moderator

All replies

  • Hi,

    have you configured your DNS-Server to forward request to another dns-server, which your server cannot resolve?

    Have you configured conditional forwarders on your dns?

    Have you the error on other clients? If so, try to clear cache on your dns. Type on cmd: dnscmd /clearcache.

    Kind regards,

    M.Hivner

    • Marked as answer by sultan.ms Tuesday, February 28, 2012 6:20 AM
    • Unmarked as answer by sultan.ms Tuesday, February 28, 2012 6:28 AM
    Friday, February 24, 2012 7:11 AM
  • 1. Make sure that tha DNS cache on client computer where you try to do test is deleted and the refresh has been done

    ipconfig /flushdns

    ipconfig /registerdns

    2. Make sure you have correct DNS settings in network adapter properties.

    3. Make sure that the DNS server has proper forward and reverse settings

    4. Reveal what mechanism do you you for host outside your domain.

    5. Test authoritative response like this one (my example, use your settings)

    nslookup -norec -type=SOA felk.cvut.cz 147.32.80.9

    Friday, February 24, 2012 10:48 AM
  • Hi,

    Have you try to add “.” behind the external name? Such as google.com. , can this resolve the correct IP address?

    From the output, it appears that the DNS suffix has been attached before you submit the DNS query for that name. Firstly, clear DNS cache on both DNS server and clients. For more detailed information, please refer to the following article about domain suffix search list.

    How to configure a domain suffix search list on the Domain Name System clients
    http://support.microsoft.com/kb/275553
    http://support.microsoft.com/kb/294785/

    Also, please check the same issue resolved under the below thread.

    http://social.technet.microsoft.com/Forums/en-US/winserverNIS/thread/80727bcf-644e-4746-be69-e7fd3464f64e


    Best Regards,
    Aiden


    Aiden Cao

    TechNet Community Support

    Monday, February 27, 2012 7:11 AM
    Moderator
  • Hello,

    Please check the used DNS suffixes. please also tryu changing the used public DNS server. You can try using 4.4.4.2 and checking results. Please also delete the cache of your DNS server using dnscmd /clearcache command.


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.   

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    • Marked as answer by sultan.ms Tuesday, February 28, 2012 6:21 AM
    • Unmarked as answer by sultan.ms Tuesday, February 28, 2012 8:00 AM
    Monday, February 27, 2012 2:10 PM
  • Hi M.Hivner,

    i tried cmd: dnscmd /clearcache and my problem solved for while....


    C:\Program Files\Support Tools>dnscmd /clearcache
    . completed successfully.
    Command completed successfully.

    C:\Program Files\Support Tools>nslookup
    Default Server:  DOMAIN.CO.IN
    Address:  10.126.130.23

    > google.com
    Server:  DOMAIN.CO.IN
    Address:  10.126.130.23

    DNS request timed out.
        timeout was 2 seconds.
    Non-authoritative answer:
    Name:    google.com
    Addresses:  74.125.71.113, 74.125.71.138, 74.125.71.139, 74.125.71.100
              74.125.71.101, 74.125.71.102

    > google.com
    Server:  DOMAIN.CO.IN

    Address:  10.126.130.23

    Non-authoritative answer:
    Name:    com.CO.IN
    Address:  96.125.163.8
    Aliases:  google.com.CO.IN

    >

    Again same problem.......

    and i tried

    http://support.microsoft.com/kb/275553
    http://support.microsoft.com/kb/294785/ also....

    Thanks&regards,

    sultan.

    • Edited by sultan.ms Tuesday, February 28, 2012 6:35 AM
    Tuesday, February 28, 2012 6:32 AM
  • Hi,

    How about we input fully quality name of the query with a trailing dot? Does the domain.co.in is a child domain of co.in domain?

    This usually appears when AD zone name has a three level name. And nslookup will use the suffix to devolve with the name of co.in. If you do not have a parent domain zone co.in, please try to create one and leave it no A record. Hope it helps.


    Best Regards,
    Aiden


    Aiden Cao

    TechNet Community Support

    Thursday, March 01, 2012 2:09 AM
    Moderator