none
Microsoft-Windows-Folder Redirection Error 502. CSC database locked by another user

    Question

  • Dear all,

    We are finalizing our Windows 7 migration where we migrated 500+ clients. In our enterprise concept we implemented RUP (Roaming User Profiles) and Redirected Folders for all users. The Redirected Folders have been by enabled by a single GPO which redirects all folders from AppData to Searches \\servername.domain.name\documents$\%username%.

    Problem:
    The RUP and Redirected folders solution works fine until a new user wants to logon. This new user has been migrated to RUP and Redirected on another system and he just wants to work on another workplace or gets a temporary pc. What happens is that redirected folders do not work. The user gets a message that the folder is not reachable and desktop is empty.

    Troubleshooting:
    Soon I found out that something was being locked. If we used a user account which had working Redirect Folders than this worked for that user. An event of 10 was logged in OfflineFiles area of EventViewer to reconnect the path which was configured in the GPO.

    This is example screenshot. It says "Error on Open Folder. \\server.domain.name\documents$\%username%\Desktop refers to a location that is unavailable. It could be on a hard disk on this computer, or a on a network. Check to make sure that the disk is properly inserted, or that you are connected to the Internet or your network, and then try again. If it still cannot be located, the information might have been moved to a different location."

    These symptoms happen randomly and not on all workstations. The pain here is when it happens on a portable computer. For desktop we disabled the "Disable Offline Files' in "Manage Offline Files" control panel and then reboot. After the reboot the folders are directed and it works without these errors... On portable computer we can't use this work around as they need to work offline.

    If I connect to the share without the FQDN like \\servername\documents$\%username%\Desktop than this works fine and user can access all folders. When I try the FQDN path which is configured in the GPO to redirect user to like \\servername.domain.name\documents$\%username%\Desktop than it fails with this message. I personally think because the C:\Windows\CSC database is locked by the previous user who has been logged on this system.

    An example of the event generated in the Applications Event viewer part (I removed some username and server path):

    Log Name:      Application
    Source:        Microsoft-Windows-Folder Redirection
    Date:          1-2-2011 17:40:11
    Event ID:      502
    Task Category: None
    Level:         Error
    Keywords:     
    User:          domain\ivan
    Computer:      computer.domain.name
    Description:
    Failed to apply policy and redirect folder "Videos" to "\\servername.domain.name\documents$\ivan\Documents\My Videos".
     Redirection options=0x1001.
     The following error occurred: "Can not create folder "\\\servername.domain.name\documents$\ivan\Documents\My Videos"".
     Error details: "Access is denied.
    ".
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Folder Redirection" Guid="{7D7B0C39-93F6-4100-BD96-4DDA859652C5}" />
        <EventID>502</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2011-02-01T16:40:11.486983400Z" />
        <EventRecordID>2754</EventRecordID>
        <Correlation ActivityID="{3211E6FB-2801-456D-BE6E-66AAE150A4DC}" />
        <Execution ProcessID="968" ThreadID="5856" />
        <Channel>Application</Channel>
        <Computer>computer.domain.name</Computer>
        <Security UserID="S-1-5-21-3705223304-2632712944-1292073641-26755" />
      </System>
      <EventData Name="EVENT_FDEPLOY_FailedToApplyPolicy">
        <Data Name="FromFolder">Videos</Data>
        <Data Name="ToFolder">\\servername.domain.name\documents$\ivan\Documents\My Videos</Data>
        <Data Name="Options">0x1001</Data>
        <Data Name="Error">Can not create folder "\\servername.domain.name\documents$\ivan\Documents\My Videos"</Data>
        <Data Name="ErrorDetails">Access is denied.
    </Data>
      </EventData>
    </Event> 

    Something like this I see in the Application Eventviewer:

     

    Environment:
    Windows 7 Enterprise client with patches until 1-Nov-2010
    Windows Server 2008 R2 for the Documents$ share
    Windows Server 2003 R2 as the domain controller

    I have tried all different option even to rebuild the CSC database but this also was not helping. I hope we are not dealing with a bug.

    Any help is much appreciated.

     


    Best regards, Ivan Versluis http://www.networknet.nl
    Monday, February 7, 2011 4:51 PM

All replies

  • Hi,

     

    According to the following error message, this issue mostly can be caused by the incorrect permissions settings.

     

    The following error occurred: "Can not create folder "\\\servername.domain.name\documents$\ivan\Documents\My Videos"".

     Error details: "Access is denied.

     

    Based on the current situation, I would like to suggest your refer to the following Microsoft TechNet and KB articles for how to configure the permissions for folder redirection.

     

    Security Considerations when Configuring Folder Redirection

    http://technet.microsoft.com/en-us/library/cc775853(WS.10).aspx

     

    Enabling the administrator to have access to redirected folders

    http://support.microsoft.com/kb/288991

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, February 8, 2011 12:39 AM
    Moderator
  • Hello Arthur Li,

    Thank you for your reply. That was the first thing we checked when having this issue. Well I verified the share and NTFS permissions and they are all set according Microsoft Knowledge Base article 274443. This morning I spent more time to work on this issue. I have found with some repeatable steps to lock the CSC database by another user. Also unlocking the path seems to work now but this is an issue to find that user who locked the system and click "Work Online" with that specific account.

    Let me share all steps in a detailed way with screenshots.

    1. User logs on and a white desktop is shown. An error message the location is unavailable. No folders are redirected and the 502 event is logged in the Applications Event Viewer. 

    2. While checking the remote share I can access my folder by using the \\servername\documents$\versli path. This path is a bit different what has been configured in the GPO as the path is going to FQDN.

    3. When opening the configured redirected path than I get the following message. Windows cannot access the \\servername.domain.name\documents$\versli 0x8007002 The system cannot find the file specified. This is strange as the server is reachable by netbios name and I can ping both netbios and hostname from DNS. 

    4. Then I logon with the user where Redirected folders work and open Windows Explorer. I see than the user is working offline. I than click "Work online" and check Event Viewer. 

    5. I see than various events but the most important is event nr 10. At some point 11:58:33AM the Offline Folders detected slowlink and transitioned to that with event 1004. The user logs off with event nr8 and than I login with event nr 7. Then for 5 minutes I check to see why my folders are not redirected. I than logoff and login with dijkmj user account where I clicked "Work online".

    6. Yes!!! My redirected folders are working after gpupdate /force to see the green sync icon.

    Based on what I learned this morning is that I need to optimize the slow-link detection in the GPO to transition the path to offline mode.

    This is the current setting:
    Configure slow-link mode

    \\servername.domain.name\documents$\* Latency=8

    I would like to configure if the latency is more than 50ms and bandwidth less than 10Mbps than it should transition to slow-link. I already tested that with the following setting but when connected with SDSL line 2Mbps it puts the folder online.

    \\servername.domain.name\documents$\* Throughput=10485760 Latency=50

    If I optimize this setting that Redirected folders should never go Offline when users are in the office than I should be in the right direction. Still the issue we are having that another user can lock the Offline Files database is buggy.

    How should I proceed? Can this post be forwarded to internal Windows 7 teams.

     

     


    Best regards, Ivan Versluis Networknet.nl Blog
    Tuesday, February 8, 2011 1:48 PM
  • Hi,

     

    You may try the group policy “Do not automatically make redirected folders available offline” to test the issue.

     

    For more information regarding offline files, please refer to the following Microsoft TechNet article:

     

    Configuring Group Policy for Offline Files

    http://technet.microsoft.com/en-us/library/cc759721(WS.10).aspx

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, February 16, 2011 2:07 AM
    Moderator
  • I'm experiencing the same issue you are Ivan. The first user to log into a cleanly imaged workstation who has a folder redirection group policy enabled will have their folders redirected and offline access set up correctly. Every other user to log into the system generates Access Denied errors failing to redirect the folders.

    If the first user toggles the state of the redirected folders offline and then back on before logging out, the next user will successfully redirect their folders and have offline access set up to them.

    If the second user logs off without toggling the state of the redirected folders and the first user logs back in, the first user gets access denied errors. Any other user who logs into the workstation, with the exception of user 2, will also get access denied errors attempting folder redirection until user 2 logs in and toggles the off-line folder state.

    It would seem that toggling the state of the offline folders to the off and then on line state somehow sets the CSC in a condition that allows the log off process to free it for the next user to log into the workstation. Failing to do so locks the CSC to the individuals account that last logged in and successfully redirected their folders without toggling the folder state before log off. Further, it would seem that you only need to toggle the state from off-line to on-line for this to work. If the folders are already in the off-line state you only need to toggle them on-line before logging off for the next user to succeed at folder redirection.

    I've been working with post SP1 images so I did a little testing, deploying a RTM pre SP1 image with no patches applied. The out of the box OS. With this installation I was able to log in and out of the workstation with multiple user accounts without the need to toggle the state of the offline folders.

    I would say that a hotfix that is included in the SP1 image of Win 7 Ent is causing this. Which one it is specifically I don't know. I haven't taken the time to apply them one by one until I identify it. I'm just going to to open a support case with MS.

     

    You can see a history of my efforts to diagnose this here: http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/51721012-2b3d-4479-8c93-02354e80ce13

     

    I thought I'd post here and see if you had identified a fix or a workaround before I opened the support case with MS Monday.

     

    Thanks,

    SteveDiG

    Sunday, April 10, 2011 2:37 AM
  • Hi,

     

    You may try the group policy “Do not automatically make redirected folders available offline” to test the issue.

     

    For more information regarding offline files, please refer to the following Microsoft TechNet article:

     

    Configuring Group Policy for Offline Files

    http://technet.microsoft.com/en-us/library/cc759721(WS.10).aspx

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

     

    Dear Arthur,

    Two weeks I have tested this policy setting in my lab environment. This does not make any sense in our configuration. We want to have the files offline and by enabling this setting the files are not cached anymore.

     


    Best regards, Ivan Versluis
    Networknet.nl Blog
    Monday, April 11, 2011 8:57 AM
  • Hi SteveDIG!!

    I am really happy we have found each other to work on this issue. I am still working with Microsoft Professional Services support to solve this issue. The case is open for two months now and we still do not have an solution.

    Our pain and criticality was solved a bit by removing the "slow-link detection mode" which was configured for the file servers. By removing this setting and going to the default Win7 of 80 ms our users are expierincing this problem less than after the migration.

    I agree with the sympoths you are having. It is important to mentioned the patch level of the image. My Win7 image received latest patches until end of October 2010.

    In our environment we use roaming profiles and having the 502 errors and denies to the CSC database we ended with the error messages where users are not being able to work.

    To help you and Microsoft if you open your support case please reference to mine. Case ID Num: SRX111020940753200


    Best regards, Ivan Versluis
    Networknet.nl Blog
    Monday, April 11, 2011 9:09 AM
  • I'm also encountering this issue, so thank you both for posting your experiences with this.  I'll follow this thread with interest.

    I've been using Folder Redirection for years in a Windows XP environment, and began testing and transitioning to Windows 7 about 6 months ago.  I too am using offline files caching on desktops as well as laptop computers, due to issues that the Windows Indexing Service seems to have when Library folders are located on a DFS share.  (Apparently, the Indexing/Search components of Windows 7 are being managed by a team whose focus is the consumer market rather than the enterprise, with the sad result that DFS support has been overlooked.)

    In any case, folder redirection seems to work fine most of the time, because users rarely log onto one anothers' workstations.  The first user to log onto a Windows 7 workstation is usually the only user to do so, so we haven't noticed issues with folder redirection.  Today, however, I thoughtlessly left my laptop at home, so I opted to log onto a "Loaner" laptop I've never used before.  Folder redirection has been failing consistently, logging an "Access Denied" message in the Application Log just as both of you have noted. The previous (and only other) user of this laptop had no such issues with folder redirection.  Permissions on the \\domain.local\dfs\redirected\ share are set correctly and have been working for years, so I'm not about to start screwing with them.

    Thanks to your thread(s), I'm going to try reinitializing the Offline Files cache and see what result I get the next time I log back in.  I'll post the results here.

    Thanks again for your excellent documentation of this problem.  I agree MS needs to get this one figured out asap.

    Bryan L
    Tuesday, April 12, 2011 5:33 PM
  • Hi Bryan-L and SteveDIG.

    I have an update and I am not happy about that.

    ======================================================================================================================

    Directory Services, Microsoft Enterprise Platforms Support

    Hello Ivan,

    I have discussed this case with the experts and we have found that this is the normal behavior of Windows if we enable “Work Offline” on a Windows 7 client machine as this is a machine specific setting.

     

    Please let me know if there is any other information that I can share with you to help you understand.

    ======================================================================================================================

    I have escalated this to our account manager in US and saying not to accept the "normal behavior" since we moved to Windows 7 and Offline Files database.


    Best regards, Ivan Versluis
    Networknet.nl Blog
    Wednesday, April 13, 2011 3:59 PM
  • "Dear Microsoft:

    "Yes, you can help me understand why a company believes that an acceptable response to my problem is, 'We designed this feature badly or with insufficient foresight, but since it DOES work this way by design, you have to live with it even though it's unusable in many enterprise scenarios.  We won't admit to any fault, mistake, shortsightedness, or indeed anything at all.  This is your problem - not ours.'"

    This is exactly the kind of attitude that sets apart Microsoft from a few other tech companies (like Apple) that actually DO care about user experience in common, real-world scenarios.  Grrr....

    </soapbox>

    FYI, reinitializing the Offline Files cache and rebooting the laptop had the desired effect - my Folder Redirection policy applied successfully on next login.  Thanks to both Ivan and SteveDiG for sharing your experiences in such detail.

    Some thoughts about resetting the offline files cache automatically.  Reinitializing the cache is done in Windows 7 by setting a registry value that apparently gets read on next startup, then deleted.  After hunting down the article that explains this for the second or third time, I finally created and saved a simple .reg file that I can click to import to the registry whenever I need to do this on a Windows 7 workstation.  It would certainly be possible to automate this thru scripting or Group Policy Preferences to occur on every shutdown, but it defeats the purpose of making files available offline if there's nothing cached when you log in while out of the office.  What we need is some clever logic to determine when it's appropriate to clear the cache to solve this problem.

    Digging into the GPP Targeting Editor, I see that there's no item to look for specific events in the Event Log.  But if we can come up with some other check condition to determine when a user who's logged on isn't successfully having their folders redirected, we could then set the registry entry to clear the cache.  It's an automatic solution that requires a reboot to kick in to solve the problem, but it seems to be the best we can do at present.

    What do you guys think??

    - Bryan L

    Wednesday, April 13, 2011 4:43 PM
  • I'm having the same problem with a Windows7 SP1 connecting over a VPN.

    This isn't right but appears to be a work around for now.

    I changed Group Policy for the redirected folders to be the IP address instead of the ServerName or the ServerName.Domain.Name

    \\10.0.0.3\RedirectedFolders

     

     


    Bill Dibble
    Friday, April 15, 2011 1:42 PM
  • We're also seeing similar behavior on multi-user workstations where Documents is redirected to a DFS share.

    Sniff traces show the client doing weird things when trying to validate connection to the network share (e.g. checking the existence of the \ad.domain.com\dfsroot)

    Is there a resolution?

    Monday, May 2, 2011 7:29 PM
  • This IP address was not a permanent fix.

    It temporarily resolved my issue with the Windows7 machine but eventually caused an issue with another pc.

    My initial issue was with trying to allow for ADMINISTRATOR access to the users documents.

    In the process of fixing the administrator issue it appears that my user access issue has been resolved as well.

     Before proceeding make sure you have a backup of all user documents.

    I set 'Grant user exclusive rights to Documents' to disabled in Group Policy.

    I used the 2003 settings from this KB http://support.microsoft.com/kb/288991 to the appropriate security for 'REDIRECTEDFOLDERS' folder.

    I had a few instances where I believe the documents were out of sync with the off-line files and the contents of the user's My Documents directory was deleted.

    You may have to delete their My Documents directory on the server so that it will be created with the proper permissions.

     


    Bill Dibble
    Wednesday, May 4, 2011 7:21 PM
  • Dear all who are monitoring this post.

    Still no update. I am working with Microsoft Professional Services from India. They have tested this in their labs too and it is by design...

    I am being requested now to submit a change document why they should change this. Our company is working in getting a Microsoft Premier support contract and I hope soon I can address this with our TAM (Techinical Account Manager) to see what they could to from US.

     


    Best regards, Ivan Versluis
    Networknet.nl Blog
    Thursday, May 12, 2011 3:09 PM
  • I would counter their request with a request for a technical explanation and justification for their design and why they consider it to be desired behavior. :-)  Clearly, the design does not align with typical, expected, and desired real-world use cases.

     

    Bryan

    Thursday, May 12, 2011 3:42 PM
  • Actually, I'd call BS because the issue was introduced by some combination of hot fixes apparently prior to the release of SP1. I have tested this with a unpatched fresh install of Win 7 and it works no problem at all. A clean install with release media with no hotfixes at all installed does not display this behavior. I can log in with as many different users as I like. They all redirect their folders with no errors and they all utilize the cache with no need to change the state of the folders prior to logoff. Once the system is updated to current patch levels the problem recurrs. 

    It's not a feature, it is a bug introduced by some combination of hotfixes which I haven't tested one at a time to see which one/s cause the issue.

    I suspect they are unable to identify the culprit with their std troubleshooting tools and are claiming this is design behavior as a fall back position.

     

    If it was a feature, you would not be able to circumvent the problem by changing the redirected folder to work offline, then online before logging off the preceeding user. If you do this, the next user to log on will successfully recirect their folders and use the cache. Further, if you then do not do this prior to logging user 2 off and then log user 1 back on, user 1 will fail folder redirection even though they succeeded the first time they logged in and already have content in the cache. User 1 will get access denied on this second logon attempt. 

     

    rgds,

    SteveDiG

    Thursday, May 12, 2011 9:06 PM
  • Had this happen on one of my client's PCs running Windows 7 Pro in SBS 2011 Standard Edition network environment.  On the server side, under redirectedfolders\username (in SBS 2003 would be users\username), found that the user was not the "owner" of all the objects in and under their respective redirected folder.  Changed that permission to give them ownership and had it propagate all child objects.  On the client side, manually enabled offline files...rebooted...voila!  Issue fixed itself.  Hopefully that helps some of you out too.

    Best,

    co.nexus exchange

    Tuesday, May 31, 2011 11:24 PM
  • is there any update on this?

    we're having the exact same problem with RUP, Redirected Folder and Offline Files being locked when logging on with multiple users.

    Thursday, August 18, 2011 9:12 AM
  • If you are using SBS you need to ensure that they users are ticked in the SBS console for Folder Redirection to work.

    For SBS 2008, Open the Console, Select Shared Folders.

    Under Redirected Folders Tasks,

    On the Right Hand side select "Redirect Folders for User Accounts to the Server"

    Pop up "Folder Redirection Properties"  will show then select the correct users.  (As pictured Below)

    This fixed it for me!!!

     

     

     

    Monday, September 5, 2011 3:01 AM
  • Hi Winuser123,

    There is an update from my side but I don't know if there will be a solution. This week I have a Microsoft Premier Field Engineer onsite to work on another problem. I hope he can have a look into this problem too.

    Current status is that this is by design. At my environment we are still dealing with this issue. Especially if profiles become corrupt or people use a spare laptop.


    Best regards, Ivan Versluis
    Networknet.nl Blog
    Wednesday, September 7, 2011 11:11 AM
  • I have a similar issue where we have folder redirection for all folders except Start Menu being directed to a DFS share. This works fine and all folders are automatically created and accessable by the user. With the default behaviour for redirected folders to always be available off line this is not a great solution for some of our desktop PCs but is a good solution for our Laptop users so the solution was to apply another GPO to our users with a WMI filter to filter out just the desktops which has the setting "Do not automatically make redirected folders available offline". Once this policy is applied the folder redirection breaks and the user can no longer access there my documents, desktop etc. All our servers are 2008 R2 and are running at that functional level with all our clients as Windows 7. This will still fail with new users when this policy is applied. We are currently not using RUP's but maybe look at mandatory profiles later once this redirection issue is resolved. Has anyone else out there experienced this issue?

     

    Thanks all

    Wednesday, September 7, 2011 12:52 PM
  • Just a quick update on this... I have resolved this issue now by simply allowing the offline files for all desktops and laptops. The issue I faced appeared to be an issue with my share path in that I was redirecting to "\\namespace\share\documents folder", I reconfigured it to be "\\namespace\share\documentsfolder" and all started to work smoothly so possibly an issue with spaces in the DFS path.

     

    Dont know if this will help anyone else but it seemed to solve my issue :-)

    Thursday, September 8, 2011 11:45 AM
  • While we are sharing tips...  This is slightly off topic but could be helpful to anyone trying to map an administrative share in Vista or Windows 7:

      Regedit

      Navigate to Hive: HKEY_LOCAL_MACHINE

      Navigate to Key: Software\Microsoft\Windows\CurrentVersion\Policies\System

      Add a Name: LocalAccountTokenFilterPolicy

      32bit Data Type: REG_DWORD

      Value: 1

      Exit Regedit

      Reboot

    The Administrative Shares should now work.

    Thursday, September 15, 2011 1:54 AM
  • Ivan and SteveDIG - Thanks for taking the time to post detailed information about what you have found.  I have found the same things over the past few months and have been working with Microsoft to resolve this.  Like Ivan, I have been told by MS that this is a design problem in Windows 7, but they did admit it is a bug and did not charge me for the case.  That was the good news.  The bad news was that the problem is so 'deep' in Windows 7 that it will not be fixed until Windows 8 and the CSC engineering team in Redmond has rejected several requests to fix this issue in Windows 7 from several customers.  I personally feel we should have hauled our TAM in over this, but that wasn't my call so we haven't attempted to get an attitude change from MS.

    <RANT> I find this completely outrageous.  Windows is supposed to be a multi-user operating system suitable for deployment to mobile workforces spread around the world and often using slow VPN links.  Offline folders, folder redirection, slow link detection, etc. are all great on paper and as I did the design work for the W7 solution I've just built I sold these advantages heavily.  I now have serious egg on my face and am not happy.  Like others here I missed this in testing as multiple users are a fringe for us, but still important, I unfortunately didn't think to specifically test for multiple users, though I tested the features thoroughly and was happy with the results when used on single user machines.</RANT>

    As identified above, this issue manifests when more than one user uses a machine and their Offline folders (all redirected folders are configured this way by default) are in an offline state when the first user logs off.  The second user cannot access this 'offline' share so folder redirection fails.  We get burnt as we have latency=0 configured for slow link detection with Offline folders so users always work offline.  This is partly because of WAN optimisers in the network that lie to Windows so the online/offline transition doesn't work on slow links (not MS's fault), and partly because it made sense for other reasons.

    The workaround Microsoft and I came up with for our environment was to use individual file shares for each user.  We had been using a common file share with each user folder under that file share.  Changing to an individual share for each users means the share is not locked by the previous user.

    Examples

    This would cause a problem if John then Emma logged on to the same machine. Folder redirection would fail for Emma:
    \\FileServer1\Users$\john
    \\FileServer1\Users$\emma


    So would this if DFS was used
    \\my.domain\users\john            (points to \\FileServer1\Users$\John)
    \\my.domain\users\emma          (points to \\FileServer1\Users$\Emma)


    This would fix the problem:
    \\FileServer1\John$
    \\FileServer1\Emma$

    Unfortunately we then figured we could move these shares behind DFS like so:
    \\my.domain\homes\john             (points to \\FileServer1\John$)
    \\my.domain\homes\emma          (points to \\FileServer1\emma$)

    This was wrong.  The problem returned.  I assume the share that is being locked is now the DFS root and not the user share.

    The operations team here is very reluctant to go with direct access to the file servers and not use DFS as that will create issues for them in the future when they need to make file server changes.  I sympathise with them but can't see an alternative at the moment as we are deploying W7 and can't stop.  If I'd picked this up earlier a third party product might have been the solution (MS actually suggested this when I opened my case).

    I hope the information about individual shares above is helpful to someone.  Otherwise I don't really have more to add but I needed the rant :-)

    <RANT>BTW.  Has anyone tested changing a user’s home directory path once it is cached?  Try it. Test a scenario where you move the user from one file server to another.  You will not enjoy the results.  I'll say no more than this as it is off topic, but it shows the lack of investment in the CSC feature in Windows.  Very disappointing</RANT>


    • Edited by jsc.19 Thursday, September 29, 2011 9:00 AM spelling
    Thursday, September 29, 2011 8:49 AM
  • All

    Good news.  I've got a hotfix from Microsoft today that appears to fix this issue.  I've got to do more testing, and the KB article is not published yet, but the hotfix is a public not private fix.  You will probably need to intially contact MS for this fix.

    Look for KB2610379

    I'll post back when I finish my full testing, but initial testing looks OK.

    jsc.19

    Thursday, October 13, 2011 8:20 AM
  • Hi jsc.19,

    Thanks for your updates. Week and half I've got the same news from my TAM. I am looking forward to get the hoxfix too and work on the issue.

    I will contact him now.

     

     


    Best regards, Ivan Versluis
    Networknet.nl Blog
    Thursday, October 13, 2011 8:44 AM
  • Hi All

     

    Please note a hotfix for the Slow-Connection issue in Folder Redirection was avaialble for a short time but was pulled due to a regession that was introduced by the changes for this fix. We are currently working on the resolution and expect the new hotfix to be avaialble in January.

     

    Regards

    Roland [MSFT]



    Friday, October 14, 2011 12:41 PM
  • I just requested the hotfix from MS, recieved it, before I could try it got pulled back by MS. The link doesn't work anymore and MS said, I shouldn't install it.

     

     

    Friday, October 28, 2011 9:49 AM
  • Hi Philippe,

    I am experiencing this exact problem, has Microsoft re-release this patch yet "Windows6.1-KB2610379-x86.msu" as I cannot find it on their site.

    Thanks Pat

    Sunday, November 27, 2011 5:04 PM
  • Version 3.0 of the patch is available here http://support.microsoft.com/kb/2610379/en-us

    I have the same problem on 2008 R2 RDS servers & will be testing the fix tomorrow.


    Douks
    Monday, January 16, 2012 5:51 PM
  • Quick update - there are still problems with this hotfix.  When using DFS-N to alias user redirected folder locations in a DFS namespace the original problem is still reproducable.  MS is working on this, but you should open a case with MS ... the more cases MS has on this the more pressure there is for a solution.  I am still working with MS on this issue and will post an update if/when I have a solution.
    Tuesday, January 17, 2012 4:50 AM
  • We have a similar problem

    Scenario:

    - Win 2008  R2 RDS server
    - DFS share is on Win 2008 server
    - Folder redirection set to DFS folder: \\DFSNAME\DFSSHARE\HOMEDIRS\  (This is also the home folder)
    - Folder redirection automatically creates the subfolders "My Documents", "Desktop" etc. under \\DFSNAME\DFSSHARE\HOMEDIRS\TESTUSER10 when the "testuser10" folder exist
    - Desktop redirecton works fine
    - My documents and the rest does not work (although the logging says it worked)
    - I checked all the permissions
    - This is what the user see's when logged in (weird white icons):

    - When a new user logs in, a new folder is created and i get error 502, can't create file that already exist in the logging

    - when i try to open the folder \\DFSNAME\DFSSHARE\HOMEDIRS\TESTUSER10 as an administrator i get the same message as ivan:
    - also cannot view permissions as administrator (only when i become owner)


    - When i set the folder redirection to a new DFS share, everything works fine (and no white icons).
    - also i can open this folder as admin and see the permissions
    - Permissions are the same. Only difference is that the new DFS share is not the HOME directory. Maybe this is a clue?

    Getting desperate!!!


    Friday, January 27, 2012 2:32 PM
  • All,

    I came across a (temporary and not exactly great) solution to this problem that seems to have worked for me and all of the end points that are seeing the issue. You can find it halfway down in http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/df22f06f-656f-459d-906b-f0101418cffc/, where Hubert Iam suggests logging onto the machine as the local administrator. I don't know why but it works. This is one of the more baffling issues I have faced in a while and has an even more baffling solution.

    If you try this and it works can you please post back to let me know. I would be keen to see if this is a universal solution or if it just happened to work for us.

    Good luck!

    Wednesday, February 1, 2012 10:26 PM
  • Per your <rant>, please see http://vistavitals.blogspot.com/2007/11/folder-redirection-misbehaves-after.html , which suggests a complex solution but with very desirable outcomes.  I've successfully used it in my organization on a large scale.
    Wednesday, February 15, 2012 4:46 PM
  • Yes, clearing the offline files cache with the certain registry entry works to make the error message "Q: refers to a location that is unavailable" go away.  I think you (Bryan-L) are on the right track if we can detect a corrupt cache.
    Wednesday, February 15, 2012 4:49 PM
  • Hello everyone,

    A few days ago I encountered a similar problem to ICT Volckaert-SBO,
    Since our setup is similar to his , maybe my solution could be helpful.

    The same errors occured.
    In addition to his setup we also had “acces based enumeration” enabled on the dfs shares and the windows shares.

    Redirection was not working. In event log there where several items telling me that
    redirection was successful.  But it wasn’t….

    Sometimes “desktop” also did not redirect correctly.

    We redirect the folders to \\DFSNAME\DFSSHARE\USERS\%Username%

    This top ‘USERS’ folder had the usual NTFS permissions:

    • Creator/Owner à Full Control, Subfolders And Files Only
    • Security group of users needing to put data on share àList Folder/Read Data, Create Folders/Append Data - This Folder Only
    • Local System à Full Control, This Folder, Subfolders And Files

    The problem was that this was not enough. (maybe because of the access based enumeration?):
    When I gave the group of users needed to put data on the share the following rights, everything worked again.(In  this
    case I tested with the authenticated users)

    Greetings ,

    Tim


    Tuesday, March 13, 2012 7:40 PM
  • While your issue was slightly different than ours, I believe this may be your answer:

    http://support.microsoft.com/kb/2610379

    or 

    http://support.microsoft.com/kb/230738

    Credit goes to this article:

    http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/51721012-2b3d-4479-8c93-02354e80ce13

    Thursday, August 2, 2012 2:11 PM
  • Above (Jan 17) I posted that there was still issues with the hotfix MS provided in 2011.  I've left the organisation where I was working on this issue, but on the day I left in late May 2012 the private version of a new hotfix arrived to address the ongoing issues that still existed with the Offline Cache being locked on machines used by multiple users.  I never got to test it but was just going through my posts here and saw I hadn't updated this one.

    I will try and find out if it has now been released and what the KB number is.  I'll have to have lunch with my old boss to see if he will dig out details for me, or even if his team pursued this after I handed it over as I walked out the door :-)  In the meantime, talk to MS if you have the luxury of a TAM or other contact into their support organisation.  There was definately ongoing work in this area.

    Tuesday, August 7, 2012 2:05 AM
  • Hello,

    We are still experiencing the same problems with or without the hotfix. Are there any news on this "private" hotfix, or any workaround that is really working ?

    Thanks

    Thursday, September 13, 2012 3:54 PM
  • It seems the KB has been published and the hotfix is available:

    http://support.microsoft.com/kb/2610379

    The hotfix has solved the problem for me on a number of test systems - will be deploying to a medium sized site too before wider rollout.


    Carl Barrett | Twitter: @Mosquat

    Tuesday, November 27, 2012 10:53 AM
  • got same problem in a simple SBS2011 environment....

    what is really amazing is the in 2014 and after 10,000 different patch, MS doesn't put the fix inside standard update....

    Now I will test those patch in my production environment....

    435552_intl_i386_zip.exe        544.912 byte
    435556_intl_x64_zip.exe         611.072 byte
    440845_intl_i386_zip.exe        5.184.704 byte
    440861_intl_x64_zip.exe            7.907.472 byte

    Great post anyway....very usefully....

    If those patchs will work you will have saved my life

    Friday, February 28, 2014 7:42 PM
  • STILL UNDER TEST...

    I got 2 client with those update...... since 3 weeks.

    ...to be continued.

    Thursday, April 17, 2014 7:50 PM
  • I recently had similar issues with Server 2012 R2 Essential, when implemented group policy for redirection folder. I had user who were unable to connect to their roaming profiles on one PC that was running Windows 7 service pack 1 but could connect on the next PC. After reading many posts and trying hotfixes that had no help. I managed to solve my issues after weeks of pulling my hairs.

    The source of my issues were the share name I have given to my folder redirection Folder. The share name must not contain any spaces if you are going to use more then one word. For example "File Redirection", for some funny reason when the policy was implemented, it caused confusion and my clients kept getting Error Codes 502. All I had to do was to change my share name to "FileRedirection" eliminating the space in between. This has solved all my problems.

    Please Note.. Make sure that all your clients are log off from your server before you implement or make amendments to your policy. You will eventually may need to do some tweaking on your system. ie if your clients are using outlook pop accounts you may need to change their .pst files to the new share name.

    hopefully this will help with issues. I apologise in advance if someone has already posted similar resolution

    Goodluck

    Sarac 


    Monday, March 30, 2015 1:16 PM