none
DFS namespace standalone 2012 cluster. Target folders not accesible by IP RRS feed

  • Question

  • Hello,

       we have set a DFS namespace standalone cluster on Windows 2012 with two servers (virtualized).

       We have created certain folders and when we access it via name (netbios) everything works fine (\\nasDFS\FM\XXXXX) , but when we try to access with IP (\\10.28.5.100\FM\XXXX) it fails for every folder with a target (folders without target, those to generate the tree,  work until you reach a leaf one with target). It says it is not accessible.

       I have tested this on a standalone DFS on Windows 2008 R2 and worked fine.

       Any clue? It is due to changes in 2012 DFS or because it is a cluster?

    Thursday, April 4, 2013 1:49 PM

All replies

  • The domains controllers are not VM, are the DFS namespace standalone cluster servers (Really they are also File servers). thanks anyway.

    Any clue out there? Our domain controllers are 2008 R2, and it seems to be a authorization issue,  because DFS woks fine, but when it trys to redirect it says not accesible(but the odd thing is that it works fine when you use the name of the DFS cluster and it doesn't when you use the IP odf the cluster).

    Friday, April 5, 2013 9:35 AM
  • Hi,

    The IP 10.28.5.100 belong to the cluster or a node of the cluster? Meanwhile it is a standalone namespace or a domain based namespace? Please noticed that domain based namespace is not supportd on cluster.


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Tuesday, April 9, 2013 12:35 PM
    Moderator
  • Hello,

      the 10.28.5.100 Ip is the assigned to the DFS in the cluster (if you try to resolve the name with ping (or else) in any machine of the nasDFS it resolve to this one 10.28.5.100).

     We have made a test with a not cluster standalone DFS namespace (in 2012) and everything works fine, target folder can be accessed by name and IP (in this case the IP is the one of host that hosts the DFS namespace).

      The problem is when we create the DFS as a cluster service (we assign a new IP) and then, everything works fine when you use the name but it says it is not accessible when you use the IP (for target folders).

      We will probably go for a DFS not in cluster and establish a quick contingency plan with an powershell script to regenerate quickly the DFS structure in other server if needed.

      But anyway, if someone has found the solution/bug please tell us.

    Thursday, April 11, 2013 11:54 AM
  • Hi JESUSNB,

    We are seeing the exact same problem here: Our deployment process involves resolving the DFS name into the Ip addresses, however since we moved to DFS cluster (before we didn't have DFS structure, we used share locations directly) this doesn't work anymore. 

    Using the \\DFSName path works just fine, \\IPAddress however doesn't work

    I cannot even go to the target location when I logged on the DFS server and tried going through D:\Namespace\DFSRoots\..; however using the path\\DFSName still works.

    We haven't tested on 2008 servers but seems like this certainly has something to do with Win 2012 ones. Any suggestions or help will be appreciated :)

    Thanks.

    Tuesday, December 3, 2013 12:27 AM
  • Thanks for the prompt response Vegan,

    Are you using Win 2012 servers and DFS clusters as well?

    Also this problem only happens until I try to access a leaf target link:

    Example: \\10.xx.xx.xx\folder1\folder2\dfslink1 

    I can access all the way up to folder2, but gets the error when going into the link. Somehow it doesn't recognize it as a "link", when I right click on the links I cannot see "DFS' tab in the properties. Whereas when I do the same when accessing through \\DFSNamefolder1\folder2\dfslink1 , it shows all the correct information and I can access without any problems.

    Do you have any ideas?

    Thank you!

     


    Tuesday, December 3, 2013 1:57 AM