Default Wallpaper in Windows 7


  • Hi,

    I am currently trying to set a default wallpaper for the machine in Windows 7 using group policy.

    I have created the BackgroundDefault.jpg in c:\Windows\System32\oobe\info\backgrounds and changed the GPO setting to 'Always use a custom logon background'.  I have also included the background[HxV].jpg setting that then sets the background to the correct resolution on the fly.  Doing this has set the background to the correct resolution as desired. 

    My question is this.

    Is there a way to force this background to apply to all users of the machine, rather than using the wallpaper specified in HKCU\Control Panel\Desktop\Wallpaper?  Of course I can set this setting to BackgroundDefault.jpg, but then the resolution correction functionality wouldn't be used. 

    Most GPOs have a computer setting that overides any user setting - do we have one that will help me with this?

    Thanks in advance.

    Tuesday, March 02, 2010 2:34 PM

All replies

  • The biggest problem you're going to face if you decide to specify a background image via group policy is the capacity to select an image based on resolution is lost. When you specify "filename.jpg" in the policy setting, that's exactly what you get, not the auto-adjusted "filenameHxV.jpg" format.

    That said, if you're like us and run a fleet that's mostly of the same spec, then yes, you can do this. There are two settings you may be interested in:

    1. User Config > Admin Templates > Control Panel > Personalisation > Prevent changing the desktop background.
    2. User Config > Admin Templates > Desktop > Desktop > Desktop Wallpaper.

    You may just be interested in the first option if you have the capacity to push out the second setting either via a custom .adm file, SCCM, logon script, or other such mechanic.


    Wednesday, March 03, 2010 2:18 AM
  • Hi Bobby,


    Is this Windows 7 computer in a domain? Are you trying to set wallpaper for domain users or the local users on this computer?




    Wednesday, March 03, 2010 5:15 AM
  • Hi Bruce,

    Yes, the Windows 7 machine is in a domain.

    I want the domain user's wallpaper to follow the background[HxV].jpg custom logon wallpaper I have set in c:\windows\system32\oobe\info\backgrounds.

    It would be nice if any local users get this wallpaper too.

    Wednesday, March 03, 2010 3:54 PM
  • Good day BobbyJ99,

          Hope this would help you.

         You can download the Hotfix straight off the KB article page.

          The "Desktop Wallpaper" Group Policy setting is not applied in Windows 7 or in Windows Server 2008 R2

          Thanks and Regards,


    Wednesday, March 03, 2010 7:06 PM
  • Hi Rad,

    Thanks for the link, but I have already tried this to see if it made any difference in our case. 

    It didn't.

    Thursday, March 04, 2010 4:42 PM
  • Good day BoobyJ99,

         It is sad to say which I don't have here on my Laptop a Windows Server 2008 and Windows 7 to be one of my instance on my VMWare as my test environment to be able to test this Default Wallpaper on Windows 7 using Group Policy I have here Windows Server 2003 Ent. Ed. and Windows XP Pro. and Windows Vista Bussiness Ed. but I have tested the implementation of Desktop Wallpaper with my instances on my VMWare and also in the real operations Servers, Clients, and real Networks with Firewall please read this as part of my contribution to be able to solved your probs.

    Good day Jimit,

         I have another workaround to be sure that the desktop wallpaper will be injected properly the folder where the wallpaper is located the user or the users will be member of "Domain Users" see the steps below: Using Windows Server 2003 Ent. Ed., Windows XP Pro. SP2.

         "Sharefolder" Sharing and Security Permissions:

              Sharing Permissions:
              1.)  Everyone - Read

              Security/NTFS Permissions:

              1.)  Domain Users - Full Permissions (grade-out)
              2.)  CREATOR OWNER - No Permissions
              3.)  Domain Users (<NetBUIName>\Domain Users) - Read & Execute, List Folder Contents, Read
              4.)  SYSTEM - Full Permissions (grade-out)
              5.)  Users (<NetBUIName>\Users) - Read & Execute, List Folder Contents, Read (grade-out)

         Note:  You can modify this security permissions.

         At the Group Policy of a certain OU which implements the Desktop Wallpaper:

              1.)  Active Desktop Wallpaper - User Configuration, Administrative Templates, Desktop, Active Desktop
                    Path:  \\<server>\<sharefolder>\wallpaper.jpg
              2.)  Allow only bitmapped Wallpaper - User Configuration, Administrative Templates, Desktop, Active Desktop
                    Set - Enable
              3.)  Prevent changing wallpaper - User Configuration, Administrative Templates, Control Panel, Display
                    Set - Enable

          Another way of checking at the Client Computer Windows Registry - if this is really injected, the wallpaper .jpg fill will be converted to bitmap file and you will see this converted file from .jpg to .bmp below on "b" and "c":

              1.)  At HKEY_CURRENT_USER, Control Panel, Desktop - this entries will be updated
                    a.)  ConvertedWallpaper - \\<server>\<sharefolder>\wallpaper.jpg - added entries
                    b.)  OriginalWallpaper - C:\Documents and Settings\<username>\Local Settings\Application Data\Microsoft
                    c.)  Wallpaper - C:\Documents and Settings\<username>\Local Settings\Application Data\Microsoft

              Note:  The converted, copied .jpg file from server to clients the capacity will be 340KB and the filename converted to .bmp wil be "Wallpaper1.bmp" which will be same as the entry at Registry, if not try this command below.

          Another way of forcing the Group Policy do this command below:

              1.)  Try to run this on Server @ Command Prompt - gpupdate /target:user /force /wait:0
              2.)  Try to run this on Client @ Command Prompt - gpupdate /target:user /force /wait:0 /logoff /boot /sync - this will reboot the client.
              3.)  Place this one on Login Scripts when the users will logon - gpupdate, or gpupdate /target:user /force /wait:0

          Hope this will help you with another alternative way.

          Thanks and Regards,


          This is my previous Threads with Jimit with the thread below:

          I have also a follow-up added questions on the Thread below to find out if there is an available Hotfix for Windows Server 2003 and Windows XP Pro. SP2 regarding on the same scenario but there is no update because I want also to have on my thread so that when I got there when we have Windows 7 I will know on what to do, but no update:

          Hope this will help you on other ways of finding a solution, and try to follow if this will work the one I gave to Jimit.

          Another workaround login as Administrator on local PC then go to C:\Users then delete the specific profile to be able to re-create again the local profile of the specific user then logon using the user that injected the group policy and check the Registry above stated.

          Thanks and Regards,


    • Marked as answer by Bruce-Liu Tuesday, March 09, 2010 6:20 AM
    • Unmarked as answer by BobbyJ99 Tuesday, March 16, 2010 4:20 PM
    • Edited by radical93 Tuesday, March 23, 2010 12:46 PM Added Workaround Troubleshooting...
    Thursday, March 04, 2010 7:04 PM
  • hopefully this can help someone:

    This article also talks about using multiple resolutions: 


    Mike Crowley
    Check out My Blog!

    Tuesday, April 12, 2011 3:33 PM
  • I suggest using a theme instead.  You can create a theme in notepad and distribute it (and related files) with a combo of GPO settings and preferences.


    Mike Crowley
    Check out My Blog!

    Friday, April 15, 2011 4:00 PM
  • Dear check  the reply on this link:

    • Proposed as answer by AmitCEH Friday, October 05, 2012 10:32 AM
    Friday, October 05, 2012 10:32 AM