none
Sysprep a Windows 2008 R2 Image with unattend.xml RRS feed

  • Question

  • I don't seem to be able to bypass the OOBE process with sysprep.  I have read countless articles on the matter, and nothing seems to actually work.  Is there a confluence of settings that will allow this?  I want to generalize the machine, and specify the bare-minimum so that the image will start up and get to a logon screen.  After this I will join it to the domain myself.

    I keep getting errors just trying to execute the sysprep command.

    I have placed the unattend.xml file inside of C:\Windows\System32\sysprep and executed the following command:

    sysprep /generalize /shutdown /oobe

    I always get an error stating: 2012-09-28 00:04:25, Error [sysprep.exe] UnattendSearchExplicitPath: Found unattend file at [C:\Windows\System32\sysprep\unattend.xml] but unable to deserialize it; status = 0x1, hrResult = 0x800705b9.

    Here is the information from the setupact.log:

    2012-09-28 00:04:25, Error                        [sysprep.exe] UnattendSearchExplicitPath: Found unattend file at [C:\Windows\System32\sysprep\unattend.xml] but unable to deserialize it; status = 0x1, hrResult = 0x800705b9.
    2012-09-28 00:04:25, Warning               SYSPRP SysprepSearchForUnattend: Found invalid unattend file while searching; hr = 0x1
    2012-09-28 00:04:25, Warning               SYSPRP WinMain:Encountered invalid unattend file during search; hrResult = 0x800705b9
    2012-09-28 00:04:28, Info                  IBS    UnattendErrorFromResults: Hit an unattend error; dumping any info we have about the failure...
    2012-09-28 00:04:28, Info                  IBS    UnattendDumpSetting: ------Unattend setting error / warning------
    2012-09-28 00:04:28, Info                  IBS    UnattendDumpSetting: Error code = 0x800705b9
    2012-09-28 00:04:28, Info                  IBS    UnattendDumpSetting: File path = [C:\Windows\System32\sysprep\unattend.xml]
    2012-09-28 00:04:28, Info                  IBS    UnattendDumpSetting: --------------------------------------------
    2012-09-28 00:04:28, Info                  IBS    UnattendErrorFromResults: Error text = Windows could not parse or process unattend answer file [C:\Windows\System32\sysprep\unattend.xml]. The answer file is invalid.
    2012-09-28 00:04:39, Info       [0x0f004c] SYSPRP WaitThread:Exiting spawned waiting thread
    2012-09-28 00:04:39, Info       [0x0f0052] SYSPRP Shutting down SysPrep log
    2012-09-28 00:04:39, Info       [0x0f004d] SYSPRP The time is now 2012-09-28 00:04:39

    Here is my unattend.xml

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <UserAccounts>
                    <AdministratorPassword>
                        <Value>[redacted]</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                </UserAccounts>
                <OOBE>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                    <NetworkLocation>Work</NetworkLocation>
                    <HideEULAPage>true</HideEULAPage>
                    <ProtectYourPC>1</ProtectYourPC>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                </OOBE>
                <TimeZone>Central Standard Time</TimeZone>
                <Display>
                    <ColorDepth>16</ColorDepth>
                    <HorizontalResolution>1024</HorizontalResolution>
                    <VerticalResolution>768</VerticalResolution>
                </Display>
            </component>
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-US</InputLocale>
                <SystemLocale>en-US</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UserLocale>en-US</UserLocale>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <RegisteredOrganization>ClickMotive</RegisteredOrganization>
                <RegisteredOwner>ClickMotive</RegisteredOwner>
            </component>
        </settings>
        <settings pass="generalize">
            <component name="Microsoft-Windows-OutOfBoxExperience" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DoNotOpenInitialConfigurationTasksAtLogon>true</DoNotOpenInitialConfigurationTasksAtLogon>
            </component>
            <component name="Microsoft-Windows-ServerManager-SvrMgrNc" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DoNotOpenServerManagerAtLogon>true</DoNotOpenServerManagerAtLogon>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="catalog:d:/sources/install_windows server 2008 r2 serverstandard.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    

    Friday, September 28, 2012 5:11 AM

All replies

  • Hi,

    Could you please let me know whether you are using Windows System Image Manager to create unattend.xml file or not?

    From the error message, it seems that the unattend.xml file is not valid. I think you need to validate the unattend.xml file before putting into production enviornment. At the same time, I didn't find any sysprep action in your unatten.xml file.

    Regards,

    James


    James Xiong

    TechNet Community Support

    Friday, October 5, 2012 8:05 AM
    Moderator
  • Hi,

    Could you please let me know whether you are using Windows System Image Manager to create unattend.xml file or not?

    From the error message, it seems that the unattend.xml file is not valid. I think you need to validate the unattend.xml file before putting into production enviornment. At the same time, I didn't find any sysprep action in your unatten.xml file.

    Regards,

    James


    James Xiong

    TechNet Community Support

    James, yes the unattend.xml file was created using Windows System Image Manager.  I was able to validate the file, and there are a few warnings, stating that SkipMachineOOBE and SkipUserOOBE are deprecated.  They are not errors, but warnings.

    Friday, October 5, 2012 1:10 PM
  • I am working on this with wsim and I have yet to get this to work on 2008 r2. I did how ever get my Windows 7 deployment to work with an unattend.xml. Did you get this working on 2008 R2? 
    Friday, August 29, 2014 2:02 PM