none
Server 2008 My Documents Redirection

    Question

  • I just migrated from server 2003 to server 2008. I have a group policy set up to redirect everyones My Documents to the server. The options to create a folder for each user is selected and exclusive rights check box is not selected. When logging out of a XP machine the computer tells me it will redirect with no errors. But you create a word document in my documents and log out and then look at the redirection path on the server and nothing is their?
    Monday, November 30, 2009 10:04 PM

Answers

  • Hi,

     

    To verify the GPO was applied, please check the following items:

     

    1. On the client, right click My Documents and select Properties. Please check if the Target folder location. Is it redirection path?

     

    2. Did the issue start after migrating to Windows Server 2008?

     

    3. Please enable the "Always wait for the network at computer startup and logon" policy on XP client. For more information, please refer to the following article:

     

    Description of the Windows XP Professional Fast Logon Optimization feature

    http://support.microsoft.com/kb/305293/en-us

     

    After you enable the "Always wait for the network at computer startup and logon" policy on XP client, please run gpupdate /force and re-logon to check if the problem continues.

     

    If the problem continues, please collect the following information:

     

    1. Please enable userenv debug log on the same computer. The userenv debug log will record the whole procedure of applying group policy and is very useful for troubleshooting group policy problems. You may refer to the following KB for detailed steps:

     

    How to enable user environment debug logging in retail builds of Windows

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;221833

     

    Note: if the registry UserEnvDebugLevel does not exist, please create it. Please set it to 10002 (Hex). After you enable the log, please reboot the computer and logon with a problematic domain user to reproduce the issue. After the issue is reproduced, please upload the userenv.log file to Windows Live SkyDrive and give us the download address.

     

    2. After the issue is reproduced, open Command Prompt on the XP client. Type the following command and run it:

     

    gpresult /v >c:\gpresult.txt

     

    A gpresult.txt file will be created in C:\ drive. Please use Windows Live SkyDrive (http://www.skydrive.live.com/) to upload the c:\gpresult.txt file and then give us the download address.

     

    3. Run eventvwr to open Event Viewer. Export the Application log. Then, please upload it to Windows Live SkyDrive and give us the download address.

     

    4. On the DC, open GPMC, right-click Group Policy Results, choose Group Policy Results Wizard, follow the wizard to collect a Group Policy result for problematic XP client and user. You may need to disable XP Firewall temporarily to collect information. Please upload the GPMC Report to Windows Live SkyDrive.

     

    Regards,

    Bruce

    • Marked as answer by Bruce-Liu Monday, December 07, 2009 9:43 AM
    Tuesday, December 01, 2009 9:44 AM

All replies

  • When you create a folder for redirect, Are you set share permission on those folder ?
    You needed to set only Shared Permission on the target folder before redirect.
    Thana
    Tuesday, December 01, 2009 5:13 AM
  • Hi,

     

    To verify the GPO was applied, please check the following items:

     

    1. On the client, right click My Documents and select Properties. Please check if the Target folder location. Is it redirection path?

     

    2. Did the issue start after migrating to Windows Server 2008?

     

    3. Please enable the "Always wait for the network at computer startup and logon" policy on XP client. For more information, please refer to the following article:

     

    Description of the Windows XP Professional Fast Logon Optimization feature

    http://support.microsoft.com/kb/305293/en-us

     

    After you enable the "Always wait for the network at computer startup and logon" policy on XP client, please run gpupdate /force and re-logon to check if the problem continues.

     

    If the problem continues, please collect the following information:

     

    1. Please enable userenv debug log on the same computer. The userenv debug log will record the whole procedure of applying group policy and is very useful for troubleshooting group policy problems. You may refer to the following KB for detailed steps:

     

    How to enable user environment debug logging in retail builds of Windows

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;221833

     

    Note: if the registry UserEnvDebugLevel does not exist, please create it. Please set it to 10002 (Hex). After you enable the log, please reboot the computer and logon with a problematic domain user to reproduce the issue. After the issue is reproduced, please upload the userenv.log file to Windows Live SkyDrive and give us the download address.

     

    2. After the issue is reproduced, open Command Prompt on the XP client. Type the following command and run it:

     

    gpresult /v >c:\gpresult.txt

     

    A gpresult.txt file will be created in C:\ drive. Please use Windows Live SkyDrive (http://www.skydrive.live.com/) to upload the c:\gpresult.txt file and then give us the download address.

     

    3. Run eventvwr to open Event Viewer. Export the Application log. Then, please upload it to Windows Live SkyDrive and give us the download address.

     

    4. On the DC, open GPMC, right-click Group Policy Results, choose Group Policy Results Wizard, follow the wizard to collect a Group Policy result for problematic XP client and user. You may need to disable XP Firewall temporarily to collect information. Please upload the GPMC Report to Windows Live SkyDrive.

     

    Regards,

    Bruce

    • Marked as answer by Bruce-Liu Monday, December 07, 2009 9:43 AM
    Tuesday, December 01, 2009 9:44 AM