locked
Allowing users to open multiple remote sessions on Windows Server 2012 RDS RRS feed

  • Question

  • I've just installed Windows Server 2012 with Remote Desktop Services, and I'd like to allow users to open multiple (simultaneous) remote desktop sessions --- but I'm having trouble locating where to configure that option.

    Regards,

    Terry Dawydiak

    TD Computer Solutions Inc.

     

    Terry Dawydiak TD Computer Solutions Inc. Vancouver, BC

    Wednesday, November 14, 2012 1:03 AM

Answers

  • Hi,

    You may set this via group policy, for example, in the server's local policy using gpedit.msc:

    Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Session Host\ Connections\

    Restrict Remote Desktop Services users to a single Remote Desktop Services session     Disabled

    Or you could edit the server's registry:

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server

    fSingleSessionPerUser     REG_DWORD     0x00000000

    -TP

    • Proposed as answer by Aiden_Cao Thursday, November 15, 2012 5:59 AM
    • Marked as answer by TP []MVP Friday, November 16, 2012 2:10 AM
    Wednesday, November 14, 2012 2:12 AM
  • Hi,

    How are things going? I just want to check if the information provided was helpful. If there is any update or concern, please feel free to let us know. You may also refer to the following article, applies to Windows Server 2012.

    Restrict Users to a Single Session

    http://technet.microsoft.com/en-us/library/cc754762.aspx 

    Best Regards,
    Aiden

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Aiden Cao

    TechNet Community Support

    • Marked as answer by Terry Dawydiak Friday, November 16, 2012 2:06 AM
    Friday, November 16, 2012 2:04 AM

All replies

  • Hi,

    You may set this via group policy, for example, in the server's local policy using gpedit.msc:

    Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Session Host\ Connections\

    Restrict Remote Desktop Services users to a single Remote Desktop Services session     Disabled

    Or you could edit the server's registry:

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server

    fSingleSessionPerUser     REG_DWORD     0x00000000

    -TP

    • Proposed as answer by Aiden_Cao Thursday, November 15, 2012 5:59 AM
    • Marked as answer by TP []MVP Friday, November 16, 2012 2:10 AM
    Wednesday, November 14, 2012 2:12 AM
  • Hi,

    How are things going? I just want to check if the information provided was helpful. If there is any update or concern, please feel free to let us know. You may also refer to the following article, applies to Windows Server 2012.

    Restrict Users to a Single Session

    http://technet.microsoft.com/en-us/library/cc754762.aspx 

    Best Regards,
    Aiden

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Aiden Cao

    TechNet Community Support

    • Marked as answer by Terry Dawydiak Friday, November 16, 2012 2:06 AM
    Friday, November 16, 2012 2:04 AM
  • Information was helpful --- the solution provided was the answer, all is working well.

    Thanks

    Terry


    Terry Dawydiak TD Computer Solutions Inc. Vancouver, BC

    Friday, November 16, 2012 2:09 AM
  •  Enable Multiple RDP Sessions
    1. Log into the server using Remote Desktop.
    2. Open the start screen (press the Windows key) and type gpedit.msc and open it
    3. Go to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections.
    4. Set Restrict Remote Desktop Services user to a single Remote Desktop Services session toDisabled.
    5. Double click Limit number of connections and set the RD Maximum Connections allowed to 999999.

    Disable Multiple RDP Sessions

    1. Log into the server using Remote Desktop.
    2. Open the start menu and type 'gpedit.msc' and open it
    3. Go to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections.
    4. Set Restrict Remote Desktop Services user to a single Remote Desktop Services sessionto Enabled.

     

    Source:

    https://support.managed.com/kb/a1816/how-to-enable-disable-multiple-rdp-sessions-in-windows-2012.aspx

    Thursday, March 16, 2017 10:27 AM
  • You can have 2 remote connection in same time for free, but if you need more, you should install rds,
    check out this:
    https://operavps.com/how-many-users-can-remote-desktop-2012/
    • Proposed as answer by Jaddi62 Monday, October 28, 2019 1:30 PM
    Monday, October 28, 2019 1:30 PM