none
Hyper-V on Windows 10 (1903) - how to set default configuration version? RRS feed

  • Question

  • Hyper-V on Windows 10 (1903) - how to set default configuration version?

    I have upgraded my Windows 10 from 1809 to 1903.

    I have several VMs running under Hyper-V with configuration version 9.0.

    Using the command Get-VMHostSupportedVersion I receive the following output: 

    Name                                                      Version IsDefault
    ----                                                      ------- ---------
    Microsoft Windows 8.1/Server 2012 R2                      5.0     False
    Microsoft Windows 10 1507/Server 2016 Technical Preview 3 6.2     False
    Microsoft Windows 10 1511/Server 2016 Technical Preview 4 7.0     False
    Microsoft Windows Server 2016 Technical Preview 5         7.1     False
    Microsoft Windows 10 Anniversary Update/Server 2016       8.0     False
    Microsoft Windows 10 Creators Update                      8.1     False
    Microsoft Windows 10 Fall Creators Update/Server 1709     8.2     False
    Microsoft Windows 10 April 2018 Update/Server 1803        8.3     False
    Microsoft Windows 10 October 2018 Update/Server 2019      9.0     True
    Microsoft Windows 10 April 2019 Update/Server 1903        9.1     False

    So there is a new 9.1 configuration available, but it's not set as default. How can I change to 9.1 as default?

    I am also unable to upgrade my existing VMs from 9.0 to 9.1, using Update-VMVersion <vmname>.

    Windows tells me that I am already on the maximum supported version for my VM, so why is there a 9.1 config if it is not available for an upgrade?

    Please help!
    Tuesday, April 23, 2019 4:23 PM

Answers

All replies

  • Hi Robert,

    Your question is more suitable for the Windows 10 virtualization forums here:

    Windows 10 IT Pro  >  Windows 10 Virtualization

    The Get-VMHostSupportedVersion PowerShell cmdlet only retrieves a list of the supported virtual machine configuration versions for your Hyper-V host (your Windows 10 in this case).

    Since Windows 10 version 1903 / Windows Server 1903 is new, it might simply be that the new configuration version has not been yet released/finalized, but it just shows the support for the new version.

    I believe that you cannot change the default version manually, the latest configuration version will automatically become the default version. As it appears the 9.1 version is not yet released yet, that's most likely the reason why Windows is telling you that you already have the maximum supported version for your VMs.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    • Proposed as answer by Leon Laude Wednesday, April 24, 2019 4:42 PM
    Tuesday, April 23, 2019 5:12 PM
  • Hi,

    Thanks for posting in our forum!

    I don't think we can change the default version. Judging from the output of your command, your virtual machine is already in the highest version. I haven't found any information about 9.1 in the official documents. It seems that Leon is right. Maybe it's still not released.

    I suggest that if all the virtual machines are working now, we can wait for a while. Microsoft officials may have news about 9.1 in the near future, and then I think we can upgrade the version by that time.

    For more information, you can visit:

    https://docs.microsoft.com/en-us/windows-server/virtualization/hyper-v/deploy/upgrade-virtual-machine-version-in-hyper-v-on-windows-or-windows-server

    Best Regards,

    Daniel


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 24, 2019 7:13 AM
    Moderator