locked
Windows Server 2012 R2 BPA issue RRS feed

  • Question

  • Good day Experts,

    I have recently deployed two Windows Server 2012 R2 Domain controllers to a new site. Everything looks good so I'm currently busy with the final configurations which includes the BPA scans. I have resolved one or two issues so far but I'm struggling to get one of the warnings resolved.

    The following below is the direct text from the BPA warning.

    Title:
    Srv.sys should be set to start on demand

    Severity
    Warning

    Date:
    2013/11/15 10:21:58 AM

    Category:
    Configuration

    Problem:
    Srv.sys is not set to start on demand.

    Impact:
    Client computers will not be able to access file shares and other Server Message Block (SMB)-based network services on this computer.

    Resolution
    Set Srv.sys to start on demand.

                        http://go.microsoft.com/fwlink/?LinkId=246875

    It seems straight forward enough but I cant get any information telling me how to resolve it for Windows server 2012 R2. Even the link provided by the BPA is not correct, or it seems as if Microsoft has not yet populated the actual web link with the warning information. It just displays the following information:

    Windows Server Future Resources        

    Updated: August 10, 2011

    The document that you are attempting to access is not available yet.

    Is there anybody out there that has resolved this error before and can assist me with a resolution?

    Regards

    Saturday, November 16, 2013 3:59 PM

Answers

  • Hi,

    Test to set the startup type of Server service to "Automatic" and make sure this service is running.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, November 19, 2013 9:22 AM

All replies

  • Good day Experts,

    I have recently deployed two Windows Server 2012 R2 Domain controllers to a new site. Everything looks good so I'm currently busy with the final configurations which includes the BPA scans. I have resolved one or two issues so far but I'm struggling to get one of the warnings resolved.

    The following below is the direct text from the BPA warning.

    Title:
    Srv.sys should be set to start on demand

    Severity
    Warning

    Date:
    2013/11/15 10:21:58 AM

    Category:
    Configuration

    Problem:
    Srv.sys is not set to start on demand.

    Impact:
    Client computers will not be able to access file shares and other Server Message Block (SMB)-based network services on this computer.

    Resolution
    Set Srv.sys to start on demand.

                        http://go.microsoft.com/fwlink/?LinkId=246875

    It seems straight forward enough but I cant get any information telling me how to resolve it for Windows server 2012 R2. Even the link provided by the BPA is not correct, or it seems as if Microsoft has not yet populated the actual web link with the warning information. It just displays the following information:

    Windows Server Future Resources        

    Updated: August 10, 2011

    The document that you are attempting to access is not available yet.

    Is there anybody out there that has resolved this error before and can assist me with a resolution?

    Regards

    • Merged by Vivian_Wang Monday, November 25, 2013 6:17 AM replicated
    Friday, November 15, 2013 11:18 AM
  • The same issue for me.
    Friday, November 15, 2013 3:46 PM
  • This is very odd and unfortunate that a system was released with a BPA issue for which there is not enough documentation online to resolve the issue?
    Saturday, November 16, 2013 3:56 PM
  • Same issue for me too!
    Sunday, November 17, 2013 12:09 AM
  • Hi ,

    Thank you for posting your issue in the forum.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Best Regards,

    Andy Qi

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Andy Qi
    TechNet Community Support

    Monday, November 18, 2013 9:57 AM
  • Me Too...
    Monday, November 18, 2013 10:51 AM
  • Hi,

    Test to set the startup type of Server service to "Automatic" and make sure this service is running.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, November 19, 2013 9:22 AM
  • Good day Laura,

    This service is already set to start Automatically and is running. This is just a warning in BPA, but I'm not sure if this is a general problem with Server 2012 R2 as I have seen many other people complaining about the same issue. I have seen this same error on all my Windows Server 2012 R2 deployments thus far.

    Tuesday, November 19, 2013 10:33 AM
  • I seem to be having the same issue in my environments running Server 2012 R2 as well.

    Tuesday, November 19, 2013 10:15 PM
  • Hi,

    I've tested in my environment and successfully reproduced the issue. I think this warning is misinformation, it won't have real impact to our systems. With this warning, the file shares are still available. As we know, BPA has improved a lot since server 2008, new scan scripts are added in each new system version. I'm not sure if this is a bug or something, I will provide this information with our product team for further analysis.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, November 20, 2013 9:05 AM
  • Same issue here. 2012R2, freshly installed.

    Configured as a print (and document) server.

    Wednesday, November 20, 2013 1:28 PM
  • I'm looking for the resolution as well. How to enable SRV.SYS to Start on Demand...or is that not the correct thing to do with server 2012 R2?
    • Proposed as answer by Richard C. Cruz Thursday, September 25, 2014 8:22 PM
    • Unproposed as answer by Richard C. Cruz Thursday, September 25, 2014 8:23 PM
    Sunday, November 24, 2013 10:31 PM
  • Hi SeatacAdmin,

    Please refer to my other thread regarding this issue where I also refer to the same BPA warning. http://social.technet.microsoft.com/Forums/windowsserver/en-US/db3836ac-abca-4e3d-b3dc-e3aa327f6a82/windows-server-2012-domain-controller-in-a-windows-server-2003-forest?forum=winserverDS

    It does not seem as if there is a definitive answer at this stage, but a lot of other people are also experiencing the same issue.

    Monday, November 25, 2013 5:33 AM
  • Just saw this in the BPA analyzer as well and Google pointed me to this discussion. Sounds like a problem with the BPA actually. The Server service is set to start automatically and not manual or on demand (whatever "on demand" might be). I'm assuming this is a bug in the BPA as the Server service should always be running on file server or DC.
    Wednesday, November 27, 2013 3:49 PM
  • Hi David,

    I agree that it seems like a BPA error which is unfortunate as we can then not trust the output of BPA until this has been resolved.

    @Microsoft - Is there any feedback to this issue as it is clearly a problem that a lot of customers are experiencing.

    Thursday, November 28, 2013 6:45 AM
  • Start REG_DWORD value should be set to 3 (instead of 2) in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\srv registry key

    Premier Field Engineer | Active Directory

    • Proposed as answer by Marzzie Thursday, December 5, 2013 1:34 PM
    Tuesday, December 3, 2013 5:57 PM
  • Had the same issue. The regkey proposed bu Maxim works for me
    Thursday, December 5, 2013 1:34 PM
  • This makes sense but it sounds like you're suggesting we should set the Server service to start manually. That's the first time in Windows Server that it's been suggested. There are a few services dependent on this that I'd be worried about - Netlogon & DFS Namespaces, for example. I assume the service will start up when these are requested.

    On the one hand it makes sense to have a slimmer set of running services but on the other hand this is a core service on a Windows server and I assume we would want to have it running to handle requests quickly. This reg key would fix the issue called out in the BPA but have other effects. Is this a new recommendation from Microsoft suggesting we set the startup type of the Server service to Manual?

    Separate question - if this service is set to Manual and is started up by some process then will it stop if it's not used for some time? That's outside the scope of this discussion but I do want to consider all effects.

    Thursday, December 5, 2013 2:22 PM
  • I have to agree with David. It sounds more like a hack just to get rid of the BPA issue instead of solving the problem in BPA itself? Is this the official response and recommendation from Microsoft for all Server 2012 R2 deployments?
    Friday, December 6, 2013 7:25 AM
  • Andy,

    What have you found about this issue?

    Thursday, December 19, 2013 12:18 AM
  • Same issue for me here too. But it only showed up on one of my servers (Certificate Services server). None of the other servers show this one...

    Friday, December 20, 2013 4:31 AM
  • I had same prbm. Solved removing the " Management Service" of IIS ...
    • Edited by Greg-D Sunday, December 22, 2013 11:29 AM
    Sunday, December 22, 2013 11:26 AM
  • I noticed by yesterday. If you running a Windows server 2003 in your domain and you changed this setting on your Windows server 2012 system. You have to reboot your system to activate the key.

    The DFS BPA indeed cleared the message before the reboot. But the troubles starts after the reboot.
    With this setting you won't be able to access any share anymore of the Windows server 2012 system in your domain from a Windows server 2003.

    So in case you have a Windows server 2003 in your domain, leave the value on 2 instead of the given solution above on 3.

    Friday, January 31, 2014 6:56 AM
  • From an elevated command prompt use sc config to modify the value of the srv.sys service in the registry to start on demand.

    C:\Windows\system32>sc config srv start=demand

    [SC] ChangeServiceConfig SUCCESS

    For more on sc config: http://technet.microsoft.com/en-us/library/cc990290.aspx

    • Proposed as answer by Matt Tewksbary Tuesday, February 4, 2014 5:48 PM
    Tuesday, February 4, 2014 5:47 PM
  • Can anyone explain why it should be set to "demand"?

    According to this page http://technet.microsoft.com/en-us/library/cc990290.aspx

    demand - Specifies a service that must be started manually. This is the default value if start= is not specified.

    So changing the service to Manual, should clear the BPA

    That seems a little strange for that service!

    • Proposed as answer by johndev1 Tuesday, April 29, 2014 1:38 PM
    • Unproposed as answer by johndev1 Tuesday, April 29, 2014 1:47 PM
    Tuesday, March 11, 2014 12:27 PM
  • Now the really interesting thing for me here is: Setting srv.sys to manual startup of course clears the corresponding BPA warning, but funny enough creates a new one: Warning: srv.sys shpuld be running...

    The pointer promising more information actually ends in nirvana. Looks like the only option i have is to choose which warning i prefer. Given that choice i think i decide for automatic startup....

    • Proposed as answer by Asdfghjkl4578 Thursday, August 18, 2016 9:40 AM
    Tuesday, March 11, 2014 2:00 PM
  • Kindly Refer to this link below:

    This BPA message is erroneously produced when the SMB 1.0 feature has been removed from Windows Server 2012.  SMB 1.0 is required for older clients, such as Windows XP.

    http://social.technet.microsoft.com/wiki/contents/articles/21104.srv-sys-should-be-set-to-start-on-demand.aspx

    Friday, May 9, 2014 6:03 PM
  • type this command on cmd

    sc config srv start=demand

    • Proposed as answer by M.Martens Friday, October 10, 2014 9:29 AM
    Thursday, September 25, 2014 8:21 PM
  • This is the solution!! Thanks!!
    Tuesday, December 23, 2014 5:32 PM
  • This works. Thanks!
    Thursday, January 7, 2016 10:14 PM