none
Windows 7 network connection to server2003 slow browser and slow sql query.

    Question

  • Hi

    (I have windows 7 ultimate with the latest sp and updates. The server 2003 also is completely up to date.)

    I have a laptop that i take with me to all my clients. Many of my clients have server2003 machines.

    I have no problem plugging into their networks and mapping drives to the server 2003 machines and browsing folders.

    I have one client though that when i connect to their network, I get amazingly slow to the point of non functional, browsing but only on their server 2003 machine.

    There are other win 7 machines that do not have this problem on this particular network.

    I can map a drive to any workstation in that network and browse normally.

    To demonstrate the problem, i simply run cmd.exe and go to a mapped drive. There i do a dir command. The data comes at me only after 5 seconds, and only some of the data. After another 5 seconds, some more data comes. and so on until the directory is completely listed.

    Another way to demonstrate the problem is to use explorer to browse the folder structures. Again there seems to be 5 second delays in the middle of the process. after which chunks of data displays. eventually the entire folder displays, but you get about 75 files at a time with the 5 second delay in between.

    Another way to demonstrate the problem is if i open sql server management studio and run a simple query. If the query take a fraction of a second to run from another workstation, then it takes 5 seconds (exactly) on mine. It i re-run the same query, it still takes 5 seconds even though it is probably cached.

    Another way it shows up is if i run remote desktop to the server. The screen takes a long time to get there. Once there, its hard to see the 5 second delays, but they are there if you look for them. On the same network if i remote desktop another workstation and then remote the server from inside the first remote, then it works well. As in nested remote sessions.

    Since the server seems to have no problem with the 50 other machines on the network, it seems that the problem is with my laptop. BUT!! Since my laptop does not have this problem on any other network with a server 2003 machine, then it seems to be this network. BUT!!! i don't have a problem with any workstation on this network, Just with this particular server 2003 unit.

    So where do i go from here.

    I have tried Microsoft network monitor but can't make heads or tails out of it.

    I can see the 5 second gaps when i click on "my traffic", but i cannot figure out if it has anything to offer so here i am asking this forum.

    Thanks

    Jerry C

     

    Tuesday, April 26, 2011 3:29 AM

Answers

  • Disabling tcp autotuning was fix for us:

    netsh interface tcp set global autotuninglevel=disabled


    • Marked as answer by JerryCici Wednesday, May 11, 2011 2:31 PM
    Thursday, May 5, 2011 1:44 PM
  • Thank you NineBelow and Others.

    Here is my complete solution

          netsh int tcp set heuristics disabled

          netsh int tcp set global autotuninglevel=disabled

    After Months of searching and experimenting, my issue is resolved.

    As a plus, even my VPN access is so much faster.

    Nine Below pointed me in the right direction. It is Important to know that heuristics must be disabled in order for autotuning to no be overridden

     

    Thanks

    Jerryc

    • Marked as answer by JerryCici Wednesday, May 11, 2011 2:31 PM
    Wednesday, May 11, 2011 2:31 PM

All replies

  • Hi ,

    Its good that you have taken netmon traffic, but you would be only be able to read them if you understand the SMB protocol stack and map that to the upper TCP layer.

    First step is to check if that particular windows 7 exhibits the behavior in safe mode with networking ? , if it , please let us know.

    Tuesday, April 26, 2011 4:10 AM
  • HI Customer,

         Please try to disable your laptop wireless NIC and use network cable to connect your network.


    Regards, Rick Tan

    Wednesday, April 27, 2011 8:54 AM
    Moderator
  • I'm experiencing the same issue. from Windows 7 sp1 (patches only recently added on Friday on servers but all servers have had them applied but only the one mentioned seem to struggle

     

    Slow RDP to 1 w2k3 server (DC/File server)

    Slow file access to the same server

    Any network resource - we use Teamviewer to remote support and now have problem connecting etc with this)

     

    I have logged a call with MS to see what they say

    Wednesday, April 27, 2011 9:41 AM
  • Hello

    Thanks to anyone who may offer suggestions.

    I finally was on site at my clients and the delay happens even in safe mode.

    For me the biggest clue is in the directory browser and sql queries.

    The 5 second is obvious.

    It is mostly 5 seconds sometimes 10 seconds or even 15 but never 7 or 12.

    This tells me that something is timing out after 5 seconds and then letting the command procede.

    If the result data requires another round trip, then another 5 seconds is wasted.

    I usually connect remotely using vpn. But the VPN is not the culpurt as it happens when i am there as well.

    when i am there, i am plugged into theie network with a t1000 (gig) rj45 connection. (and i have disabled my wireless).

    As i stated I can browse other machines with no problem. I can browse other server2003 no problem, Other win 7 machines on this network can browse this server2003 no prob. It is the particular combination of my win 7 machine and that particular server 2003.

    I believe the solution lay with my machine.

    My coworker plugged his laptop into the same port as me and has no problems browsing or querying.

    Thanks

    Jerry C

     


    Tuesday, May 3, 2011 10:09 PM
  • Disabling tcp autotuning was fix for us:

    netsh interface tcp set global autotuninglevel=disabled


    • Marked as answer by JerryCici Wednesday, May 11, 2011 2:31 PM
    Thursday, May 5, 2011 1:44 PM
  • Thank you NineBelow and Others.

    Here is my complete solution

          netsh int tcp set heuristics disabled

          netsh int tcp set global autotuninglevel=disabled

    After Months of searching and experimenting, my issue is resolved.

    As a plus, even my VPN access is so much faster.

    Nine Below pointed me in the right direction. It is Important to know that heuristics must be disabled in order for autotuning to no be overridden

     

    Thanks

    Jerryc

    • Marked as answer by JerryCici Wednesday, May 11, 2011 2:31 PM
    Wednesday, May 11, 2011 2:31 PM
  • This is probably a stupid question but did you run the netsh commands on teh PC or the server?

    Thanks

    Paul

    Tuesday, March 20, 2012 6:23 PM
  • the above setting / changes fixed the slow issue , but any one let me know why we have this behavior
    Tuesday, March 27, 2012 4:29 PM
  • Hi

    The netsh commands were run on the PC (Laptop)

    Also since my last post, i have discovered a few other win7 pc's that have this issue and the netsh settings have fixed those PC's as well.

    Friday, March 30, 2012 10:17 PM
  • Does i require reboot after changing the settings? 

    Thanks in advance. 

    Monday, April 9, 2012 9:46 PM
  • JerryCici do you know what you are disabling?  I am worried what set heuristics disabled and what autotuninglevel=disabled is disabling.

    I find that on my Microsoft Windows 7 Professional SP1 x64 that going to Microsoft Windows Server 2003 R2 Standard Edition SP2 x86 - Physical Servers will be resolved by going into a Command Prompt as Administrator and running netsh interface tcp set global autotuninglevel=disabled  I have not heard about the heuristics.  I am nervous about pushing this out to the rest of the company as I don't know what these are actually doing that might cause others to have issues.

    Friday, June 1, 2012 5:24 PM
  • I believe that heuristics is an automatic realtime tweaking of the netsh set global settings. It was explained to me that this heuristics layer overrides the autotuning function. I believe that autotuning came in under XP and heuristics came in under win 7 or possibly vista. Under XP i have never had any problems but with win 7, sometimes on some machines the above commands fixes the extreme slowdown.

    I have read several explainations as to why it fixes the issue, and no doubt some goodness in the heuristics setting will be disabled, but i have solved about 10 or 12 machine access problems and expect to bump into more as my clients eventually retire the XP machines. Also I dont know if the problem exists going to a server 2008 machine. You can always undo a client's win7 settings change. 

    Good Luck

    Jerry C

      
    Thursday, June 7, 2012 7:35 PM
  • Thank you for the information.  I had the same problem and will see if this solution works.  Aaron.
    Thursday, August 1, 2013 10:14 PM
  • hi  is this applied on client machine or  server machine? asking just to be sure.. thanks
    Monday, April 2, 2018 9:53 AM