GPP - Group Policy Printer Preferences - Access Denied


  • Hi All,

    I have two GPO preferences for installing printers:

    • Local_Print_Pref which install shared printer from a local print server (\\servername\sharedprintername)
    • Remote_Print_Pref which install TCP/IP printer from a remote print server

    (I don't explain why I've these both GPO but there are mandatory)

    Since several days, I've a warning in the Application Log:

    "The Description for Event ID (4098) in Source (Group Policy Printers) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE=flag to retrieve this description; see Help and Support for details. The following information is part of the event: user; <Object name inside the GPP>; <GPO name> {GPO ID}; 0x80070005 Access Denied"

    I've tried to run the GPP in "User mode context" but nothing happened. Same problem.

    I've tried to search some informaiton about "Access Denied" and the error code " 0x80070005" but no way.

    Tuesday, February 07, 2012 9:00 AM


  • Hi All,

    I found a cause of my problem:

    We have virtualized all print servers. The server's name has been changed but we have created a DNS alias <old print server name> CNAME <new print server Name>

    But it seems the DNS resolution doesn't working properly for the GPP Printers. In the Local_Print_Pref, I've modified the print server name by the new one and it works.

    • Example before:

      PRT1234 ; \\prtsrv01\PRT1234
      DNS Cname record: prtsrv01 --> newprtsrv01

      In this case, it doesn't work

    My question is: Why it doesn't work for the first example?

    • Marked as answer by Khalydros Tuesday, February 07, 2012 9:07 AM
    • Edited by Khalydros Tuesday, February 07, 2012 9:07 AM
    Tuesday, February 07, 2012 9:07 AM