locked
Change RDWeb Application port in winserver 2012 RRS feed

  • Question

  • I use regedit change RDP-TCP portnumber from 3389 to 63385 (in teminal server of server 2012), and i can remote my server by this port.

    But when I run program in RD Web Application  it still use port 3389 so it cannot connect (in .rdp file wrote: "server port:i:3389"), I run RDWeb App in local so i am not want use RD gateway .

    Please help me change this port for RD session host server

    (In server 2008 I can do it by change port in RemoteApp Deployment Settings/ RD session host server / RDP port. In server 2012 I cannot find this GUI)


    • Moved by Santosh Bhandarkar Thursday, July 25, 2013 4:25 AM Moved from Server General Forum
    Thursday, July 25, 2013 3:56 AM

Answers

  • Ok now I find the solution, onnly run follow command in powershell (as admin):

    Set-RDSessionCollectionConfiguration –CollectionName QuickSessionCollection –CustomRdpProperty "server port:i:63385"

    • Marked as answer by VanNam1976 Thursday, July 25, 2013 4:33 PM
    Thursday, July 25, 2013 4:32 PM

All replies

  • Dear Customer,

     

    Please configure RD Session Host server settings:

    On the RD Session Host server, open RemoteApp Manager. To open RemoteApp Manager, click Start, point to Administrative Tools, point to Remote Desktop Services, and then click RemoteApp Manager.

    In the Actions pane of RemoteApp Manager, click Remote Desktop Session Host Settings. (Or, in the Overview pane, next to Remote Desktop Session Host Settings, click Change.)

    On the Remote Desktop Session Host tab, under Connection settings, accept or modify the server name and the Remote Desktop Protocol (RDP) port number.

     

    For detail information, refer to the following article:

    Configure RD Session Host Server Settings

    http://technet.microsoft.com/en-us/library/cc733043.aspx

    Hope the information above is helpful!

    Thursday, July 25, 2013 8:31 AM
  • Dear Tom Zhang

    Sorry , may be your instruction only apply for server 2008. In server 2012  can cannot find "RemoteApp Manager" GUI .Only have Collection Properties and deployment Properties ;RemoteApp programs attach to collection

    Thanks you

    Thursday, July 25, 2013 3:15 PM
  • Ok now I find the solution, onnly run follow command in powershell (as admin):

    Set-RDSessionCollectionConfiguration –CollectionName QuickSessionCollection –CustomRdpProperty "server port:i:63385"

    • Marked as answer by VanNam1976 Thursday, July 25, 2013 4:33 PM
    Thursday, July 25, 2013 4:32 PM
  • This property will save in registry hkey local machine\software\microsoft\windows n t\currentversion\terminal server\centralpublishedresources\publishedfarms\QuickSessionCollection\Deploymentsetting

    (as String Value, type REG_SZ)
    Friday, July 26, 2013 1:31 AM