none
File associations after migration

    Question

  • Hi

    I'm using ADMT 3.2 to migrate Windows 8 machines to a new domain within the same forest and I know that it's not 100% supported but I wonder if anyone got the same problem as me.

    The Migration finish successful without any problems but when the user logs on the file associations are lost and even after choosing program the question question turns up again the next time the user tries to start the program by clicking on a jpg file or an xls file

    And yes the user profiles are migrated.

    Any ideas?

    Will there be a ADMT 3.X that supports Windows 8 and Windows 2012?

    Thanks

    Magnus





    Tuesday, October 29, 2013 12:04 PM

Answers

All replies

  • Hi,

    For File Associate issue, is should not related to ADMT.

    Please check the following key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.xls

    Compare with the original system and see if anything changed. If the key is missing, you could export it from a working system and import to your new system.

    In addition, for ADMT supports Windows 8/2012, as you said currently the newest version still not support Windows 8/2012 but I believe we will get a new version in nearly feature.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forum a great place.


    Thursday, October 31, 2013 2:35 AM
    Moderator
  • How are things going? Please let us know if there is any progress.

    If you have any feedback on our support, please send to tnfsl@microsoft.com.

    Thursday, November 7, 2013 2:09 AM
    Moderator
  • Hi, Sorry for resurrecting an old post, but I wondered if you ever found a way round this - We are performing an ADMT 3.2 (updated month or so ago to allow support for 2012 and win 8) and running into similar issues....

    The ADMT migration runs perfectly, without issues, but upon completion when a user logs into their PC all their file associations are broken - reg keys under HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts all seem intact, but until I go in and delete the UserChoices reg key I cannot set these file associations again!

    Looking at a PC before and after migration, there doesn't seem to be any changes (other than the new user is added to the permissions obviously)!

    Interestingly, after deleting user choices, I am still not prompted to set "default program" when I double click an affected file type...I have to right click and "Open With" before I see the checkbox to set the default!

    Very strange behaviour and must be something to do with the security translation of the registry as part of ADMT if you ask me?

    I would be interested to hear anyone's view's on this issue as you and I (so far) seem to be the only ones affected!

    Thanks

    Paul

    • Proposed as answer by _Alfredo27_ Monday, January 11, 2016 11:58 PM
    Friday, September 12, 2014 10:20 AM
  • Thx pauladam !!!!!!
    Tuesday, January 12, 2016 12:00 AM
  • Confirmed known issue when using ADMT, Move-ADObject, Quest, and other tools  to migrate users from a source to destination domain on Windows 8, Windows 8.1 and Windows 10 clients. Root cause is understood. Mitigation is complex On top of failing to retain custom file associations, Win8* users may also lack  permissions to write to the registry key that stores files associations so any updates are not retained. Microsoft needs to understand customer impact (i.e. # of seats impacted) so it can prioritize work. How viable is it to leverage the policy setting

    Computer configuration\administrative templates Windows Components\File Explorer\Set a default associations configuration file
    Monday, January 25, 2016 5:56 PM
  • I too am experiencing this issue and I cannot seem to resolve it. I have tried to set a GPO and isolate it (block inheritance) to just one applied policy on an OU where I have migrated a test machine to. The policy I implemented sets the default file associations using: Computer configuration\administrative templates Windows Components\File Explorer\Set a default associations configuration file

    Using the default dism.exe file, as the policy suggests, seems to hold no results even after verifying that the policy was successfully applied to the computer object. 

    Regardless of this implementation, various file types i.e. .jpg, .bmp, all prompt with an inquiry asking which program you would like to use to open the file. 

    Is this issue unresolved? 

    Tuesday, January 26, 2016 11:37 PM
  • Hi

    Any update???

    Regards

    Thursday, September 22, 2016 2:51 PM
  • Go to registry “HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts" remove user permission and add, resulted for me.
    It is not the best solution, but...

    Thursday, September 22, 2016 4:46 PM