none
Using ADK to deploy later Operating Systems RRS feed

  • Question

  • Hi all.

    I have a 2012 R2 VM running inside Hyper-V. I have downloaded the 20126 ISO and mounted the file. My objective is to create a Nano VHD file. After importing the Nano PS module i run the following command:

    New-NanoServerImage -MediaPath g:\ -BasePath .\Base -TargetPath ".\NanoImage\Nano02.vhd"

    The command appears to run but soon errors with the following error:

    WARNING: Terminating due to an error. See log file at: C:\Users\Administrator\base\Logs\2017-01-09_09-23-38-80
    Dism.exe available from PATH is not supported for servicing of the target image. Download appropriate ADK or run this
    cmdlet from a newer Windows build.

    So I can figure what the error means. I am using ADK from 2012 R2 trying to deploy a later OS? So, I downloaded the latest Windows 10 ADK and installed all options. I rerun the PS command and I get the same error. My question is should this work with the newer ADK download or do I need to have a 2016 build to run the command? 

    Thanks all. 


    • Edited by Palmer_001 Monday, January 9, 2017 9:41 AM typo
    Monday, January 9, 2017 9:40 AM

Answers

All replies