none
RD Connection Broker - Farm name and RD Session Host servers not listed

    Question

  • Hello,

    I have 2 RDSH servers configured and 2 RDCB servers configured in a cluster.  The 2 RDSH servers are configured in the same farm.

    The issue is that when I use Remte Desktop Services Manager and I import from the connection broker - the RDCB is imported however the farm name is not listed - nor are the RDSH servers... it just says 'RD Conection Broker (RDCBResource Name)'.

    Broker services are working okay - however we are not able to veiw active connections farm wide.  We are able to see active sessions when we look directly on the individual RDSH servers.

    Any idea? 

     

     

    Wednesday, August 25, 2010 9:00 AM

Answers

  • Hi Steven

     

    Please check the issue with the following steps:

     

    1.     According to the following article, check the process you set up Windows Server 2008 R2 RDS farm with Windows Server 2008 Session Broker:

    TS Session Broker Load Balancing Step-by-Step Guide
    http://technet.microsoft.com/en-us/library/cc772418(WS.10).aspx


    Especially, have you add the RD Session Hosts into Session Directory Computers group?

    2.     As the second step, please check the model of the RD Session Host:

    a. On the server with Session Host role, click Start,  Administrative Tools, Remote Desktop Services and select the Remote Desktop Session Host Configuration.

    b. In the Remote Desktop Session Host Configuration, under the Edit Settings area, double-click Member of farm in RD Connection Broker.

    c. Click Change Settings under RD Connection Broker tab.

    d. Confirm that Farm Member is selected and the correct name is listed at RD Connection Broker server name. If not, please correct them.

    e. Check the issue again.

    3.  As the third step, please check the network connectivity between RD Connection Broker and RDSH servers.

          You can refer to the following article

          http://technet.microsoft.com/en-us/library/cc775237(WS.10).aspx

     

    Let us know the result if possible. Thanks.

     

    Wilson Jia

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Wilson Jia Friday, September 03, 2010 2:56 AM
    Thursday, August 26, 2010 2:51 AM

All replies

  • Hi Steven

     

    Please check the issue with the following steps:

     

    1.     According to the following article, check the process you set up Windows Server 2008 R2 RDS farm with Windows Server 2008 Session Broker:

    TS Session Broker Load Balancing Step-by-Step Guide
    http://technet.microsoft.com/en-us/library/cc772418(WS.10).aspx


    Especially, have you add the RD Session Hosts into Session Directory Computers group?

    2.     As the second step, please check the model of the RD Session Host:

    a. On the server with Session Host role, click Start,  Administrative Tools, Remote Desktop Services and select the Remote Desktop Session Host Configuration.

    b. In the Remote Desktop Session Host Configuration, under the Edit Settings area, double-click Member of farm in RD Connection Broker.

    c. Click Change Settings under RD Connection Broker tab.

    d. Confirm that Farm Member is selected and the correct name is listed at RD Connection Broker server name. If not, please correct them.

    e. Check the issue again.

    3.  As the third step, please check the network connectivity between RD Connection Broker and RDSH servers.

          You can refer to the following article

          http://technet.microsoft.com/en-us/library/cc775237(WS.10).aspx

     

    Let us know the result if possible. Thanks.

     

    Wilson Jia

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Wilson Jia Friday, September 03, 2010 2:56 AM
    Thursday, August 26, 2010 2:51 AM
  • Dear Customer, I just wanted to say hi, and to see how things are going. I haven't heard back from you yet and I was wondering if there are any updates on the service request. Thanks. Sincerely Wilson Jia
    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, August 30, 2010 7:33 AM