none
Windows Server 2012 VM Windows Update is slow RRS feed

  • General discussion

  • I have a Windows Server 2012 Standard VM running in VMware 9.  This is a domain controller, and I am not an administrator.

    After starting the server from a snapshot, I try to open Windows Update, and it is so painfully slow that Windows Update just seems like it has hung.

    I am able to use the internet without any slowness on the same machine.

    The OS is still very responsive, and everything I try to use is fast.  It is just Windows Update that is so slow.  After 45 minutes, I was told that I have 26 updates to install.  I started that, and it took 30 minutes to install the first update.

    Does anyone know what the problem might be?

     

    Friday, March 29, 2013 4:52 PM

All replies

  • Windows update are going very slow, I have multiple Windows 2012 VMs on VMware workstation and it takes some time for the updates to finish.

    Friday, March 29, 2013 7:54 PM
  • Hi Vegan Fanatic,

    Thanks for the information.  This seems to be something other than bandwidth to Windows Update servers.  I just updated Windows 8 Pro in a VM on the same host machine, and the Windows Update Control Panel window was responsive, it took about 10 minutes to download and about 10 minutes to install 30 updates (460MB). 

    On Windows Server 2012 Standard, the Windows Update Control Panel window was completely unresponsive (I waited about 1 hour during one attempt).  I couldn't cancel it, close it or interact with it.  It was just frozen.  I tried 5 times over the last two days to update the machine.  I couldn't even stop the Windows Update service.  The entire machine is responsive with the exception of Windows Update.

    Only one time (my first post) did I ever see the Windows Update window ever respond and it took 45 minutes.  Even then I couldn't cancel or interact with Windows Update, and I couldn't close the window.  I couldn't even kill it via Task Manager.

    Any other ideas as to what is wrong with Windows Update on Windows Server 2012 Standard?

    I have three roles (DC, DNS and Fileserver) installed.

    Friday, March 29, 2013 8:52 PM
  • Hi Vegan Fanatic,

    I could not find a newer driver for the OS in VMware.  I was finally able to change from 'Install updates automatically (recommended)' to 'Never check for updates (not recommended)'.  With that change, I don't get the hanging behavior that I was seeing on Friday when I check for updates.  I am happy with that solution since this is just a test environment for me to use for learning.

    As a note, after the change, I was able to download and install over 350MB of updates in less than 15 minutes.  In my mind though, the most important point is that I could interact with the Windows Update dialog while the download and install were occurring.  It was not hanging like it did on Friday.

    Monday, April 1, 2013 5:40 PM
  • What helped me is the folowing command (source http://www.edugeek.net/forums/windows-server-2012/113360-2012-server-windows-updates-extremely-slow.html):

    netsh winhttp import proxy source=ie

    Now it works like charm.


    TomazicM

    Wednesday, July 10, 2013 1:16 PM
  • Well, im glad your environment is special, and licensing is not an issue for you. Could you please explain how that is supposed to help anyone?
    Tuesday, November 12, 2013 6:07 PM
  • I dont have a proxy set up for anything, I wish I could say gold, but no love. 

    Tuesday, November 12, 2013 6:10 PM
  • Same problem, bare metal install. 
    Tuesday, November 12, 2013 6:10 PM
  • Disabling the IPv6 tunnel interfaces worked for me

    Followed the instructions here: http://www.dickson.me.uk/2012/03/20/ipv6-disabling-isatap-and-6to4-in-windows-7/

    Thursday, December 12, 2013 6:44 PM
  • had a similar problem - Hyper-v 20-12, with a 2012VM server - windows update would hang up or stop at download updates (-% forever). Used the following procedure to resolve:

    - disabled windows updates and application experience

    - rebooted

    - deleted all contents in c:\windows\softwaredistribution

    - disabled ipv6 (temporarily)

    - started windows updates and application experience and checked for updates

    - It STILL stayed at "downloading updates" 0 percent - but I watched the size of software distribution

    folder (right-click - properties) and it grew and grew - this meant it was in fact downloading all the updates.- after 20 minutes or soe when the file size would not change (approx 14k files for me)  -  with the processor still bouncing around high - I stopped window updates, changed the settings to "check for windows updates automatically", then clicked the Charms on the right- power - shutdown - and picked UPDATE AND RESTART.

    This installed all the updates, then it worked fine after that manually.

    Saturday, November 1, 2014 3:23 PM
  • Same issue, 2012 Rs Standard on VM Fusion 8.5

    This worked for me @astech, thanks for your post

    Friday, November 24, 2017 2:56 AM