none
Windows 2019 RDS issue RRS feed

  • Question


  • Hello,

    I recently created a 2019 Standard server and purchased 100 2019 User Cals for RDS.  I have several 2016 server clients.  When I run the licensing diagnostics on the 2016 server, I receive two errors: 


    The Remote Desktop Session Host server is in Per User licensing mode and No Redirector Mode, but license server xxxx.xxx.xxx.org does not have any installed licenses with the following attributes:
    Product version: Windows Server 2016
    Licensing mode: Per User


    and


    License server xxxxx.xxxx.xxx.org cannot issue licenses to the Remote Desktop Session Host server because the "License server security group" Group Policy setting is enabled.



    It was my understanding that RDS licenses were backward compatible--checked with several different Msoft documents.  In addition,

    I have looked in both local and domain gpo, and do not see the referenced GPO enabled.


    What also bothers me is that there is no Session Host configuration tool as in previous version--I need to make my changes in local GPO, such as specifying the license server.


    Anyone else facing these issues?
    Monday, February 11, 2019 6:57 PM

Answers

  • Hi,

    When running RD Diagnoser on an RDSH you need to use a domain account with enough rights to access the RD Licensing server.  Typically a Domain Admin account.

    1. Is your 2019 RD Licensing server joined to the domain?  It needs to be joined to the domain so that it can issue Per User RDS CALs.  The computer account for the RD Licensing server needs to be a member of the domain's BUILTIN\Terminal Server License Servers group so that it has enough rights to update the domain user objects.

    2. When logging on to RDSH server, the users need to use a domain account in order for a Per User RDS CAL to be issued.  Please confirm only domain user accounts are being used.

    3. On the RD Licensing server, did you use gpresult to check if the licensing server security group setting is enabled?  You could use below commands in an admin cmd.exe prompt:

    gpresult /h GPReport.htm

    start GPReport.htm

    If the License server security group group policy setting is enabled on the RD Licensing server you will need to add the computer accounts of all the RDSH servers to the RDS Endpoint Servers local group on the RD Licensing server.  Alternatively you could set the policy setting back to Not Configured

    Thanks.

    -TP

    • Marked as answer by rsbst19 Tuesday, February 12, 2019 1:58 PM
    Monday, February 11, 2019 9:05 PM
    Moderator

All replies

  • So I was able to get past the errors above by adding credentials in the licensing diagnostics.  But it still does not pull down a user cal from the licensing server, and my credentials are no longer valid if I log ogg and back on; i.e, the errors return when I log back in unless I specify my high privilege creds.
    Monday, February 11, 2019 7:52 PM
  • Hi,

    When running RD Diagnoser on an RDSH you need to use a domain account with enough rights to access the RD Licensing server.  Typically a Domain Admin account.

    1. Is your 2019 RD Licensing server joined to the domain?  It needs to be joined to the domain so that it can issue Per User RDS CALs.  The computer account for the RD Licensing server needs to be a member of the domain's BUILTIN\Terminal Server License Servers group so that it has enough rights to update the domain user objects.

    2. When logging on to RDSH server, the users need to use a domain account in order for a Per User RDS CAL to be issued.  Please confirm only domain user accounts are being used.

    3. On the RD Licensing server, did you use gpresult to check if the licensing server security group setting is enabled?  You could use below commands in an admin cmd.exe prompt:

    gpresult /h GPReport.htm

    start GPReport.htm

    If the License server security group group policy setting is enabled on the RD Licensing server you will need to add the computer accounts of all the RDSH servers to the RDS Endpoint Servers local group on the RD Licensing server.  Alternatively you could set the policy setting back to Not Configured

    Thanks.

    -TP

    • Marked as answer by rsbst19 Tuesday, February 12, 2019 1:58 PM
    Monday, February 11, 2019 9:05 PM
    Moderator
  • Hi,

     

    Besides the checking points provided by TP, here are related troubleshooting links below that you could refer to:

    [Forum FAQ] Troubleshoot the error “The Remote Desktop Session Host server is in Per User licensing mode and No Redirector Mode”

    https://social.technet.microsoft.com/Forums/en-US/707c9dd9-27a1-431d-ae52-1fa292b1f500/forum-faq-troubleshoot-the-error-the-remote-desktop-session-host-server-is-in-per-user-licensing?forum=winserverTS

     

    Best practices for setting up Remote Desktop Licensing (Terminal Server Licensing) across Active Directory Domains/Forests or Workgroup

    https://support.microsoft.com/en-us/help/2473823/best-practices-for-setting-up-remote-desktop-licensing-terminal-server

     

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, February 12, 2019 9:19 AM
  • So the license diag check utility shows no errors when I run it with the proper creds. All the machines involved are domain joined.

    The issue now is that the 2019 licensing server, with 100 2019 CALS, is issuing 2016 Cals (Built-In Overused).  I thought that it would issue 2019 cals, even though the RDSH is 2016 since the cals were supposed to be backward compatible.

    Is that the expected behavior, or should it be pulling from the 2019 pool?


    • Edited by rsbst19 Tuesday, February 12, 2019 1:06 PM
    Tuesday, February 12, 2019 12:56 PM
  • I think I found my answer here...

    https://blogs.technet.microsoft.com/askperf/2015/05/07/2012-r2-license-server-issuing-built-in-overused-cals-for-2008-r2-session-host-servers/

    Thanks everyone for the help.

    Tuesday, February 12, 2019 1:58 PM