locked
Desktop icons in Server 2008-R2 - bug?

    Question

  • I can't figure out how to get to the desktop ICON check mark boxes in Server 2008-R2.  (Except by using search.)
    I've asked MVPs and folks on Microsoft's server team and no one knows the Control Panel or Desktop Properties method of finding it.

    I've been using seach, but I'd like to know the mouse click method to get to the desktop icons config screen.

    Anyone know how to do it?

    Thanks,
    Douggg

    Thursday, October 01, 2009 5:19 PM

Answers

  • Hi,

     

    Did you mean you can’t find the “Change desktop icons” in Windows Server 2008 R2? If so, you have to install the Desktop Experience feature, then you will be able to find the option in Personalize option.

     

     

    Best Regards,

    Vincent Hu

     

    Friday, October 02, 2009 7:37 AM
    Moderator

All replies

  • Hi,

     

    Did you mean you can’t find the “Change desktop icons” in Windows Server 2008 R2? If so, you have to install the Desktop Experience feature, then you will be able to find the option in Personalize option.

     

     

    Best Regards,

    Vincent Hu

     

    Friday, October 02, 2009 7:37 AM
    Moderator
  • Vincent, you are mistaken.  You do not have to install desktop experiance to have the computer and network icons on the desktop.

    On Server 2008-R2 if you search for "show desktop icons" you can get to the "Change Desktop Icons" to check mark the icons you want to appear.  I'm trying to find out how to mouse click to get to "Change Desktop Icons" without using search.

    Douggg

    Friday, October 02, 2009 3:34 PM
  • Hi,

     

    If you are using Windows Server 2008, you have to right click on Desktop > Personalize > Change desktop icons. You can’t mouse click on Desktop or any other place to get the “Change desktop icons” directly. So does in Windows Server 2008 R2, if you are using Windows Server 2008 R2, you have to install the Desktop Experience feature, and then you can right click on Desktop > Personalize > Change desktop icons (Or you can use search), this is no way to mouse click to get “Change desktop icons” directly.

     

     

    Best Regards,

    Vincent Hu

     

    Monday, October 05, 2009 4:19 AM
    Moderator
  • Vincent,

    Sounds like this is an Easter egg in reverse.  (It's there, it's documented, but you can't get to it the way you could in Server 2003, 2003-R2, 2008, XP, Vista or Win 7. 

    Sound's like a bug.  Do you know if it will be fixed?

    Tuesday, October 06, 2009 6:19 PM
  • Hi Dougg,

     

    I understand that it will be a bit inconvenient that you can’t change the desktop icons without installing Desktop Experience. However, as you know, you can just search "show desktop icons” and you will get it immediately. I think this will be more convenient than you to right lick on desktop …….

     

    Actually, this is not a bug, it’s just a change of GUI in Windows Server 2008 R2.

     

     

    Best Regards,

    Vincent Hu

     

    Wednesday, October 07, 2009 7:53 AM
    Moderator
  • Thank you so much Doug for the answer.  I wasted a lot of time just trying to get the computer icon on my desktop until I finally found this posting.  However, Vincent, come on, are you serious?  I have to install the full Desktop Experience with Aero and everything just to get to a little dialog box that is already there?  Sure, I can get to it if I type in the right incantation into the search box.  If I type in “show desktop icons” I find it, but if I type in “change desktop icons” I don’t.  It is obvious that the user interface was tweaked in this area and this little item fell through the cracks.  You can’t tell me that it was purposely designed that way.  While not a show stopping bug, it is definitely an annoyance that should be fixed to stop wasting peoples’ time.

    John

    Monday, November 23, 2009 1:36 PM
  • John,
    It's definatly a bug and something someone at Microsoft left out of the code in Server 2008 R2.  Wonder if the programer who was suppose to work on this piece of the code was fired and that's why it's not there.   With so many people at Microsoft getting sacked I'm wondering if we will be seeing lots more of these "bugs" or mistakes in their code? 
    Monday, November 23, 2009 3:44 PM
  • Hi Dougg,

     

    I will forward your request to our production group.

     

     

    Best Regards,

    Vincent Hu

     

    Tuesday, November 24, 2009 5:25 AM
    Moderator
  • Vincent,

    I just checked - The ability to add desktop icons is in Server 2008 and was pulled or omited in Server 2008-R2.  The IT Pros I spoke with today said they tried the Server 2008-R2 Desktop Experience and they absoutly hate it.
    Tuesday, November 24, 2009 6:34 AM
  • OK, days of searching (but not in the server search dialog, apparently) finally resulted in a fairly fast yet extremely non-intuitive method for providing two desktop icons on Server 2008-R2. Who ever would think that you need to type a specific phrase into the server search dialog to have the standard desktop configuration dialog box appear? Certainly not me (or the thousands of other people searching for this answer). I can't fathom why it can't be reached from the Control Panel.

    Now that the icons are on the desktop and things "look normal", I realize that the My Computer icon has little value.. the %USERNAME% on %COMPUTERNAME% tweak that we apply to our servers doesn't work (I can't seem to delete the default reg key which has the very informative "Computer" in it), you can't launch Explorer from My Computer, and I'm already getting used to launching the Manage interface from the QuickLaunch area..

    Still, the ability to display AND change the My Computer icon to (at least) the computer name provides a small amount of extra assurance that you're working on the correct server - especially when you're sitting at a KVM console connected to a datacenter full of servers.

    Glenn
    Thursday, November 26, 2009 3:50 AM
  • ...  Who ever would think that you need to type a specific phrase into the server search dialog to have the standard desktop configuration dialog box appear? Certainly not me (or the thousands of other people searching for this answer). I can't fathom why it can't be reached from the Control Panel.
    ....

    Glenn

    Glenn I belive that' called a bug.
    Thursday, November 26, 2009 5:36 AM
  • I also find this bug very annoying. I can't believe it is so complicated to include the "Computer" icon on Windows 2008R2 Server desktop. (But it is true)

    Did someone at MS had told the famous phrase "It is not a bug, it is a feature" about this ?
    Tuesday, January 12, 2010 3:52 PM
  • I also find this bug very annoying. I can't believe it is so complicated to include the "Computer" icon on Windows 2008R2 Server desktop. (But it is true)

    Did someone at MS had told the famous phrase "It is not a bug, it is a feature" about this ?

    Actually to include "Computer" icon on desktop in Windows 2008 R2 is quite simple: click "Start" menu, right click "Computer" item and select "Show on desktop". What is funny is that this philosophy does not work on "Network" item. There is no "Show on desktop" selection available for "Network" item. "Is this a feature or a bug: that is the question ..." somebody said once.

    - Mitja
    Wednesday, January 20, 2010 9:54 AM
  • Hi Dougg,

     

    I understand that it will be a bit inconvenient that you can’t change the desktop icons without installing Desktop Experience. However, as you know, you can just search "show desktop icons” and you will get it immediately. I think this will be more convenient than you to right lick on desktop …….

     

    Actually, this is not a bug, it’s just a change of GUI in Windows Server 2008 R2.

     

     

    Best Regards,

    Vincent Hu

     


    Vincent,

    I have Desktop Experience installed but I'm getting the following error when I click "Show Desktop Icons".. 

    "Your system administrator has disabled launching of the Display Control Panel."

    I am using 2008 R2 and this is a fresh install.  I have tried from two accounts which are both system Administrators and the computer is not part of any domain that would be enforcing group policy.  Is this a bug too?

    Thanks.
    Tuesday, January 26, 2010 8:33 PM
  • Vincent, thank you for getting back to us on this.   Why after 20 years and having this feature 27 different products did the Product group think we didn't want it any more unless you typed the hidden phrase? 

    The feature is still in there they just removed the menu item so now it's an Easter Egg.

    I beleive the logical answer is someone on the Product Team screwed up and forgot to put it in.

    Would you please tell them that their customers (the Server Admins) who use the product consider it a bug that it's missing and ask them give us back the feature.

    Thank you

    Wednesday, January 27, 2010 4:19 AM
  • Right click on desktop, choose "Personalize", "Change desktop icons" is shown on the left panel.

    OS Name:                   Microsoft Windows Server 2008 R2 Enterprise
    OS Version:                6.1.7600 N/A Build 7600
    Thursday, February 11, 2010 4:58 AM
  • Ferro Fang,
    Have you installed a the Desktop Experiance?

    Thursday, February 11, 2010 5:42 AM
  • Also, what happened to the aesthetically pleasing icons from Windows 2008?

    The new Control Panel icon in R2 is hideous. I tried to replace it via Shell32.dll and the old one is not included!  Finally the icons were nearing photo-realism and now they've taken a huge step backwards.

    The Network icon was very polished in 2008 and now looks very low-resolution with a hairy globe behind it.

    The icon representing the public network in the Network and Sharing Center is now some hideous low-resolution park bench (icon) with a black blob underneath it that is supposed to represent a shadow.  What were they thinking?  R2 looks like an unfinished product.

    The Library icon is just plain goofy and low-res.  It's 2010 - our server hardware (and remote sessions) can handle nicer icons for goodness sake!  After all, Server Manager is now so overcolored and heavy that it takes a long time to expand certain items (Event Viewer is much snappier in Windows 2003).  It's odd that certain elements of the UI have been made overly rich and others have become more sparse.  It's hugely inconsistent. 

    The R2 interface looks like a toy, whereas things were looking much nicer in Windows 2008.  Network administrators take pride in working on their servers, and I hate to say that every time I remote into my R2 servers and navigate the Playskool GUI I cannot help but feel that the unfinished, juvenile interface betrays the elegant technology underneath.
    Friday, February 19, 2010 2:41 PM
  • Sorry for not checking if Desktop Experiance installed on the server. It's a test server not installed by me.

    Yes,  Desktop Experiance was installed when "Change desktop icons" was shown.

    After uninstalling Desktop Experiance, "Personalize" can't be found by right clicking on the desktop.
    Friday, February 26, 2010 1:27 AM
  • I also find this bug very annoying. I can't believe it is so complicated to include the "Computer" icon on Windows 2008R2 Server desktop. (But it is true)

    Did someone at MS had told the famous phrase "It is not a bug, it is a feature" about this ?

    Actually to include "Computer" icon on desktop in Windows 2008 R2 is quite simple: click "Start" menu, right click "Computer" item and select "Show on desktop". What is funny is that this philosophy does not work on "Network" item. There is no "Show on desktop" selection available for "Network" item. "Is this a feature or a bug: that is the question ..." somebody said once.

    - Mitja

    Right click and select "Show on desktop" is really the simplest way we can use for the moment.

    As for "Network" icon, I choose to drug and drop it to desktop to create a shortcut.
    Thursday, March 04, 2010 5:26 AM
  • Right click and select "Show on desktop" is really the simplest way we can use for the moment.

    As for "Network" icon, I choose to drug and drop it to desktop to create a shortcut.

    This doesn’t work for the other ICONs the only way you can get to the Desktop Icon screen is to use search.  This feature has been in ALL versions of Windows since Windows NT/95.  It appears a programmer forgot it in Server 2008R2.

    IT Pros consider this an annoying bug in Windows Server 2008R2.

    Thursday, March 04, 2010 4:55 PM
  • Try adding the Computer icon by right clicking the Computer link in the Start menu and selecting "Show on desktop".

    Now go to the desktop, right click the newly added icon and select "delete".

     

    Then you get

    "Are you sure you want to delete the Computer icon from your desktop?
    To restore it later, go to Personalization in Control Panel."

     

    Rrrrrgh! A bug.... definitely :-)

     

    Don

    Monday, April 12, 2010 12:31 PM
  • Hi Doug

    If you just want the icons on the desktop without the "install features" nonsense try this:

    HKEY_USERS\%userprofile%\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons
     \ClassicStartMenu
     \NewStartPanel

    You can change the dword values of the CLSID's to unhide the icons (1 = hidden, 0 = visable)

    Hope that helps

    Cheers Matt :)

     

    Friday, June 11, 2010 4:03 AM