none
RemoteApp "Jumping" to Second Screen RRS feed

  • Question

  • Setup

    I have Server 2016 set up with Remote desktop Services.  Its primary function is to deploy one particular application, installed on the server, with RemoteApp.  The Configuration for the workstations is being pushed out with a GPO, and RemoteApp shortcuts are successfully being placed in the Start Menu.  We have approximately 50 Users utilizing this application, and for 95% of them this works perfectly.

    Issue

    While running the application on one monitor (right), under certain circumstances, the application will jump to the second monitor, maximize, and "appear" to be frozen (no response to mouse movements). We have a remote control software used for troubleshooting.  When we shadow the console on the users workstation, you can clearly see the application is open on the second monitor (left).  When we shadow the users' session on the server, the application appears to be maximized on the right.  Restoring the window restores the window to the right monitor, both on the workstation console (jumps) and server session, and regains control.

    Attempted Resolutions

    We have attempted video driver updates, alternate graphics adapters, complete windows updates, restoring older versions of mstsc.exe (for Windows 10 1803 users, per another hotfix), and switching primary monitors and resolutions.  The problem still arises.  Problem only exists for particular users for dual screens.  User A and User B have identical hardware and dal screens, but problem only exists for User A.  User C has a different make & model desktop, and User D has a laptop with a docking station, and both C & D experience the same issue.  We cannot duplicate the issue on workstations that aren't experiencing it already.

    Tuesday, June 12, 2018 7:37 PM

All replies

  • Hi,

    >Problem only exists for particular users for dual screens.
    If possible, try to log on user A device using user B credential, confirm that if same problem happens.

    Besides, are problematic users using same client OS version? 

    Besides, please confirm that if same problem happens on specific RemoteApp?

    Also, please check below confiruation:
    1. Equal resolution monitors
    2. Total resolution of all monitors not exceeding 4096 x 2048
    3. Top-left monitor being the primary

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 14, 2018 8:38 AM
    Moderator
  • User A experiencing problems on Workstation A loaded with Windows 10 1803 logged into Workstation B loaded with Windows 10 1803, both workstations have dual 1920x1080 monitors totaling 3840x2160.  User did NOT experience issues on alternate workstation.

    Problematic users are using Windows 10 1803, 1709, and Windows 7 SP1, all machines with current updates.

    Some users have the right monitors primary, others the left, but I will double check the exact configurations to make sure this information is accurate.

    Currently we are using only one RemoteApp, heavily.  Other RemoteApps deployed such as Word, Excel, Outlook may not be used heavily enough to present the issue, but under current surveillance, they are not causing the problem.  There are some users with unequal resolutions, specifically those users on notebooks using a 1920x1080 monitor as their second screen.

    Thursday, June 14, 2018 12:51 PM
  • Hello world !

    I'm hosting manager and deploy RemoteApp for a lot of my customers since more than 5 years.

    Since 1 year we don't have a day without issue with RemoteAPP (display issue essentially) so i think it's time to forgot RemoteAPP

    We have switched a lot of my customer to use the classical Remote Desktop 3389 ... I am more than frustrated to go back but my customers not cry any more over me........

    Maybe the RemoteApp over HTML5 will fix these issue, or maybe Microsoft will come out of his sleep to correct this RemoteAPP

    And thank you for not talking about editing rdp files, changing the mode of HD support with GPOs, the only thing to do is Microsoft to get to work.

    Sorry for my annoyance but it becomes so pathetic !

    Thursday, June 14, 2018 2:52 PM
  • I have exactly the same problem.  Dual screen users with remote desktop app switching screens.

    I have told them to disconnect and reconnect from the remote computer which allows them to regain control of the app.  One user is having to do this many times every day.

    Did you find a solution at all?



    • Edited by Jules Gl Wednesday, August 15, 2018 11:01 AM
    Wednesday, August 15, 2018 11:00 AM
  • I have not found a permanent solution.  Some users experience it less if they switch which monitor is their primary, some experience less if they use the RemoteApp in windowed-mode rather than maximized.  I'm still pursuing a solution although my users are just dealing with it.
    Thursday, August 16, 2018 7:56 PM
  • We are still just dealing with it too!

    Our users have found the same as you and have the RemoteApp in a (nearly full screen) window.  I will suggest they also try changing their primary monitor.

    I have also found that you can recover the 'frozen' app by doing the following:

    • Hover the pointer over the 'frozen' app's icon on the taskbar so that the preview window appears.
    • Move the pointer over the preview window.
    • Right click on the preview window and select restore.
    • The 'frozen' app will switch back to the other screen as a smaller window and will be working again.
    • The window can now be maximized.

    I was hoping an update would fix this, but instead it has stopped us from being able to copy and paste files from within the remote app to the local PC!

    Hopefully both issues will get fixed eventually.


    • Edited by Jules Gl Wednesday, January 2, 2019 4:25 PM
    Wednesday, January 2, 2019 4:25 PM
  • Maybe the Same Issue here:

    * Server 2016

    * Clients with Win 10 (1709 Builds

    Most of our Users use Dual Screens of the same Build/Resolution; Some additionally use their Laptop as 3rd Screen.
    We've Tried several Driver Updates (VGA, Chipset, Docking, etc.) with no success.
    Also tried the "remove Mouseshadow" Reg entry on the Termservs.
    Also changed DPI Settings on the Pcs for testing
    Nothing seems to solve the Problem, only to use one Screen and disable the Second (and Third).

    If the Users try to scroll within one specific applications, the Mouse jumps to the exact same coordinates on the second (right screen and always the right screen); if the App is started on the last right screen, the mouse cursor jumps to the edge of the screen.

    The funny thing is that other Apps on the TS Farm do not show this behavior.

    Completely lost with this issue :(


    • Edited by Paul Dengg Friday, May 3, 2019 10:04 AM
    Friday, May 3, 2019 10:00 AM