none
New Windows Server 2019 RDWeb Webclient connection issue RRS feed

  • Question

  • We're currently having issues setting up our Terminal Server for our remote users.
    Everything is on place: RD Web Access, RD Gateway, RD Connection Broker (Some confusion) and RD Session Host.

    We are able to connect to the interface locally and remotely to servername/rdweb/webclient/index.html, we can use the Remote Apps locally but when we try to use the Remote Apps from a remote computer it gives us this error:

    Oops, we couldn't connect to "Remote Desktop Connection"
    The connection to the remote PC was lost. This might be because of a network problem. If this keeps happening, ask your admin or tech support for help.

    Does anyone have any idea what were doing wrong? It would be really helpful.

    Tuesday, June 11, 2019 7:24 PM

Answers

All replies

  • I figured out the problem, now I need to find out how to solve it. So we currently have our RDS locally and the certificate is set with a specific name we were using the IP.... we need to make it available outside our local network for our remote users to use, I have no idea how to do this because with our current setup (RDS port forwarded to WAN IP) is not working.

    • Edited by MightyIT Wednesday, June 12, 2019 4:30 AM
    Wednesday, June 12, 2019 4:29 AM
  • Hi,

    Article “Set up the Remote Desktop web client for your users” mentioned below about certificate for webclient:
    1. The RD Web Access role is configured with a publicly trusted certificate.
    2. Your URL uses the FQDN of the server hosting the RD Web role.

    Link:
    https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/remote-desktop-web-client-admin

    Also, blog “Certificate Requirements for Windows 2008 R2 and Windows 2012 Remote Desktop Services” mentioned certificate requirements as below:
    1. The certificates you deploy need to have a subject name or subject alternate name that matches the name of the server that the user is connecting to.  
    2. The certificate for RDWeb needs to contain the FQDN of the URL, based on the name the users connect to.  If you have users connecting externally, this needs to be an external name (needs to match what they connect to).  

    Link:
    https://techcommunity.microsoft.com/t5/Ask-The-Performance-Team/Certificate-Requirements-for-Windows-2008-R2-and-Windows-2012/ba-p/375448

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by MightyIT Tuesday, June 18, 2019 2:06 PM
    Wednesday, June 12, 2019 6:52 AM
    Moderator
  • Hi,

    How things are going there on this issue?

    Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang  

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 18, 2019 2:17 AM
    Moderator
  • Hello,

    Everything works now, the issue was with the Domain name and assigning the right certificates with the right names.

    Thank you very much for your help!

    Tuesday, June 18, 2019 2:07 PM
  • Hi,

    I am glad to hear that your issue was successfully resolved. If there is anything else we can do for you, please feel free to post on the forum.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 19, 2019 1:55 AM
    Moderator
  • Hi, 

    I have this setup on Server 2016 and we are only going to be accessing it internally. A windows 7 machine can login to the webclient and use the resources just fine. A windows 10 machine or the chromebook we are setting this up for long term will give the message the connection to the remote PC was lost.

    Any ideas?

    Thanks,

    Keith

    Monday, October 21, 2019 4:43 PM