WinRM Multi Hopping Problem


  • Hi community,

    i got a specific problem concerning the multi-hop support in WinRM.

    The task is following (to keep things simple I use server a, server b and server c in the explanation):

    I'm sitting on server a. On server b, there are some scripts stored on the HDD. One script (powershell) contains the job to write a test-file on server c (must be via UNC-path). When I command server b to execute the script (via a winrs command on server a) then I'm getting an Access denied error. After searching for this problem I came across CredSSP. I set it up and tried it again. After trying different possibilities, I'm stuck now.

    When I use the -ad switch, winrs asks me for the credentials. After giving these via the -u: and -p: switch, there is still the same error message!

    My question: Is there a possibility to multihop without explicit credentials / CredSSP? Does multihop work in general?

    My servers are all running on Win2k8R2.

    Thanks in advance, if your're missing any information, just ask ;)


    Wednesday, April 04, 2012 8:59 AM