Failed to connect to a windows service "Group Policy Client Service"


  • I'm having a problem where when a user logs into a machine they get a popup like the following. It's only happening on one machine and I'd rather not have to wipe it and start fresh if I can avoid it.

    When I pull logs I see the following.

    Vincent Sprague

    Wednesday, August 22, 2012 1:53 AM

All replies

  • Hi, 

    Please have a look into below links and these are for your reference:

    Regards, Ravikumar P

    Wednesday, August 22, 2012 3:49 AM
  • Unfortunately that did not help

    Vincent Sprague

    Wednesday, August 22, 2012 11:50 PM
  • Now I also encountered this problem, Did you find the answer? Could you give me a hint, thank you very much.
    Wednesday, November 07, 2012 1:19 AM
  • I have not found a solution yet. This keeps happening for me.

    Vincent Sprague

    Wednesday, November 07, 2012 9:39 PM
  • The crash of your computer during Windows Updates may have caused that !

    I had this issue on my laptop since November, and it really bugged me.  I sifted through the event log and found the pattern of events that preceded the issue, and, probably, caused it.

    In short, the pattern is as follows: Windows updates run automatically as scheduled, and when reboot is initiated after the updates are finished, the computer crashes (probably during reboot sequence).  When it boots up, it reports that the last shutdown was unexpected, and the issue begins to occur.

    I spent 2 days trying to dig out a solution from the Internet, to no avail, until I came across this page.  It doesn't say anything about this particular problem, but it gives more information about SVCHOST process that starts many services, including Group Policy Client.  It looks like during reboot a vital registry settings were lost during crash and Group Policy Client "don't know" how to start.  Let me explain:

    There are two places to look in the registry:

    1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services this path should contain gpsvc key (a folder), which is responsible for service parameters and configuration.  I found that the key was intact, so, you do not touch anything here - just check that the key exists.
    2. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SVCHOST This is the most important path you should look into, as it must contain the keys and values referred in the key #1.  Below are descriptions what must be present there.
    • There must be Multi-String value called GPSvcGroup. My laptop was missing it.  So, you should create multi-string value named GPSvcGroup and assign it value GPSvc.
    • Next, you must create a key (a folder) and name it GPSvcGroup - this key normally should be there, but, again, it was missin on my laptop.
    • Then open newly-created GPSvcGroup folder and create 2 DWORD values:
    1. First called AuthenticationCapabilities and you must give it a value of 0x00003020 (or 12320 in decimal)
    2. Second is called CoInitializeSecurityParam and it must have value of 1.

    Once you complete all steps above, reboot the computer and the problem will be fixed.

    Video walkthrough for those who are not very technical is here:

    I am so relieved I was able to fix it, and hope this will help others with the similar issue.

    • Proposed as answer by SQL-ER Sunday, February 17, 2013 6:57 PM
    • Unproposed as answer by Baron164 Monday, February 25, 2013 12:35 AM
    • Edited by SQL-ER Wednesday, February 27, 2013 4:16 PM
    • Proposed as answer by SteveS72 Wednesday, June 12, 2013 7:39 AM
    • Unproposed as answer by SteveS72 Wednesday, June 12, 2013 7:39 AM
    Sunday, February 17, 2013 6:57 PM
  • My machine is showing all the proper register entries.

    Vincent Sprague

    Monday, February 25, 2013 12:35 AM

    I would start from answering these questions:

    1. What is the content of ImagePath variable in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\gpsvc
    2. What is the status of Group Policy Client service in services.msc?
    3. What does System Event Log says about Group Policy Client service at the time of a user log-on?
    4. Can non-admin users log in?
    5. Is the computer a part of a domain?
    6. Are there any group policies defined?
    • Edited by SQL-ER Thursday, February 28, 2013 6:56 AM
    Thursday, February 28, 2013 6:56 AM
  • Hi, I stumbled upon this post when I was experiencing an identical problem. Your instructions above worked perfect - thank you!!
    Friday, April 19, 2013 6:21 PM
  • The method posted by SQL-ER on 17-Feb-2013 and the associated you-tube video solved this issue for me. Thank you. Steve
    Wednesday, June 12, 2013 7:41 AM
  • Hi,

    I am having the same issue, but this solution did not work for me. When I check the ImagePath, it says:

    "%systemroot%\system32\svchost­­.exe -k netsvcs" instead of "....svchost­­.exe -k GPSvc" 

    Who can help me with this?

    Thanks in advance.

    Wednesday, October 30, 2013 6:00 PM
  • Baron164, Thank You!!
    Monday, March 31, 2014 5:09 AM
  • SQL-ER,

    I, too, want to express my gratitude for sharing your findings on restoring the Group Policy service to a functional state!

    My system began acting very strangely and when I finally booted it and went immediately to the Desktop, I saw the error message and found this posting.  It corrected all of the strange behaviors that I was seeing and also restored the function of Windows Update, which was hanging on me every time I attempted to start it.

    Thanks again!

    • Edited by BanditoB1 Monday, November 10, 2014 5:05 PM
    Monday, November 10, 2014 5:05 PM
  • This solved my problem as well.  Thank you for posting this solution!


    Tuesday, December 02, 2014 1:28 AM