locked
Network discovery won't stay enabled

    Question

  • I have a server running 2K8 R2 as a DC. Every time I turn on Network Discovery and go back in to check, it is turned off again.

    I have created a Group Policy to enable LLTDIO and RSPNDR in Link Layer Topology Discovery and I have enabled the Function Discovery Resource Publication and SSDP Discovery services but none of this has made any difference.

    It is working fine on some of my Win7 clients.

    Monday, March 29, 2010 3:33 PM

Answers

  • It looks like this is now working.

    I had to also enable the Function Discovery Provider Host, Function Discovery Resource Publication and SSDP Discovery services.

    Confusingly, in Advanced sharing settings, 'turn on Network Discovery' still won't stay switched on!

    • Marked as answer by troy99 Monday, April 12, 2010 3:03 PM
    Tuesday, March 30, 2010 10:54 AM

All replies

  • Hello,

    Thank you for your post here.

    Please understand that the responder only runs on a network that is designated private, but does not run on networks that are designated public or domain. It is by design because that  if network discovery is active on many domain clients, the client PC will quickly be flooded by hundreds of responses to queries which may have bad influence on domain network connections to e-mail, web servers, etc.

    Enable or Disable the LLTD Responder by Using Group Policy

    http://technet.microsoft.com/en-us/library/cc772308(WS.10).aspx

    If you have any questions or concerns, please do not hesitate to let me know.

     

    Tuesday, March 30, 2010 7:49 AM
  • Hi Miles,

    Thank you for your reply, but that is exactly what I have already done.

    It is a good job I checked this thread for replies, because the Alert system is still not working reliably. I reported this months ago on another thread I raised but it still hasn't been fixed.

    Correction to Alert issue - an alert email did arrive, several minutes after I initially posted this message! (i.e. about ninty minutes after Miles' post).

    Tuesday, March 30, 2010 9:09 AM
  • It looks like this is now working.

    I had to also enable the Function Discovery Provider Host, Function Discovery Resource Publication and SSDP Discovery services.

    Confusingly, in Advanced sharing settings, 'turn on Network Discovery' still won't stay switched on!

    • Marked as answer by troy99 Monday, April 12, 2010 3:03 PM
    Tuesday, March 30, 2010 10:54 AM
  • I Am having the same problem in Windows Ultimate. Network Discovery will not stay on and I still can use every part of my network now but it stays off. Did you get it to stay on?  Jim  jamepie@yahoo.com

    I can do it
    Monday, April 19, 2010 8:05 AM
  • I Am having the same problem in Windows Ultimate. Network Discovery will not stay on and I still can use every part of my network now but it stays off. Did you get it to stay on?  Jim  jamepie@yahoo.com

    I can do it
    Monday, April 19, 2010 8:05 AM
  • The Network Discovery setting is still set to 'Off' and won't stay enabled no matter how many times I change it - even as the domain admin.

    However, by applying all of the settings above, the servers appear reliably when anyone browses the network, which is what I was trying to achieve.

    Monday, April 19, 2010 8:34 AM