Hypervisor processor startup failed


  • I recently did an in-place upgrade of a Dell PowerEdge 2900 from Windows 2008 R2 SP1 to Windows 2012 RC (Build 8400).

    This server runs the latest BIOS available and has two dual-core CPUs installed (Xeon 5130).  In Windows 2008 R2, this appeared everywhere as 4 cores, and in Windows 2012 Device Manager, it does as well:

    However in task manager, msinfo32, Hyper-V manager and everywhere else in Windows it only reports a single dual-core socket:

    At first, I assumed it was something fancy/NUMA related that I needed to figure out, but now I've noticed the following error in the system log, which I presume is related:

    Log Name:      System

    Source:        Microsoft-Windows-Hyper-V-Hypervisor

    Date:          8/8/2012   12:55:26 PM

    Event ID:      96

    Task Category: None

    Level:         Error


    User:          SYSTEM

    Computer:        HyperV.demolab.local


    Hypervisor processor startup failed (APIC ID 0x6, status 0x1035).   Further processors in the system were not started.

    Event Xml:

    <Event   xmlns="">


        <Provider   Name="Microsoft-Windows-Hyper-V-Hypervisor"   Guid="{52FC89F8-995E-434C-A91E-199986449890}" />







        <TimeCreated   SystemTime="2012-08-08T16:55:26.932029300Z" />


        <Correlation />

        <Execution   ProcessID="4" ThreadID="8" />



        <Security   UserID="S-1-5-18" />



        <Data   Name="CPU">0x6</Data>

        <Data   Name="ErrorCode">0x1035</Data>



    Is this an RC bug?  I'll do a fresh install with RTM when it comes around, but I'd like to get this figured out before then.

    BTW, I've made no changes to the BIOS between 2008 R2 and now (e.g. VT, DEP, etc).  The Hyper-V role was installed prior to the upgrade, and other than this, all of my VMs run as expected.

    Mike Crowley | MVP
    My Blog -- Planet Technologies

    Thursday, August 09, 2012 4:19 AM


All replies

  • You may try to perform a fresh installation with Windows Server 2012 RC to see whether you get the same issue. Use native boot, it will not affect your current disk topology.
    Thursday, August 09, 2012 6:52 AM
  • If I can't get a solution to the problem, I'll consider blowing it away as a last ditch effort, but I'd like to understand and fix it if possible.

    Mike Crowley | MVP
    My Blog -- Planet Technologies

    Thursday, August 09, 2012 2:20 PM
  • Have you contacted Dell to see if they have a BIOS update specific to 2012?  Just because you have the latest publicly available one doesn't mean it supports 2012.  I know I have had to get a beta BIOS for a system I was working on in order to install 2012.


    Thursday, August 09, 2012 4:02 PM
  • 2900 series is old, and I'd doubt they will make a new BIOS update.  

    This page however states that 2900's work with Windows 2012:

    Because this all worked fine with 2008, I'd like a technical answer as to what Microsoft change broke this.  The CPU shows up in device manager, so it does not appear to be a driver issue.

    I just found this post where someone said something similiar occurred when they installed Hyper-V:

    Mike Crowley | MVP
    My Blog -- Planet Technologies

    Thursday, August 09, 2012 4:17 PM
  • Well try to browse over the YouTube! there are a lot of Demonstrations there regarding your problem, you might see the solution.


    Genuine Batteries

    Thursday, August 09, 2012 4:42 PM
  • Sadly, I have just completed a fresh install with the RTM (build 9200) and have the same problem.

    Mike Crowley | MVP
    My Blog -- Planet Technologies

    Wednesday, September 05, 2012 2:01 AM
  • I have also seen this post:

    I don't think this *should* be the issue, since Hyper-V worked just fine with Win2k8 R2 SP1, which is when this issue should have occured per the above, however just to check, I want to look at the CPU stepping.

    Each of my CPUs in device manager report a "device instance path" of:


    but, I can't determine the "stepping" from this. 

    The PS command "gwmi win32_processor" also doesn't help because it doesn't report on the 2nd (stopped) CPU.  Ditto for the Intel® Processor Identification Utility.

    Any ideas on how to check the stepping from device manager, or another approach, which does not require the CPU to be "started"?

    Thursday, September 13, 2012 4:02 PM
  • I have the same problem with Dell PE2900, and Hyper-V 2012.

    To detect a stepping, you can do the following: install Dell OpenManage to the Hyper-V server, and check there.

    In my case, CPU stepping was different for 2 CPUs, and I do not know is this a source of the problem or not.

    Thursday, September 20, 2012 11:58 AM
  • Interesting; thanks.  I'll install Open Manage and see what I can see.

    Mike Crowley | MVP
    My Blog -- Planet Technologies

    Thursday, September 20, 2012 4:32 PM
  • Addition - regular setup of Dell OM can fail on Hyper-V 2012, go to the <unpackedfolder>\SystemsManagement and start directly SysMgmt.msi. During setup, OM can report that 'prerequisites check' (or something like that) was not performed, but installation went properly. Dell OM can be accessed via https://servername:1311 remotely.

    Also, we sent a request to DELL about the same - error [Hypervisor processor startup failed (APIC ID 0x4, status 0x1035). Further processors in the system were not started.]

    Thursday, September 20, 2012 5:55 PM
  • What did Dell say?  I started a thread in their forums, but its the blind leading the blind in there.

    Mike Crowley | MVP
    My Blog -- Planet Technologies

    Thursday, September 20, 2012 6:42 PM
  • According to DELL, they will start Windows 2012 support in October (?!)

    Also, we upgraded one more PE2900 server from Hyper-V Server 2008 to Hyper-V Server 2012, also, with 2 CPUs, but with the same stepping.

    No problems found, and there is no error with ID 96.

    So, most probably, error caused by the different CPU stepping.

    Monday, September 24, 2012 8:41 AM
  • DOH!

    (thanks for the advice on installing open manage)

    Interesting however - I never had an issue with Hyper-V 2008 R2 SP1, as the above article suggested I would...

    Mike Crowley | MVP
    My Blog -- Planet Technologies

    Monday, September 24, 2012 4:13 PM
  • Hi,

    i have the same situation with a PE2950 and two different Quad Core Xeon (E5405).

    But i have no Probleme with Hyper-V!

    One CPU has a stepping C0 (SLAP2) and the other E0 (SLBBP).
    Device Manager shows all 8 Cores.

    I checked the event Log /System and can´t find any Event ID 96.
    I think it must be somethink with the stepping of the 5130.

    So after 4 years with a PE2950 the server will get a second change with Windows 2012 and Hyper-V.
    Maybe as a free Hyper-V Core Server.

    I found a used E5405 with the same stepping E0 (SLBBP) at ebay for 14€.
    And i will change the cpu in the next weeks.


    Monday, December 03, 2012 11:29 AM
  • I also have the exact same problem , will there be a fix from microsoft for this ? seeing as it is working fine previously on a Hyper V 2008 R2

    the result from systeminfo shows different stepping for the processor, but I can't ask for a processor replacement as the unit is out of warranty, would like to upgrade the box to Hyper-V 2012, but not if it can't utilize the available resource.

    Tuesday, June 04, 2013 10:27 AM
  • Hi Adi,

    i think there will be NO fix at all.

    I had changed the CPU´s, i purchased the XEON´s at ebay. i paid about 15€ (maybe 10 USD).
    The Problem was gone.

    So i installed Windows 2012 and activated Hyper-V, but the Overall Performance of Hyper-V Guest Systems was poor.
    The old Hardware won´t Support all the nice Features of Windows 2012 hyper-V.

    So the PE295o still runs Windows 2008 R2 now.


    Tuesday, June 04, 2013 10:33 AM
  • Hi Jurgen,

    so your guest OS performance is running better in Hyper-V 2008R2 than in Hyper-V 2012 ? hmm, didn't think that would happen, I've actually tried it running on a HP BL460c G1 [exact same processor on both sockets] and it feels like my guest OS is running better than before [subjective feel], but that could be because I added the Virtual Processor to 8 [not available on the 2008 R2 Hyper-V]

    Tuesday, June 04, 2013 10:57 AM
  • Hi,

    The Guest Performance is Excellent on my Dell Power Edge R420 with Windows 2012 (Host and Guest)!

    The Guest Performance with Windows 2012 as a Host at the Dell Power Edge 2950 is poor.
    Sometimes it took double the time to install some Updates or a SQL 2012 Installation within a Windows 2012 Guest.

    Tuesday, June 04, 2013 12:03 PM