none
Windows Server 2008 R2 - No auto lock RRS feed

  • Question

  • Hello.

    I'll start by saying I'm a newbie in all things related to servers and I'm not English native speaker.

    I have a Server 2008 R2 install on a new machine that'll be our future website server.
    I use Teamviewer to access the server on the datacenter.
    We are a team of 3 techs.

    The server will be without a domain server, so it is configured as being in a workgroup. Since the 3 of us remote access the machine and have diferent levels of access, it is important for the machine to auto lock or even auto log-off after a period of inactivity, but this does not happen.

    I've added the following keys to the registry, but still no luck:

    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Control Panel\Desktop]
    "ScreenSaverIsSecure"="1"
    "ScreenSaveActive"="1"
    "ScreenSaveTimeOut"="5"
    
    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop]
    "ScreenSaverIsSecure"="1"
    "ScreenSaveActive"="1"
    "ScreenSaveTimeOut"="5"

    I've searched the web for help but so far nothing.

    Here I've seen this question similar but no answer worked for me.

    Any help is welcomed. Thanks in advanced,

    MB

    Tuesday, May 8, 2012 12:00 PM

Answers

  • Since you are new to 2K8, sharing the below info.

    The system would automatically lock itself by doing below steps.

    1) Right click on the desktop -> Personalize -> Screen Saver.

    2) Also check the box which says ‘On resume, display logon screen‘ 

    Password Protect With Screen Saver


    Regards, Ravikumar P

    • Marked as answer by 朱鸿文 Monday, May 14, 2012 2:14 AM
    Tuesday, May 8, 2012 12:52 PM
  •  
    > The server will be without a domain server, so it is configured as
    > being in a workgroup. Since the 3 of us remote access the machine and
    > have diferent levels of access, it is important for the machine to
    > auto lock or even auto log-off after a period of inactivity, but this
    > does not happen.
     
    Auto Logoff is hard - this would require a script that fires up when the
    screen saver kicks in and then logs the user off...
     
    > [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control
    > Panel\Desktop]"ScreenSaverIsSecure"="1""ScreenSaveActive"="1""ScreenSaveTimeOut"="5"
     
    The keys look ok - but I miss "ScrnSave.exe" - what Screensaver should
    lock the screen? Typically you may use "logon.scr".
     
    And ScreenSaveTimeout = 5 means "5 seconds" - seems to be a very short
    amount of time... ;-)
     
    regards, Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    • Marked as answer by 朱鸿文 Monday, May 14, 2012 2:14 AM
    Tuesday, May 8, 2012 3:39 PM

All replies

  • Use Screen saver settings  to lack out a PC.

    Also use power management settings according to your requirement.


    Regards, Ravikumar P

    Tuesday, May 8, 2012 12:28 PM
  • Since you are new to 2K8, sharing the below info.

    The system would automatically lock itself by doing below steps.

    1) Right click on the desktop -> Personalize -> Screen Saver.

    2) Also check the box which says ‘On resume, display logon screen‘ 

    Password Protect With Screen Saver


    Regards, Ravikumar P

    • Marked as answer by 朱鸿文 Monday, May 14, 2012 2:14 AM
    Tuesday, May 8, 2012 12:52 PM
  •  
    > The server will be without a domain server, so it is configured as
    > being in a workgroup. Since the 3 of us remote access the machine and
    > have diferent levels of access, it is important for the machine to
    > auto lock or even auto log-off after a period of inactivity, but this
    > does not happen.
     
    Auto Logoff is hard - this would require a script that fires up when the
    screen saver kicks in and then logs the user off...
     
    > [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control
    > Panel\Desktop]"ScreenSaverIsSecure"="1""ScreenSaveActive"="1""ScreenSaveTimeOut"="5"
     
    The keys look ok - but I miss "ScrnSave.exe" - what Screensaver should
    lock the screen? Typically you may use "logon.scr".
     
    And ScreenSaveTimeout = 5 means "5 seconds" - seems to be a very short
    amount of time... ;-)
     
    regards, Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    • Marked as answer by 朱鸿文 Monday, May 14, 2012 2:14 AM
    Tuesday, May 8, 2012 3:39 PM
  • Hi MB,
     
    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.
     
    BTW, we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.
     
    Best Regards
     
    Kevin

    TechNet Community Support

    Monday, May 14, 2012 2:14 AM
  • Changing registry in the below manner worked for me

    [HKEY_CURRENT_USER\Control Panel\Desktop]

    "ScreenSaveActive"="1"
    "ScreenSaveTimeOut"="60"
    "ScreenSaverIsSecure"="1"

    For those who need can download the key from here and double click and add to the registry

    https://www.dropbox.com/s/irn6un48ct378x4/serverlock.reg

    For more details please refer..
    http://www.windowstechinfo.com/2013/07/windows-screen-server-auto-lock-not.html

    Friday, July 12, 2013 11:38 AM