Error 80070570


  • I have problem to instal server 2008 on virtual PC. When I enter product key to start setup system responds me by error

    80070570 windows cannot open required file D;\source\

    However this file exist on cd image in the same location. Entering DOS mode from this CD I see that I have D and W drives with similar contest. What I can do?

    Saturday, September 08, 2007 1:48 AM



    I've now installed the x86 version of Datacenter with luck. Haven't tried the x86 version of Enterprise but i suspect that it also will work. The 64bit emulation in VMware's is experimental so I guess the problem is with VMware and not with Windows ?



    Tuesday, October 09, 2007 10:26 PM

All replies

  • Can you try with the latest RC0 build and tell us if this problem is still reproducing? 


    Thursday, September 27, 2007 6:39 PM
  • When installing Windows Server 2008 RC0 Datacenter on a VMware virtual computer I get the same error.

    I have VMware Workstation ACE Edition version 6.0.1 build-55017, set up to run a virtual machine with Guest Operating system; Windows Server 2008 x64 Edition (experimental). Not sure exactly what motherboard and CPU, but it is for sure an AMD 64 bit processor.


    This is the iso file I've been trying to install:




    When trying to install Windows Server 2008 RC0 Enterprise on the same virtual machine

    (ISO file:  6001.16659.070916-1443_amd64fre_Server_en-us-KR1SXFRE_EN_DVD.iso)

    I get the following message (on a black screen with grey font)


    Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:


    1. Insert your Windows installation disc and restart your computer.

    2. Choose your language settings, and then click "Next."

    3. Click "Repair your computer."


    If you do not have the disc, contact your system administrator or computer manufacturere for assistance.


    File:   \windows\system32\drivers\megasr.sys


    Status: 0xc0000098


    Info:   Windows failed to load because a critical system driver

           is missing, or corrupt.

    Monday, October 01, 2007 6:41 PM
  • Have the same problem,  Tried installing in VMware server 1.0.1 got the same message "Error 80070570 not able to fone D:\

    Previosuly had another issue with B3 that it won't find  the drivers for the CD\DVD drive. Did some googling and the drivers from this link did the job.

    Tried the same drivers with RC0....No Luck!

    Something fishy with RC0

    Monday, October 08, 2007 6:29 PM

    I've now installed the x86 version of Datacenter with luck. Haven't tried the x86 version of Enterprise but i suspect that it also will work. The 64bit emulation in VMware's is experimental so I guess the problem is with VMware and not with Windows ?



    Tuesday, October 09, 2007 10:26 PM
  • I am having this same issue installing 2008 RC0 Enterprise as the primary OS on a machine.


    Any idea why this would be happenning?






    Thursday, October 11, 2007 11:32 PM
  • Hi Guys,

    i'm getting the same error after providing the key because this file is missing. I've used the following image file for installation directly on my hardware (no virtualization):


    Could someone help?

    Best regards,

    Sunday, October 21, 2007 7:40 PM
  • Is this from a DVD from the action pack? Please try using the ISO from the Microsoft website.

    Monday, October 22, 2007 7:41 PM
  • In my original post I wrote that I use ISO image. I tried different beta vertion with the same answer.

    Monday, October 22, 2007 7:51 PM
  • Hello

    I'm having same problem with the iso file from the MS site 


    Missing install.wim

    error 80070570

    Thursday, October 25, 2007 3:52 PM
  • I checked my iso image that I downloaded, and it's

    1.31 GB (1,408,304,837 bytes)

    the web site says it's suppose to be  2649.0 MB

    so I'll download it again.. and see what happens
    Thursday, October 25, 2007 4:23 PM
  • I am getting the same errors while trying to install 2008 Enterprise version directly to a drive.  Were you able to get this resolved and how was it accomplished?  Thanks,  Andy

    Tuesday, December 18, 2007 6:00 PM
  • Hello everybody,

    I have the same error on file install.wim (i have no product key entered) ;

    The file size is 1688 MB.

    I downloaded 2 times (because of this error) Windows 2008 RC1 Standard Edition (ISO file) for x86 and tried to install it on a new computer directly from dvd drive.. impossible.

    I next downloaded Windows2008 RC1 Enterprise Edition (thinking it would be different) and the same error appears..

    I don't know what to do, i thank it was possible directly installing this platform on a "virgin server" but reading informations here and there, i am not alone: we are some persons with this error..

    It seems to be the size of file ? perhaps..

    Others persons with RC0 meet the problem too..

    Directly putting the dvd on a windows 2000 server (patched) and automatic execution, windows tells that autorun.dll is not valid because of a file named "spwizeng.dll" that was not loaded..


    Did anyone found a solution ?

    Someone wrote about rewriting the file install.wim without some options ..? not easy faor all of us. i haven't got vista and the utilities that permit doing that.

    Thanks for your answers.



    Monday, December 31, 2007 10:31 AM
  • Hi!!

    Maybe this is not the correct topic to discuss this, but I'm receiving the same error (80070570) when my Windows Update tries to download and install a Windows Vista Update...

    Another thing, not relationated with this, everytime I want to update my computer I need to go to Control Panel - Administrative Tools - Services and then search for windows update and iniciate the service... The same happens with Windows Defender, but with this one, even after I turn the service on, when I open Windows Defender it closes immediately...

    Oh, and I use CCleaner in computer, but it also opens and closes immediately!

    Afffff... I dunno what to do... Tongue Tied
    My computer is a mess!! Format and re-install the OS it's a good idea ?! Sad
    Thursday, March 20, 2008 6:38 PM

    The 80070570 is a Win32 HRESULT (8=bad ***, 007=win32, 570=couldn't open file) that basically means 'couldn't open file'.  Seeing this error during windows update would have a different root cause than one seen when trying to open a file from a CD rom.



    That said I got past this error during installation after I found another VM on the same box was also hitting the DVD drive that I was installing from.  I released the DVD drive from all VMs then released and reattached it to the VM I was installing in.  Tried again and everything was fine.


    Monday, March 24, 2008 8:32 PM
  • well what you have to do is go to vmware web access, then summary tab, then hardware section, then edit the cd/dvd option, change the selected option from 'ATAPI emulation' to 'Access the drive directly'
    Thursday, March 05, 2009 7:10 AM