locked
Applying Deployed Printer Connections Policy.... Server 2008 RRS feed

  • Question

  • Hi All,
        Hoping someone can help with a slight issue I am having. We have a Win 2K domain and a Win  2K3 file and print server pushing out printers via group policy (and the pushprinters.exe) to our win XP clients and our citrix users. Just recently we have installed Win 2K8 as a test server at our DR site and configured it as web server (IIS, ASP etc).

    When trying to log into the server via RDP it hangs at Applying Deployed Printer Connections Policy... for quite some time (I usually have to leave it over night). I have noticed when doing this the spoolsv.exe service shoots up to 100% CPU usage and if I stop that service it logs in normally.

    I initially thought that this could be due to our pipe to the DR site being too small and the 2K8 server trying to pull the drivers up for all the mapped printers (obtained from Group Policy) as when I finally log into the server it behaves normally (i.e. no long delays)
    Also the 3 other 2K3 servers at that site work normally.

    I have tried removing my AD account from all the groups that get auto-generated printers with the same result. I have also tried installing the 2008 driver for all my printers onto the 2008 server with the same results.

    As I am quite new to Server 2008 I was hoping someone might have seen this before?
    Tuesday, January 20, 2009 10:27 PM

Answers

  •  

    Hi,

     

    From your description, I understand that you have problem with high CPU usage caused by spoolsv service. If there is any misunderstand, please let me know.

     

    Before go any further, I’d like to confirm the following questions:

    1.      How do you deploy the printer?

    2.      Do you got any error message? Please help to collect the “Microsoft-Windows-GroupPolicy” logs in System event.

     (After you have finished this, please send it to tfwst@microsoft.com  for research)

     

     

    To troubleshoot the issue, I suggest we do following test:

    1.      Please logon the server as the problematic user and try to install the printers configured in the group policy one by one.  

    If you can install the printer well, please check the Group Policy.

    If not, maybe you should check your print device.

     

    In addition, please also check whether all these deployed printers are compatible with Windows Server 2008. The Hardware Compatibility List (HCL) can be accessed from the following link:

    http://www.windowsservercatalog.com/results.aspx?bCatID=1326&cpID=0&avc=10&OR=1

     

    2.  Delete third party language monitor.

    - Open registry.

    - Locate HKLM\System\CurrentControlSet\Control\Print\Monitors

    - Export key Monitors for backup purpose.

    - Delete subkeys

    - Restart "Print Spooler" service.

     

    regards,


    Nick Gu - MSFT
    • Proposed as answer by Nick Gu - MSFT Wednesday, January 28, 2009 1:55 AM
    • Marked as answer by Nick Gu - MSFT Wednesday, January 28, 2009 6:55 AM
    Monday, January 26, 2009 1:47 AM

All replies

  •  

    Hi,

     

    From your description, I understand that you have problem with high CPU usage caused by spoolsv service. If there is any misunderstand, please let me know.

     

    Before go any further, I’d like to confirm the following questions:

    1.      How do you deploy the printer?

    2.      Do you got any error message? Please help to collect the “Microsoft-Windows-GroupPolicy” logs in System event.

     (After you have finished this, please send it to tfwst@microsoft.com  for research)

     

     

    To troubleshoot the issue, I suggest we do following test:

    1.      Please logon the server as the problematic user and try to install the printers configured in the group policy one by one.  

    If you can install the printer well, please check the Group Policy.

    If not, maybe you should check your print device.

     

    In addition, please also check whether all these deployed printers are compatible with Windows Server 2008. The Hardware Compatibility List (HCL) can be accessed from the following link:

    http://www.windowsservercatalog.com/results.aspx?bCatID=1326&cpID=0&avc=10&OR=1

     

    2.  Delete third party language monitor.

    - Open registry.

    - Locate HKLM\System\CurrentControlSet\Control\Print\Monitors

    - Export key Monitors for backup purpose.

    - Delete subkeys

    - Restart "Print Spooler" service.

     

    regards,


    Nick Gu - MSFT
    • Proposed as answer by Nick Gu - MSFT Wednesday, January 28, 2009 1:55 AM
    • Marked as answer by Nick Gu - MSFT Wednesday, January 28, 2009 6:55 AM
    Monday, January 26, 2009 1:47 AM
  • Did you ever find a solution to this issue?

    We have a Similar Issue, though it is not limited to Win2008 Servers.

    Our DC that puushes the printers is either a Win2003 or Win2008 DC.

    If you login for the first time, it takes bloody forever.  Typically the 2nd time you log in its not too bad.

    All servers and connected clients are local to the DC.

    PrintSpooler is on a Win2003 DC.

    Clients can be, Win2003 Server, Win2008 Server, Vista

    We've installed Pritner Drivers locally on the client and still happens
    Can be a Domain user or Domain Admin and same result.

    Scott<-
    Tuesday, June 2, 2009 2:37 PM
  • Has anyone found a solution to this problem? I am getting the same thing when
    my users log on to a 2008 Terminal Server. It takes up to 5 minutes or more for
    the logon process to complete and the spoolsv process is consistently above 50%
    CPU usage during this time. Any suggestions would be much appreciated.
    Friday, June 5, 2009 8:47 PM
  • I am also having this issue on 2008 server x64.. i am deploying printers via print management / group policy..

    It just sits on this screen before going to the login option.

    Thursday, January 14, 2010 8:11 PM
  • is there a solution out there for this problem?

    i keep having the same issue!

    Monday, February 14, 2011 2:39 PM
  •  In Vista and 2008, the connections are created when the policies are read.  In Windows 7 and 2008 R2, the connections get delayed and are created later.

    You have a few options. 1) do not associate the user that logs onto the server with Apply To rights on the GPO.  You must give them read access to display any deployed printers in Print Management console, and read/write if they are the ones adding and deleting connections to the GPO.

    2) limit the number of printer connections you add during logon 3) set the spooler to manual on the server 4) deploy print drivers that do not take up 25 to 50 MB of disk space  5) 2008 R2

    Additional information regarding your server usage might lead to a couple more suggestions.

     


    Alan Morris Windows Printing Team
    Monday, February 14, 2011 10:55 PM
    Answerer