Strange Behavior of DropDown Listboxes in Response Windows on Remote Desktop Resources on Mac OSX 10.9 with Server 2012

    General discussion

  • We have our app running as Published apps on Windows Server 2012.

    Using the new Remote Desktop 8.0.24091 available from the Apple Store on a MacBook Pro with OSX 10.9 - if we setup remote resources and access the applications as published apps as listed in the Remote Resources section we see some unusual application behaviors which do not appear when running the same applications from the same machine via remote desktop.

    In particular, accessing dropdowns from within a response window are problematic when run as apps via remote resources.  In the desktop mode the dropdowns appear and can be selected easily, the same dropdowns on the response window fail to allow a selection from the list and subsequently fail to display the dropdown list when selected the second time.

    I note that the first attempt to access the dropdown that the response window border grays - indicating some issue with application focus.

    Any ideas of what this is - and what is the best way to get this to someone at Microsoft who would support this product?

    Sunday, November 17, 2013 10:48 PM

All replies

  • Hi Gbarber,

    this is really weird. Can you please share a Pictures off it and tell us a Little more about your environment?

    cheers Stephan

    Tuesday, November 19, 2013 1:36 PM
  • OK - I waited until 8.0.24255 to give it some time to see if it is still doing it - it is  We are upgrading our servers to 2012 R2 and i was going to wait until that was up and retry - but apparently that isn't going too well.

    Funny about this forum, I didn't get any email that someone had responded.

    We have a windows 32 application written in PowerBuilder which we are running as a published app under server 2012.  It works fine under windows 7 and 8 remote desktop (app), also works fine with the 2X server.

    It also works fine when run with remote desktop on the Mac.  However when the apps are run from the Mac version of the remote desktop using the remote resources the drop down listbox inside a response window fails.  (environment is OSX 10.9 on macbook pro)

    I have taken some capture movies showing the behavior.  Please let me know where I can email them.

    I don't see how I can attach them here.  I am limited to only two small images

    If you have access to email please email me  (gabarber at msn)

    • Edited by GBarber Monday, December 02, 2013 4:47 AM edit
    Monday, December 02, 2013 4:36 AM
  • Hi Gbarber,Use SkyDrive to upload collected


    cheers Stephan

    Monday, December 02, 2013 9:15 AM
  • Hi Stephan

    Here's a link in Sky Drive!153&authkey=!AKasuLmTwtEwmjs&

    This is a quicktime capture from the Mac

    The first half I show the app working correctly in remote desktop, then I rerun as a Published App Resource and attempt the same feature - notice how the response window looses focus when I click the dropdown.

    Can you please contact me at my msn account when you have had a chance to look at this - gabarber @

    For some reason I get no notification when there are thread responses.

    FYI - this is a show stopper for our app deployment and would like to find out how I can get this issue escalated.



    Monday, December 09, 2013 9:32 PM
  • I would like to add a "me, too" to this. One app that we run into this issue with specifically is InfiniteVisions from Tyler Technologies, specifically in their Infinite Visions Enterprise Edition - Accounting ( IVExplorer.exe ) application.
    In our case it is on a Windows 2008 R2 server and the problem affect more than just list boxes, it also affects the menu bars.

    See video here:!108&authkey=!AOFgumIVUhjAy8M&

    • Edited by Shawn Stricker Wednesday, December 11, 2013 5:02 PM Update details
    Monday, December 09, 2013 9:50 PM
  • I haven't had a response since I uploaded the examples - is anyone following this?

    How do I get support for this bug?

    Wednesday, December 25, 2013 10:22 PM
  • Hello do you have any progress on this, i suspect that this isn´t resolved before Microsoft releases an update for the RDP client for OS X.
    Saturday, January 04, 2014 8:14 AM
  • also an issue with 10.6.8

    what type of components do you use in your application.

    have you hade anny response from Microsoft at all?

    Monday, January 06, 2014 11:06 AM
  • hello

    we see the esact same issue with another application, and both 10.6.8 and 10.9 of OS X

    in that application sheridan components are used for menu's and combo boxes

    So this must be fixed either on the RDS host's with a hotfix or the MS RDP client for OS X


    you can also see that's something isn't normal when you run a explorer as published app, the focus is moved around

    alot when you click on different folders and menus.



    Monday, January 06, 2014 11:46 AM
  • Vanilla windows App built with PowerBuilder, been working since the 90's - works fine in windows (every version) - works fine in MAC desktop - works fine with 2X client - doesn't work with Microsoft RDC on Mac.

    Definitely a problem with the Implementation - not enough testing.

    Wednesday, January 08, 2014 4:35 PM
  • I have the same issue when running SAP Business One 8.82 through the Microsoft Remote Desktop version 8.0.24308. The dropdown boxes show up and I can pull the list down, but when clicked on a selection can't be made. This only occurs if the application is launched through the Remote Resources, but doesn't if it is opened from a remote desktop.
    Monday, January 27, 2014 6:50 PM
  • would be nice to get feedback from MS on this soon.
    Tuesday, January 28, 2014 2:33 PM
  • I am having this issue also. At first I thought it was an issue with the Language bar. How do we submit this issue to Microsoft?
    Tuesday, February 04, 2014 9:57 AM
  • Any updates from anyone?
    Monday, March 03, 2014 2:32 AM
  • The dropdown boxes show up and I can pull the list down, but when clicked on a selection can't be made.

    This is exactly what is happening here on MAC PRO retina - Initially it seemed likely to be the resolution mismatch between cursor position and the position reported on click. Also, the slider of the drop-down menu was highlited on hovering over with the cursor, but not available to be clicked and moved - the menu just closes as if clicked outside of it.

    Tried all the resolutions available without success. Then I ran the Windows 7 emulation on the same machine and it worked without a glitch.

    RDP for MAC obviously has an issue with remote applications.

    Monday, March 17, 2014 2:29 PM
  • We have a similar problem with dropdown menus in Outlook when connecting from OS X via RemoteApp. Menu appears for half second and then disappears, this makes impossible to choose "Start time" and "End time" when creating new calendar entry. Same menus working fine when connecting to same server from Windows or iOS.

    Terminal Server: Windows 2008 R2 SP1 x64

    OS X: 10.9.2

    Microsoft Remote Desktop for OS X: 8.0.5 (24428)

    iOS: 7.1

    Microsoft Remote Desktop for iOS: 8.0.5 (24403)

    Outlook 2007 SP3: 12.0.6607.100

    Monday, March 24, 2014 4:15 PM
  • This particular hotfix seems to describe the problem but cites a Windows client (rather than OSX), and doesn't mention Server 2012 or 2012 R2.  Obviously this isn't a solution for us but highlights the problem has been around before and applicable to RDC7, how have Microsoft not addressed this yet?


    Monday, April 28, 2014 12:48 PM
  • Guys,

    The year 2015 is already ending but the issue still not fixed since 2013. We are using MS RDP 8.0.25 client with published application MS Dynamics NAV 2013 R2 installed on RDS 2012 R2 farm. The issue with dropdown controls in application is still persists. If we are working with the same application but installed on RDS 2008 R2 farm it is ok.

    So, RDP client is still buggy.

    MS Support, please fix it. It is very annoying issue. Our clients are mad because of that.

    Tuesday, December 15, 2015 10:59 AM
  • Hi Sergey,

    we are sorry you are running into this issue. We have this one tracking in our bug tracker.  We will notify you if we need more details.

    Tuesday, December 29, 2015 12:41 AM
  • We have a feedback from MS Support [REG:116050314118651] . They say that this is a known issue and the fix will be provided with a public fix. Perhaps the business impact is not high enough to solve this untill today.
    We need a solution for Dynamics NAV 2016. The Microsoft Remote Desktop Connection Client for Mac 8.0.31 on a Mac and connect with a Windows Server 2012 R2. When accessing an Application based on Microsoft Win.Forms and trying to click on a drop down buttons, nothing happens.
    Monday, June 06, 2016 2:12 PM
  • Hi

    Do you have any update on this problem?

    We have the sane issu with some applications.

    kind reagards Andreas

    Tuesday, June 21, 2016 9:49 AM
  • first: i would really Thank you. So... THANK YOU!

    Unfortunately i found this post not earlier. Because i opens up my own, with nearly the same issue.

    We are using multiple Business-Solutions in our Mac-Win2012R2 environment too, and hardly fight with your reported issue also with the problem, that Windowframes are loosing focus as they wish.

    Please Microsoft and please RD Developers... turn your Heads on and give us a working Solution!

    Tuesday, June 28, 2016 1:27 PM