none
Windows Server 2003 Task Scheduler

    Question

  • I have a virtual server running Windows 2003 Standard Edition SP2.  I have a scheduled task that is due to run at 01:00 am.  This task runs fine if I stay connected to it (via RDP), but the moment I disconnect it does not run.  I then have to reinput the password.  I get the following message:

    "Vantage Giga [e3c1ad18-6486-4df4-9147-452111cf7ac2].job" (WebSpy.Vantage.exe) 15/09/2008 01:00:00 ** ERROR **
     The attempt to log on to the account associated with the task failed, therefore, the task did not run.
     The specific error is:
     0x80070569: Logon failure: the user has not been granted the requested logon type at this computer.
     Verify that the task's Run-as name and password are valid and try again.

    The account used to run the task has the "log on as a batch job" , "log on as a service" and "access this computer from the network" rights.  The account is a member of the local admins too.

    Any suggestions.
    Monday, September 15, 2008 1:12 PM

Answers

  • Hi,

     

    Scheduled tasks will typically execute on the console session. Tasks setup from within Terminal Server sessions will run, but will not run interactively. If a task is setup within a Terminal Server session and the same user is logged on at the console, the task will run interactively on the console even though it was not actually created in that session. The task will only be interactive to the console however, if the user was logged in when the task was started. If the user logs into the console and is not the user whose credentials launch the task, the task will not be interactive to either the console session or the remote Terminal Server session.

     

    Troubleshooting Steps:

     

    1. Check and see if the service is running using one of the following methods:

     

    2.  Start -> Run -> type 'services.msc' and click OK

     

    3.  Scroll down to the 'Task Scheduler' service.

     

    4. Check the 'Startup Type' column.

     

    The 'Startup Type' should be set to "Automatic".

     

    5. Check the 'Status' column.

     

    If the service is started, it will list 'Started' in the 'Status' column.

     

    6. Click the "Log On" Tab, and verify that "log on as: Local System account" and also select the checkbox of "Allow services to interact with desktop"

     

    7. Please also ensure that the user account is not in the "Logon as a Batch Job" and "Logon as Service" right.

     

    Hope it helps.


    David Shen - MSFT
    • Marked as answer by David Shen Monday, September 22, 2008 1:44 AM
    Thursday, September 18, 2008 8:26 AM

All replies

  • Hi,

     

    Scheduled tasks will typically execute on the console session. Tasks setup from within Terminal Server sessions will run, but will not run interactively. If a task is setup within a Terminal Server session and the same user is logged on at the console, the task will run interactively on the console even though it was not actually created in that session. The task will only be interactive to the console however, if the user was logged in when the task was started. If the user logs into the console and is not the user whose credentials launch the task, the task will not be interactive to either the console session or the remote Terminal Server session.

     

    Troubleshooting Steps:

     

    1. Check and see if the service is running using one of the following methods:

     

    2.  Start -> Run -> type 'services.msc' and click OK

     

    3.  Scroll down to the 'Task Scheduler' service.

     

    4. Check the 'Startup Type' column.

     

    The 'Startup Type' should be set to "Automatic".

     

    5. Check the 'Status' column.

     

    If the service is started, it will list 'Started' in the 'Status' column.

     

    6. Click the "Log On" Tab, and verify that "log on as: Local System account" and also select the checkbox of "Allow services to interact with desktop"

     

    7. Please also ensure that the user account is not in the "Logon as a Batch Job" and "Logon as Service" right.

     

    Hope it helps.


    David Shen - MSFT
    • Marked as answer by David Shen Monday, September 22, 2008 1:44 AM
    Thursday, September 18, 2008 8:26 AM

  • Hi,

    Our job is to start at 11 PM and it gives the same error message as metioned in the first post. Windows 2003 virtual sever SP2.

    The start up type is automactic.
    verified that "log on as: Local System account" and  selected the checkbox of "Allow services to interact with desktop
    I am a part of the admin group and it hsa only log on as service rights.

    Wanted to know if there was any other step we could try ro resolve this issue. Also is there a way to retype my password via a command line so that i do not have to log into the server and run this job

    I have tried the following - and this also fails, it does not reset the password as I assumed it would. Below is the error message I get. Would appreciate your suggestions for this issue.

    schtasks /run /tn sql_2008_begin /s Servername /u domain\user /p my_password_here

    "sql_2008_begin.job" (sql2008upgrade.bat) 3/31/2009 11:00:02 PM ** ERROR **
     The attempt to log on to the account associated with the task failed, therefore, the task did not run.
     The specific error is:
     0x80070569: Logon failure: the user has not been granted the requested logon type at this computer.
     Verify that the task's Run-as name and password are valid and try again.
    "sql_2008_begin.job" (sql2008upgrade.bat) 3/31/2009 11:05:53 PM ** ERROR **
     The attempt to log on to the account associated with the task failed, therefore, the task did not run.
     The specific error is:
     0x80070569: Logon failure: the user has not been granted the requested logon type at this computer.
     Verify that the task's Run-as name and password are valid and try again.


    Thanks
    Ashish Patel

    Wednesday, April 01, 2009 5:36 AM