none
Workflow not working after installing Service Pack 1 and patches

    Question

  • August and July Updates were installed on my farm (two servers App and Web) as part of regular windows patches cycle.

    I was not able to open  web applications and  service application page. Error was:

    Method 'Upgrade' in type 'Microsoft.SharePoint.WorkflowServices.WorkflowServiceApplicationProxy' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation.

     

    I installed Service Pack 1. After running wizard App server had an error (failed to upgrade product), Web server no errors.

    After SP1 instalation, I was able to open my web applications and service application. All functionality work except lunching workflows from lists.

     

    I am getting errors

    Sorry, something went wrong

    Method 'StartWorkflowOnListItem' in type 'Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation.

     

     

    08/24/2014 11:49:14.85         w3wp.exe (0x06D4)                               0x1F3C        SharePoint Foundation                 General                               8nca        Medium          Application error when access /_layouts/15/Workflow.aspx, Error=Method 'StartWorkflowOnListItem' in type 'Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation.   at Microsoft.SharePoint.WorkflowServices.FabricSolutionProviderFactory….

     

    08/24/2014 11:49:14.86         w3wp.exe (0x06D4)                               0x1F3C        SharePoint Foundation                 Runtime                               tkau        Unexpected        System.TypeLoadException: Method 'StartWorkflowOnListItem' in type 'Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation.    at Microsoft.SharePoint.WorkflowServices.FabricSolutionProviderFactory.<.cctor>b__3(WorkflowServicesContext context)     at Microsoft.SharePoint.WorkflowServices.FabricSolutionProviderFactory.GetProvider[T]...

     

    Here are list of updates on my servers:

    Patches

    KB2880552   Service Pack 1

     April

    KB2760319

     August

    KB2880994   Security Update

     August

    KB2880998

     August

    KB2881034

     August

    KB2863826

     July

    KB2863837

     July

    KB2881003

     July

    KB2881077

     July

     

    What I should do next ? Reinstall Updates?

    Sunday, August 24, 2014 6:01 PM

Answers

All replies

  • The workflow upgrade issue requires that STS and OServer patches are at the same version.

    Here is the security update which you will need to install.

    Update 2880963 for SharePoint Server 2013

    http://support.microsoft.com/kb/2880963

    Chcek the link for details.

    http://expertsharepoint.blogspot.de/2014/08/workflow-not-working-after-installing.html


    Anil Avula[MCP,MCSE,MCSA,MCTS,MCITP,MCSM] See Me At: http://expertsharepoint.blogspot.de/


    • Edited by Anil Avula Monday, August 25, 2014 9:07 AM
    • Marked as answer by Andrew493 Tuesday, August 26, 2014 1:48 AM
    Monday, August 25, 2014 8:58 AM
  • Thanks Anil I applied update. It fixed my problem.

    Andrew

    Tuesday, August 26, 2014 1:50 AM
  • Anil, Thanks!
    Sunday, September 28, 2014 1:15 AM
  • Will this update need to go on all the servers in the farm or just the workflow manager server?


    Monday, December 01, 2014 5:03 PM
  • WARNING: Applying this patch will take down services required to serve up SharePoint websites, even though it doesn't require a reboot. It only takes about 5 minutes to apply. 

    I fully patched via Windows Update in mid Dec 2014 and this update wasn't installed. I had to manually download it. It resolved this issue for me. The KB article states you can use WU to install it. Maybe there's something on MS WU service that needs to be tweaked?



    • Edited by SJNBham Friday, December 19, 2014 6:43 PM
    Friday, December 19, 2014 6:41 PM
  • Hi Anil

    I got this same error when I open my SharePoint site. But this hotfix has saved my life.

    hotfix (KB2880963): http://www.microsoft.com/en-us/download/details.aspx?id=42898

    Thanks
    Manish Upadhyay


    Manish

    Saturday, August 08, 2015 7:17 AM
  • Thanks Anil, This fixed my issue.
    Friday, September 04, 2015 9:21 PM
  • hi anil , i got the same issue after installing the security update recently , all things are working only workflow is not working on list 

    below pasted the error, anyone please help me put from this 

    Error

    Message: An unhandled error has occurred. To view details about this error, enable debugging in the web.config file or view the Windows event logs.

    Source: Microsoft.SharePoint.WorkflowServices

    Exception details:

    Method 'StartWorkflowOnListItem' in type 'Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation.

    at Microsoft.SharePoint.WorkflowServices.FabricSolutionProviderFactory.<.cctor>b__3(WorkflowServicesContext context)
    at Microsoft.SharePoint.WorkflowServices.FabricSolutionProviderFactory.GetProvider[T](WorkflowServicesContext context)
    at Microsoft.SharePoint.WorkflowServices.WorkflowServicesManager.GetProvider[T]()
    at Microsoft.SharePoint.WorkflowServices.ApplicationPages.WorkflowPageBase.ConstructStatusArraysWF4(ArrayList running, ArrayList completed, Boolean onlyMyWorkflows)
    at Microsoft.SharePoint.WorkflowServices.ApplicationPages.WorkflowPage.ConstructStatusArrays()
    at Microsoft.SharePoint.WorkflowServices.ApplicationPages.WorkflowPage.OnLoad(EventArgs e)
    at System.Web.UI.Control.LoadRecursive()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    Tuesday, May 16, 2017 9:45 PM