none
Workflow not working after installing Service Pack 1 and patches

    Question

  • August and July Updates were installed on my farm (two servers App and Web) as part of regular windows patches cycle.

    I was not able to open  web applications and  service application page. Error was:

    Method 'Upgrade' in type 'Microsoft.SharePoint.WorkflowServices.WorkflowServiceApplicationProxy' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation.

     

    I installed Service Pack 1. After running wizard App server had an error (failed to upgrade product), Web server no errors.

    After SP1 instalation, I was able to open my web applications and service application. All functionality work except lunching workflows from lists.

     

    I am getting errors

    Sorry, something went wrong

    Method 'StartWorkflowOnListItem' in type 'Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation.

     

     

    08/24/2014 11:49:14.85         w3wp.exe (0x06D4)                               0x1F3C        SharePoint Foundation                 General                               8nca        Medium          Application error when access /_layouts/15/Workflow.aspx, Error=Method 'StartWorkflowOnListItem' in type 'Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation.   at Microsoft.SharePoint.WorkflowServices.FabricSolutionProviderFactory….

     

    08/24/2014 11:49:14.86         w3wp.exe (0x06D4)                               0x1F3C        SharePoint Foundation                 Runtime                               tkau        Unexpected        System.TypeLoadException: Method 'StartWorkflowOnListItem' in type 'Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider' from assembly 'Microsoft.SharePoint.WorkflowServices, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' does not have an implementation.    at Microsoft.SharePoint.WorkflowServices.FabricSolutionProviderFactory.<.cctor>b__3(WorkflowServicesContext context)     at Microsoft.SharePoint.WorkflowServices.FabricSolutionProviderFactory.GetProvider[T]...

     

    Here are list of updates on my servers:

    Patches

    KB2880552   Service Pack 1

     April

    KB2760319

     August

    KB2880994   Security Update

     August

    KB2880998

     August

    KB2881034

     August

    KB2863826

     July

    KB2863837

     July

    KB2881003

     July

    KB2881077

     July

     

    What I should do next ? Reinstall Updates?

    Sunday, August 24, 2014 6:01 PM

Answers

All replies