locked
Problem with run Suse11 SP2 after convert using Microsoft Virtual Machine Converter - Linux cannot find device /dev/sda2 RRS feed

  • Question

  • Hi

    I tried to convert Suse11 SP2, 64 bit from VMWare 5.5 vCenter to Hyper-V 2012 R2 using Microsoft Virtual Machine Converter.

    Operation finished succesfully but when i Run VM on Hyper-V, linux system cannot find hard disk. In boot window i see that Information:

    Waiting for device /dev/sda2 to appear..

    I converted windows 7 SP1 and similar problem. Windows cannot start automatically. After looking for problems with system, system Windows OS faild to run.

    All OS don't have VMware Tools installed and during convert operation were shuted down.

    Thank you for help.


    Kind Regards Tomasz

    • Moved by BrianEhMVP Thursday, August 11, 2016 4:13 PM
    Thursday, August 11, 2016 1:37 PM

All replies

  • You have to modify your grub bootloader.

    sda is a SCSI boot device.  So you would have to have created a Generation 2 VM.

    If you created a Generation 1 VM then you would need to change this to hda

    Very similar process to what I outline here:

    http://itproctology.blogspot.com/2009/06/pv-enabling-hvm-from-vmware-on.html

    Step 4 mentions modifying grub


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Thursday, August 11, 2016 4:12 PM
  • Hi

    Ok, but using "Microsoft Virtual Machine Converter" I don't see option to select virtual machine generation.

    I'll test it tommorow but i'm disappointed Microsoft programs ""Microsoft Virtual Machine Converter" and SC Virtual Machine Manager. None of them can't convert VMWare VM to Hyper-V without problems. What a pity....

    I use VMWare converter and convert Hyper-V VM to VMWare VM and it worsk without any problems with Linux and Windows OS...

    Hyper-V never be the first in line hypervisior if Microsoft cannot make full compatible converter with VMWare solutions...


    Kind Regards Tomasz


    • Edited by Yukio Seki Thursday, August 11, 2016 7:13 PM bug
    Thursday, August 11, 2016 7:11 PM
  • Hi

    Sorry but I'm not linux admin.

    Modify the grub boot loader menu (the default entries are not pygrub compatible)

    Open /boot/grub/menu.lst in the editor of your choice

    How can I do it? When i run VM with Suse my console sutck here:


    Kind Regards Tomasz

    Friday, August 19, 2016 10:35 AM