none
Where has Server 2012 Safe Mode gone - Startup Settings missing too?! RRS feed

  • Question

  • Hi, I desperately need Safe Mode (No Networking etc) in Windows 2012 RTM as the server is down because a bad network driver is generating BSOD due to IRQL_NOT_LESS_OR_EQUAL. This should be simple to disable... but in Win 2012 it isn't!

    I have already seen the articles about how F8 is different now (useful feature change in emergencies...) but if you use Shift-F8 you should get into the Troubleshoot -> Advanced Options, and phew, I can do that just about (after many long reboots and F8 mashing - it's a luck thing) - however am stunned to find that slightly contrary to article screenshots, I have the icons for:

    • System Restore
    • System Image Recovery
    • Automatic Repair
    • Command Prompt
    • Startup Settings - oh no, hang on - this one is NOT THERE!!!

    Naturally, Startup Settings is the one I need to switch this cursed thing into Safe Mode! So why is it not there on some servers - I wasn't aware that there were any hardware dependencies for this. It's an HP ProLiant DL120 G7, but this is an OS issue, not straight hardware (in which case I'd expect the setting to be there but cause an error/warning).

    This may be something to do with the OS being in Recovery Mode etc - but that is the whole point of needing Safe Mode! So what is the way to get into that please, so I can simply disable the bad driver and get on with our business?

    Phil

    Wednesday, October 2, 2013 6:21 PM

Answers

  • Hi,

    To enable Safe Mode, please try the following:

    1. If you can boot into Windows, please open a privileged command prompt.

    2. If not, please boot into recovery mode and run command prompt.

    3. In the command prompt, please input

    Bcdedit /set {bootmgr} displaybootmenu yes

    4. Once completed, please restart your computer, then press F8 to enter setup screen upon startup, then press F4 or 4 to enter safemode.

    References:

    How to easily enter safe mode in windows 8? (One-click series)

    http://support.microsoft.com/kb/2809468

    Hope this helps.


    Niki Han
    TechNet Community Support

    • Marked as answer by TickboxPhil Wednesday, October 9, 2013 3:55 PM
    Saturday, October 5, 2013 4:22 PM
    Moderator

All replies

  • Hi,

    To enable Safe Mode, please try the following:

    1. If you can boot into Windows, please open a privileged command prompt.

    2. If not, please boot into recovery mode and run command prompt.

    3. In the command prompt, please input

    Bcdedit /set {bootmgr} displaybootmenu yes

    4. Once completed, please restart your computer, then press F8 to enter setup screen upon startup, then press F4 or 4 to enter safemode.

    References:

    How to easily enter safe mode in windows 8? (One-click series)

    http://support.microsoft.com/kb/2809468

    Hope this helps.


    Niki Han
    TechNet Community Support

    • Marked as answer by TickboxPhil Wednesday, October 9, 2013 3:55 PM
    Saturday, October 5, 2013 4:22 PM
    Moderator
  • Perfect, thanks Niki, good link too - I wish I could have found this when I searched for "safe mode windows 2012" on technet but the first pages were all random articles without this clear article or your notes. This sorts it (and this post comes up in search now!). Cheers, Phil. 
    Wednesday, October 9, 2013 3:55 PM
  • you can enable safe mode by using msconfig from Windows server 2012, Windows 8 normal mode. Or you can press shift while booting PC. 

    http://www.vmwareandme.com/2014/01/guide-how-to-boot-windows-8-windows-81.html


    www.mytricks.in


    Tuesday, January 21, 2014 11:26 AM
  • SHIFT+F8 will get you into Server 2012's Advanced Boot Options Menu!

    You can choose Safe Mode etc. from there

    I am spreading the word after spending a day attempting to fix a boot loop by booting to an install DVD and trying and failing to use Command Prompt to run bcdedit

    Hope this works for anyone whose servers are crippled by Windows updates

    • Proposed as answer by JosiasMJr Tuesday, December 31, 2019 1:05 PM
    Thursday, December 19, 2019 10:45 AM
  • SHIFT-F8 was the best and easiest solution so far. Thanks a lot for that, DPK jobsbody.  I needed no more than 5 minutes to solve.  Worked fine for my server. (HP Proliant ML350P gen8).

    How I did it IN DETAILS:

    I turned power on and kept SHIFT pressed while pressing F8 repeatedly.
    The server went all its initial configurations and entered a RAID / DISK menu. As this menu was not the desired one, I simply pressed ESC to exit and continued pressing SHIFT-F8 repeatedly.

    After that Windows finally entered its Boot Options Menu as described above by DPK jobsbody, and I could choose  "Safe Mode"


    • Edited by JosiasMJr Tuesday, December 31, 2019 11:15 PM Deleted unuseful info.
    Tuesday, December 31, 2019 1:04 PM