none
"The parameter is incorrect" error when creating mount point in Server 2008 cluster

    Question

  • I am receiving the error "The parameter is incorrect" when attempting to create a new mount point in an existing Server 2008 R2 2-node cluster.  This cluster hosts four SQL 2008 virtual servers and I am trying to add new disk to one of those virtual servers.  I am able to create the folder on the virtual server's Root Mount Point and am able to successfuly format the SAN drive, but get the error when pointing the drive at the folder.  I am trying to add this with minimal disruption of the running SQL instances.  I am using the Disk Manager GUI and all permissions are correct, with SYSTEM having FC over the folders on the RMP.

    Do I need to completely take the virtual server, to which I am adding the mount point, offline?

    Tuesday, October 12, 2010 11:51 AM

Answers

  • Turns out, I wasn't adding the disk in the Failover Cluster Manager first.  I was trying to set up the disk and THEN add it to FCM.

    Within Failover Cluster Manager, right click on the Storage icon and select Add a disk.  You should now see the new LUN(s) and add them.  They will show up as Cluster Disk # so then you should probably rename them in FCM.  You can then assign the mount points in Disk Manager.

    • Marked as answer by Scott Livesey Tuesday, October 12, 2010 1:45 PM
    Tuesday, October 12, 2010 1:45 PM

All replies

  • Turns out, I wasn't adding the disk in the Failover Cluster Manager first.  I was trying to set up the disk and THEN add it to FCM.

    Within Failover Cluster Manager, right click on the Storage icon and select Add a disk.  You should now see the new LUN(s) and add them.  They will show up as Cluster Disk # so then you should probably rename them in FCM.  You can then assign the mount points in Disk Manager.

    • Marked as answer by Scott Livesey Tuesday, October 12, 2010 1:45 PM
    Tuesday, October 12, 2010 1:45 PM
  • Thanks forgot doing this on a core cluster.
    yup
    Monday, January 23, 2012 4:50 AM
  • Actually you get this error when you are adding a mountpoint to a disk which is already a cluster resource.  So if you were to go FCM and detect the storage and rename in FCM, your disk/mp still not showing up in that drive:\MP
    Monday, January 30, 2012 9:37 PM
  • So what do you to get around this? 

    First, you are encountering this problem because the Disk where you are trying to mount the Mount Point is in use by the High Availibility Cluster.   You need to go to Cluster Manager and put the Disk where you will be placing the MountPoint on (e.g. L:\) in Maintenance Mode.  Then perform your operation and you will not encounter that error.

    Monday, January 30, 2012 10:03 PM
  • Hi,

    I'm having similar difficulties. My scenario is as follows:

    • A failover cluster group exists and has a volume (G:) that successfully moves between nodes.
    • A new volume temporarily added to this existing cluster group with a drive letter (H:), which successfully moves between nodes. Removed from the cluster group so it's listed in Available Storage.
    • In Disk Management I can select Change Drive Letter and Paths. No drive letter exist. I Add a path to G:\MountedDrive and I receive an error, The parameter is incorrect.

    Things I've tried:

    • Putting the volume into maintenance mode within FCM but it doesn't change the outcome from when it's not in maintenance mode.
    • Removing from FCM entirely then temporarily mounting it as a directory on a local drive, this works. I then try mounting it as a directory on the clustered volume (as above) but again the error persists.
    • Moving the new storage and cluster group to anther node and retrying, but again the error persists.
    • The none of the Event Logs show a single error.

    Any ideas?


    • Edited by GJCanon Monday, July 22, 2013 12:05 AM Additional detail added.
    Monday, July 22, 2013 12:03 AM
  • Had same problem today, what i have done to resolve this:

    1. remove storage from FS service -> showed under storage -> available storage. 2. Enabled Maintenance Mode. 3. closed Service manager and reopened it 4. done rescan 5. successifully created mount points. When i had these disks under service and with maintenance mode, had same erorr, when created mount points

    Friday, February 20, 2015 2:45 PM
  • this here is the answer. Thanks 
    Friday, February 26, 2016 2:48 AM
  • I have found out a simple solution for this issue

    Find out the cluster node (drive), in which you are trying to create mount point.

    For example if you are trying to create mount point in F:\ drive do the following:

    1.Open failover cluster manager

    2.check all the cluster disks which is already mounted under F:\ drive

    3.Turn on the maintenance in all the cluster disk already mounted under F:\ drive

    4.Now go to disk manager and check the newly assigned Lun drive

    5.Right click and create new simple volume by pointing the path to F:\ , click create new folder, rename it whatever name you want and click next

    6.Finally click create. Now the mount point will create without , parameter incorrect issue

    7.Now go to cluster manager, add disk and select the volumes and add it

    8.Once added, move the cluster volume to required instance

    9.Now turn off the maintenance mode in already assigned cluster disks.

    This is tried and tested. Hope this will help. Provide me in reply, if it resolves the problem

    Friday, November 11, 2016 1:50 AM