none
SCCM Clients are uninstalling RRS feed

  • Question

  • I just noticed that many clients no longer have SCCM installed...I tried to push the client from our server to my PC...I could open then SCCM console.  But, after about 10 mins the SCCM console for the local client is now missing...some clients are still working properly and are installed, but most do not have the client and are listed as "Inactive" under Client Activity...we are using PKI certificates and are communicating using HTTPS only...Let me know if I can provide any logs or info that would shed some light on this issue...

    Thanks in advance!

     

    x

    Tuesday, May 21, 2019 3:50 PM

All replies

  • Nothing in ConfigMgr will automatically uninstall the client agent.

    To clarify here though, what *exactly* do you mean by "many clients no longer have SCCM installed"?

    Are you simply going by the Client column in the console or are you directly examining these client systems?

    If the former, that simply means that something has reset the value on the resource and in no ways reflects the actual client agent installation status. The only thing in ConfigMgr that will do this is the clear client flag site maintenance task which is not enabled by default. This task, as its name implies, resets the client attribute to 0 on resources where it hasn't received a heartbeat DDR in the number of days specified.

    Also, during client push, there are short periods where corresponding resources will completely disappear from the console.

    And finally, Inactive does not in any way mean that no client is installed so if that's what you're going by, then you're going down the wrong path. Inactive simply means that the client has not communicated with the site in 7 days (by default). There's no way to know why it hasn't communicated without directly examining that system.


    Jason | https://home.configmgrftw.com | @jasonsandys

    Tuesday, May 21, 2019 4:30 PM
    Moderator
  • Thanks for the reply Jason.

    I'm looking manually on each PC/Sever for System Center...I'm also attempting to run Hardware Inv via rt click tools using the console on the server...which produces:

    Error running action on PC You cannot call a method on a null-valued expression. Cannot convert value "\\PC\root\ccm:SMS_Client" to type "System.Management.ManagementClass". Error: "Invalid namespace "

    I'm not going by Inactive, rather I'm highlighting the fact it goes hand in hand with the fact that many clients seem to be missing from much of our environment...

    What other info would help shed some light on this issue?


    x

    Tuesday, May 21, 2019 5:05 PM
  • OK, then it does appear that the client agent itself is being uninstalled. As noted though, there is nothing in ConfigMgr that will ever do this automatically  so you need to track down whatever external process in your environment is responsible for this.

    As a side note as well, "System Center" has very little meaning in the context of ConfigMgr -- it's purely a marketing and licensing label.


    Jason | https://home.configmgrftw.com | @jasonsandys

    Tuesday, May 21, 2019 6:06 PM
    Moderator
  • I'm looking manually on each PC/Sever for System Center

    I just want to be clear. What do you mean by this? You won't find the ConfigMgr client in Programs and Features. You should see the following though:

    • the Configuration Manager applet in Control Panel
    • the Software Center app from the Start Menu

    I've also never heard of the client being uninstalled by some other process.



    Gerry Hampson | Blog: www.gerryhampsoncm.blogspot.ie | LinkedIn: Gerry Hampson | Twitter: @gerryhampson

    Sunday, May 26, 2019 11:39 AM