locked
search service - indexing not working not certain directories RRS feed

  • Question

  • Hi there,

    I have a windows 2012 storage server running, where I index some folders. I have noticed a odd thing -

    I have a directory called 1_Foto  and all files within this directory does not get index, though the file types is within the types which is indexed (png/jpg). This directory is a subdirecotory on a local share that is included in the search index.

    If I copy some of the files from the 1_foto directory to another directory called TEST the files is indexed

    I have rebuild the index 2 times - same result. If I test with "Everyting" from Void tools, files in 1_Foto directory gets indexed.

    Does WS2012 have a bug here or ?

    Regards

    Robert

    Thursday, January 30, 2014 8:03 PM

Answers

  • Hi Amy

    Well, I don´t get any index failures except the files does not seem to get indexed.

    But what I think it is related to is de-duplication. I have enabled de-dup on the volume and it seems it is files that are de-duped which is not indexed. Copying files to a new direcory leaves them un-deduped for 5 days.

    Is there a bug with windows search and deduplication?

    regards

    robert

    • Marked as answer by Amy Wang_ Thursday, February 13, 2014 2:54 AM
    Tuesday, February 4, 2014 8:35 PM
  • Hi Robert,

    According to the response I have received, this behavior is a known Data Deduplication interoperability limitation with Windows Search Service Indexer.

    That is because Windows Search Indexer skips files which carry reparse points, while de-duplicated files carry reparse points, as the similar thread refers.

    Therefore, using Windows Search Service to index de-duplicated files is not supported by now.

    I hope this helps.

    Amy

    • Marked as answer by Amy Wang_ Thursday, February 13, 2014 2:54 AM
    Thursday, February 6, 2014 2:18 AM

All replies

  • Hi Robert,

    Would you please tell us the error message when index fails?

    Is this file a hidden file?

    Here is a related KB below for your references:

    You cannot find files when you search a Windows Vista-based computer even though the files exist on the computer

    http://support.microsoft.com/kb/932989

    Best Regards,

    Amy Wang

    Friday, January 31, 2014 10:44 AM
  • Hi Amy

    Well, I don´t get any index failures except the files does not seem to get indexed.

    But what I think it is related to is de-duplication. I have enabled de-dup on the volume and it seems it is files that are de-duped which is not indexed. Copying files to a new direcory leaves them un-deduped for 5 days.

    Is there a bug with windows search and deduplication?

    regards

    robert

    • Marked as answer by Amy Wang_ Thursday, February 13, 2014 2:54 AM
    Tuesday, February 4, 2014 8:35 PM
  • Hi Robert,

    I have found a similar thread as below:

    Widows Search not working with Data Deduplication?

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/d8c9c5b1-fc38-476d-a780-e14910edcf6f/widows-search-not-working-with-data-deduplication?forum=winserverfiles

    Since there is no definite answer in this thread, I am now consulting some experts in deduplication field about this issue, I will let you know the outcome as soon as I get a response from them.

    Regards,

    Amy

    • Edited by Amy Wang_ Wednesday, February 5, 2014 9:49 AM
    Wednesday, February 5, 2014 9:47 AM
  • Hi Robert,

    According to the response I have received, this behavior is a known Data Deduplication interoperability limitation with Windows Search Service Indexer.

    That is because Windows Search Indexer skips files which carry reparse points, while de-duplicated files carry reparse points, as the similar thread refers.

    Therefore, using Windows Search Service to index de-duplicated files is not supported by now.

    I hope this helps.

    Amy

    • Marked as answer by Amy Wang_ Thursday, February 13, 2014 2:54 AM
    Thursday, February 6, 2014 2:18 AM
  • Hi Amy

    Thank you.

    I started a de-dup unoptimise on the volume and now the files is indexed correct, so yes, this is the issue.
    I had a de-dup rate of 40% which I think is very good - so I have wasted a lot of space now. Do you know (or the team responsible for the search index service) when this bug will be fixed?

    I have many many files and manual looking through these by hand is not a real option. I could use 3. party search tools, but I also use ExtremZ-IP on the server which is depending on Windows Search Service.

    Regards
    Robert

    Thursday, February 6, 2014 5:39 AM
  • Hi Robert,

    The Deduplication development team is working on this issue, and we don’t know when this interoperability limitation will be overcome yet.

    As a workaround, if you just want to search specific folders during your daily work, I suggest you add these folders to the “To exclude selected folders (and any files contained in them) from data deduplication” section, when you enable data deduplication.

    Regards,

    Amy

    Friday, February 7, 2014 6:39 AM
  • Amy,

    Any idea when there will be an update that solves this issue?
    We are almost a year later...

    Thanks.

    Regards,


    Kristof

    Tuesday, December 30, 2014 1:34 PM
  • Hi Amy

    Thank you.

    I started a de-dup unoptimise on the volume and now the files is indexed correct, so yes, this is the issue.
    I had a de-dup rate of 40% which I think is very good - so I have wasted a lot of space now. Do you know (or the team responsible for the search index service) when this bug will be fixed?

    I have many many files and manual looking through these by hand is not a real option. I could use 3. party search tools, but I also use ExtremZ-IP on the server which is depending on Windows Search Service.

    Regards
    Robert

    any update? i just ran into this terrible limitation after spending weeks migrating terabytes of data to 2012 and deduping it. :(
    Thursday, July 9, 2015 10:12 PM