none
Task Scheduler Errors in Windows Server 2003

    Question

  • I am using Windows Server 2003 R2 Standard SP2 and I try to create a Scheduled Task but I get an error message upon finishing that says (the details below are from when I tried to create a scheduled backup but I get the same error messages no matter what type of scheduled task I try):

    The new task has been created, but may not run because the account information could not be set.
    The specific error is:
    0x80004005: Unspecified error

    If I try to open the properties of the schedule task that does get created I get this error:

    General page initialization failed.
    The specific error is:
    0x80004005: Unspecified error
    An error has occurred attempting to retrieve task account information. You may continue editing the task object, but will be unable to change the task account information.

    If I try to run the task I do not get a pop up error message but the status of the task is "Could not start"

    I am logged as the system administrator and I am entering the username and password correctly when prompted by the task scheduler.  I have checked that the Task Scheduler Service is automatically running and is logging on as the System Account.  I have tried logging in as a different users with administrative rights and created a scheduled task but I have the same problem. I have deleted all other bkf and job files and created new ones from scratch.  I have deleted the Crypto/RSA/S-1-5-18 db4* files and allowed them to be recreated by task scheduler. 

    Any suggestions?
     
    All that being said I have no idea if this play any part but I recently had the server power supply flake out which caused the server to constantly power cycle thus preventing the OS from ever booting correctly.  This corrupted something in the first member of my System Volume RAID array.  I replaced the PS and booted off the second member of the RAID array and was back in business.  Once the boot sequence checked out and the system was operational I reconnected what was the first member of the RAID and allowed the system to it mirror it now as the second member of the RAID array.  Again, all seems well.  The task scheduler is the only issue I have had since this power problem.

    Friday, March 06, 2009 5:01 PM

Answers

All replies

  •  Please review the troubleshooting steps at http://support.microsoft.com/kb/308558/en-us . Especially the section on "Checking the Task Scheduler Service"
    ------- this information is provided as-is without any warranties, implicit or explicit.
    Friday, March 06, 2009 5:33 PM
  • Thanks.
    The Task Scheduler Service is started, automatic, local system account is selected, and interact with desktop is checked. I tried again to create a task and the same error messages persist. 
    Friday, March 06, 2009 6:12 PM
  • Hi,
    Then it trigger an issue, chk the event viewer and try to track the task scheduler error and chk too the Dependency of the Task Scheduler if it is running without issues.

    If you got an error code on the event viewer post it here or try to figure out by your self on http://support.microsoft.com.

    Good luck!!!
    Regards,
    Friday, March 06, 2009 7:15 PM
  • There is no entry in the Event Viewer (Application, System, etc...) for these Task Scheduler errors.  I just get the error messages that pop up on the screen.  Is there another place I can find the log of these errors?  Any other suggestions?  All dependent services are running properly.
    Wednesday, March 11, 2009 3:07 PM
  •  

    Hi,

     

    For this issue, I suggest referring to the following articles:

     

    Error message when you run an old scheduled task or a newly created scheduled task on a Windows Server 2003 Service Pack 2-based domain controller: "0x8007000d: The data is invalid"

    http://support.microsoft.com/kb/958837/en-us

     

    "The attempt to retrieve account information for the specified task failed" error message when you use Task Scheduler to schedule volume shadow copy to run in Windows Server 2003

    http://support.microsoft.com/kb/822904/en-us

     

    Task Scheduler returns a "HRESULT: 0x8007007A" error message after you save many jobs

    http://support.microsoft.com/kb/264522/en-us

     

    You receive error message 0x80090016 or error message 0x8009000f when you try to schedule a task

    http://support.microsoft.com/kb/246183/en-us

     

    Problems if the Cryptography Subsystem Is Damaged

    http://support.microsoft.com/kb/306964/en-us

     

    Hope it helps.

     

    Tim Quan - MSFT

     

    Friday, March 13, 2009 4:00 AM
    Moderator