none
wmi error 0x80041032 a.k.a. "Call Cancelled" , with WMI query that returns over 2K VMs RRS feed

  • Question

  • I configured about 2200 HyperV VMs , on WS2012 R2.  These VMs aren't running.

    When I do a WMI query ( in c# ) , that is about equivalent to get-vm , the WMI query fails. In the event log, the error code is

    0x80041032

    There are no problems if e.g., the VMs are 1024 , 1100 etc., running or not.  Then my cmdlet runs OK.

    AFAIK, our WMI wrapper is configured with default, and max settings for buffers and timeouts.

    And ideas?

    -- Marteen

    Friday, March 28, 2014 12:51 AM

Answers

  • usually 0x800410xx and 0x800440xx are WMI errors. It means that a specific WMI operation failed. For instance, it could be due insufficient privileges to perform the WMI requested operation or due to the nature of the request itself or due to a WMI infrastructure issue, such as WMI DCOM registration issue.

    1. You can try to rebuild the WMI Modules

    At a command prompt (cmd), change to the WBEM folder.
    cd %windir%\system32\wbem
    Carefully type the following command to make sure that all the WBEM DLLs are correctly registered.
    for /f %s in ('dir /b *.dll') do regsvr32 /s %s

    2. Try to rebuild the WMI Repository

    =========================

    a.
    Disable and stop the WMI service.

    sc config
    winmgmt start= disabled

    net stop
    winmgmt

    b. At a
    command prompt (cmd), change to the WBEM folder.

    cd
    %windir%\system32\wbem

    c. Rename
    the repository folder

    rename
    repository repository.old

    d.
    Re-enable the WMI service.

    sc config
    winmgmt start= auto

    e. Run
    the following command to manually recompile all of the default WMI .mof files
    and .mfl files

    cd
    %windir%\system32\wbem

    for /f %s
    in ('dir /b *.mof *.mfl') do mofcomp %s


    3. Verfity if the account you used has enough permission on WMI:

    http://technet.microsoft.com/en-us/library/cc787533(v=WS.10).aspx

    Meanwhile, you can verify if you can manually run the WMI query in wbemtest localy.

    Thanks.

    Kevin Tu



    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    Monday, March 31, 2014 9:25 AM

All replies

  • Hi ,

    Thank you for posting your issue in the forum.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Best Regards,

    Andy Qi

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Andy Qi
    TechNet Community Support

    Monday, March 31, 2014 7:37 AM
    Moderator
  • usually 0x800410xx and 0x800440xx are WMI errors. It means that a specific WMI operation failed. For instance, it could be due insufficient privileges to perform the WMI requested operation or due to the nature of the request itself or due to a WMI infrastructure issue, such as WMI DCOM registration issue.

    1. You can try to rebuild the WMI Modules

    At a command prompt (cmd), change to the WBEM folder.
    cd %windir%\system32\wbem
    Carefully type the following command to make sure that all the WBEM DLLs are correctly registered.
    for /f %s in ('dir /b *.dll') do regsvr32 /s %s

    2. Try to rebuild the WMI Repository

    =========================

    a.
    Disable and stop the WMI service.

    sc config
    winmgmt start= disabled

    net stop
    winmgmt

    b. At a
    command prompt (cmd), change to the WBEM folder.

    cd
    %windir%\system32\wbem

    c. Rename
    the repository folder

    rename
    repository repository.old

    d.
    Re-enable the WMI service.

    sc config
    winmgmt start= auto

    e. Run
    the following command to manually recompile all of the default WMI .mof files
    and .mfl files

    cd
    %windir%\system32\wbem

    for /f %s
    in ('dir /b *.mof *.mfl') do mofcomp %s


    3. Verfity if the account you used has enough permission on WMI:

    http://technet.microsoft.com/en-us/library/cc787533(v=WS.10).aspx

    Meanwhile, you can verify if you can manually run the WMI query in wbemtest localy.

    Thanks.

    Kevin Tu



    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    Monday, March 31, 2014 9:25 AM
  • Hi,

    i am just following up to check if any updates on this issue.


    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    Tuesday, April 8, 2014 2:07 AM
  • Hi,

    i am just following up to check if any updates on this issue.


    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    I know this is Old but I wanted to say thank you. It solved my problem as well. http://answers.microsoft.com/en-us/windows/forum/windows8_1-performance/pagefile-thrashing-and-high-msmpengexe-thrashing/f1e0afbe-a0bb-4307-9547-d40ef4ec5102?page=1
    Tuesday, November 4, 2014 9:15 AM