Windows 2008 Server R2 - Service Pack 1 Failed to install


  • A few nights ago I deployed Service Pack 1 for Windows 2008 Server R2 x64.  The update failed to install after 3 attempts using the Windows Update manager.  After the third time I checked the system properties which states that SP1 is installed, yet it never appeared to install successfully as my other server machine had a prompt stating the SP was installed successfully. 

    In update history it shows the 3 failed attempts with no successes.  This morning I began running into memory errors which are impacting my 2 VM Ware sessions which in turn lock up my virtual machine so I am going to attempt to remove and reinstall to see if this corrects my issue.  By the way what triggered the install of SP1 is random reboots of my server.  This is that unknown Kernal Power Error which I have yet to resolve.  Some months my server randomly reboots one time and other months 4-5x.  That is neither here nor there, the point of this discussion is to resolve SP1. 

    I have tried to remove SP1 by means of Control Panel, Programs and Features, Installed Updates.  So it shows the that the SP1 installed in multiple areas yet in the install history no signs of successful installation.

    When trying to uninstall from Program and Features/Installed Updates section in control panel it cycles through like its going to uninstall, but after several minutes I receive the following error      Windows Update      An error has occurred. Not all of the updates were successfully uninstalled.

    When trying to uninstall from the command prompt (as administrator) "wusa.exe /uninstall /kb:976932" I get the following popup            Windows Update Standalone Installer         Installer encountered an error: 0x80073712       The component store has been corrupted.

    Now if I try and install through the network installer file name "windows6.1-KB976932-X64.exe" I get "Windows Server 2008 R2 Service Pack 1 is already installed"

    I performed these steps in the order mentioned which I came across this "System Update Readiness Tool for Windows Server 2008 R2 x64 Edition (KB947821) [February 2011]" After applying this hotfix I went through the same steps as mentioned above with the exact same results.

    It is unfortuante I did not come across this hotfix before I attempted install SP1 as it appears as if this would have prepared the system for SP1 installation.  Currently I am in limbo with a corrupt installation of SP1 and so far no means of uninstalling short of a reinstallation or repair of the OS which I am not willing to do at this point in time.

    If anyone has any suggestions please chime in and let me know what I can try.  Thanks for all the support and hopefully this post will help others in the future.

    Friday, February 25, 2011 4:50 PM


All replies

  • You might try the Fixit tool here.

    You might also be able to repair in-place (or revert to snapshot), then update readiness, and finally SP1






    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]
    Saturday, February 26, 2011 6:38 PM
  • Dave,

    Thanks for your response.  When attempting to run the fixit program I get "This Microsoft Fixit does not apply to your operating system or application version".  Is there a version for 2008 Server R2 x64?

    Next question is the repair you mention.  Can this be performed by booting to OS DVD and choose repair rather than recovery console?  I know this option was available in XP, but haven't had to do this on the mentioned server OS.

    If you can clarify it would be greatly appreciated.  Again Thanks for the response.

    As a side note tomorrow morning I plan to update all motherboard drivers which include sound, chipset and raid controller drivers along with the latest firmware for mainboard EVGA P55 FTW.  Hopefully this will cure the Kernel Power issue.  I have yet to receive this error (and random reboot) in the past week.



    Wednesday, March 02, 2011 4:31 AM
  • This articlew may help.

    How to Perform an In-Place Upgrade on Windows Vista, Windows 7, Windows Server 2008 & Windows Server 2008 R2





    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]
    Wednesday, March 02, 2011 10:19 AM
  • Dave,

    Thanks again for the prompt response. I attempted to perform the in-place upgrade using the original DVD and now I am getting the following:

    Compatibility Report-

    The following issues are preventing Windows from upgrading.  Cancel the upgrade, complete each task, and then restart the upgrade to continue.

    - Your current version of Windows is more recent than the version you are trying to upgrade to.  Windows cannot complete the upgrade.

    Would it be safe to download and burn 2008 Server R2 SP1 iso off MSDN and try with that disk or do you have any other thoughts?

    Wednesday, March 02, 2011 9:08 PM
  • Dave,

    I took the initiative and downloaded 2008 Server R2 SP1 and this actually let me proceed past the compatibility report (mentioned below).  It starts to cycle through Copying Files and proceeds to "Gathering files, settings and programs" I get the following popup:

    Install Windows

    Setup can't continue.  Restart the computer and restart Setup.  When prompted, try getting the latest updates.

    I have tried 3x with no success.  Anything else you can recommend?



    Wednesday, March 02, 2011 10:38 PM
  • Can you revert to a snapshot?




    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]
    Thursday, March 03, 2011 3:57 AM
  • Reverting to a snapshot can only be done on Virtual Machines Correct?  This is my primary domain controller, exchange server, file server, DNS amongst other roles.

    I run a secondary domain controller 2008 Server R2 Standard through a Virtual Machine.  The future of this install is looking bleak.



    Thursday, March 03, 2011 1:38 PM
  • I somehow thought it was a VM. Yes you don't want to revert a snapshot on a domain controller anyway. You may need to transfer roles and rebuild it.

    Using Ntdsutil.exe to transfer or seize FSMO roles to a domain controller





    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]
    Friday, March 04, 2011 4:00 AM
  • Dave,

    2 Virtual machines (Win 7 - my dedicated work PC & 2008 R2Server - secondary DC) run on this server, but the host OS for this server is 2008 Server R2 which is not a VM.  When the time is right I can transfer roles to the secondary.  I would have to transfer VM temporarily to my workstation PC so that it remains active during the rebuild process as I dont have a dedicated server for the secondary DC.

    One thing I am hoping you can point me in the right direction.  Exchange 2010 is on the Host OS experiencing issues.  My secondary DC does not have exchange currently installed.  What can I do to streamline the process as I don't want to lose my Exchange installation - mail, contacts, calendar, etc?  Do I install Exchange on DC2?  Is there an option for a secondary server similar to a secondary DC?  Never had to do this so hopefully you can assist with some direction.



    • Proposed as answer by klappa Wednesday, February 22, 2012 8:42 AM
    • Unproposed as answer by klappa Wednesday, February 22, 2012 8:42 AM
    Friday, March 04, 2011 3:36 PM
  • Wow, talk about a being between a rock and a hard place. I hope this isn't production. I don't think it's recomended to install Exchange on a DC anyway. Sounds like you'll need two more boxes at least temporarily. One for exchange and one to stand up as a DC. I'd ask them here about options with moving Exchange to anther host.





    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]
    Saturday, March 05, 2011 4:28 AM
  • Maybe a little bit late, but I was running almost same problem on a exchange server.


    First attempt to Update the windows patches - excluded the patches from the last 2 months.

    I was kind a new to this, and didnt noticed that Windows Service pack must have at least 8GB free disk space.(Recommended)
    So the C:\ partition had less then 5 GB free disk space, and I started the updates.
    All went well until Windows SP1 begun running to downloading and installing.

    When the installer noticed there wasnt enough space, It stopped, it give the status Failed, en when scaling up the C:\partition with another 10GB more space, the C:\partition had 18GB free disk space.

    Tried to Call up a new attemp to install the SP1... but with no succes to start the SP1 installation...
    I tried to reinstall but the windows update didnt get offered again to install again or resume or anything to try again... is handy for Mickysoft, to check before installing, so the install wont get corrupted, and can install when c:\ partition has enough disk space.

    What was the trick:
    1) Stop the windows Update Service
    2) C:\Windows\SoftwareDistribution\DataStore - Delete content
    3) C:\Windows\SoftwareDistribution\Download - Delete content
    4) Windows update Service check if its runs again
    5) Check again for windows updates - Check if Windows Server Service pack 1 is offered, and install reboot and youre good to go.

    It works for me :) hopefully after 3 years you had found a solution, but since I was poping for a solution and found this article with no solution.
    I tought it will be hopefull for others to respond to this article with a solution.

    Kind regards,

    Alexander Tjintjelaar
    Micky soft noob

    Wednesday, April 09, 2014 7:19 PM