none
Windows Internal Database (WID) Install Fails - error computer requires restart

    Question

  • I have setup a domain controller in Windows Server 2012 Standard. Currently this server is holding roles: AD DS, AD CS, DHCP, DNS, IIS. Now I am trying to install Windows Server Update Server (WSUS) and part of this is to install Windows Internal Database (WID). I have installed WSUS by not including WID during the add roles and features wizard but WID would not install. It keeps coming up with an error message that the server requires restart but when I try to install after I restart the computer it comes with same message.

    Friday, October 12, 2012 12:03 PM

Answers

  • I am having the same issue just trying to install WSUS without WID using SQL 2012 database.
    This one is easy: WSUS v3 is not supported on SQL Server 2012 (yet).

    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2012)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin

    Thursday, October 18, 2012 9:15 PM
    Moderator

All replies

  • Am 12.10.2012 schrieb gen_gen95:

    I have setup a domain controller in Windows Server 2012 Standard. Currently this server is holding roles: AD DS, AD CS, DHCP, DNS, IIS. Now I am trying to install Windows Server Update Server (WSUS) and part of this is to install Windows Internal Database (WID). I have installed WSUS by not including WID during the add roles and features wizard but WID would not install. It keeps coming up with an error message that the server requires restart but when I try to install after I restart the computer it comes with same message.

    Search for a file WININIT.INI in Windows Directory. Delete the file if
    you find it.

    Next part is in Registry.
    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager >
    PendingFileRenameOperations You can delete
    PendingFileRenameOperations. Try Installation again.

    Winfried


    http://www.microsoft.com/germany/windowsserver2003/technologien/updateservices/default.mspx
    http://www.wsuswiki.com/Home

    Friday, October 12, 2012 5:42 PM
  • Winfried, thanks for the reply.

    But I don't seem to have the WININIT.INI file and registry entry.

    Sunday, October 14, 2012 11:48 PM
  • I have same issue trying to install AD FS.  Any luck?
    Monday, October 15, 2012 5:52 PM
  • I am having the same issue just trying to install WSUS without WID using SQL 2012 database. No matter what I do Requires restart error.
    Wednesday, October 17, 2012 2:54 PM
  • I am having the same issue just trying to install WSUS without WID using SQL 2012 database.
    This one is easy: WSUS v3 is not supported on SQL Server 2012 (yet).

    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2012)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin

    Thursday, October 18, 2012 9:15 PM
    Moderator
  • I have setup a domain controller in Windows Server 2012 Standard. Currently this server is holding roles: AD DS, AD CS, DHCP, DNS, IIS.

    You'll want to research the implications of running WSUS on a Certificate Services server.

    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2012)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin

    Thursday, October 18, 2012 9:16 PM
    Moderator
  • You'll want to research the implications of running WSUS on a Certificate Services server

    Are you referring to the performance issue it can cause if WSUS installed in certificate server? Performance is not really an issue for me because we don't have many client computers and our setup is pretty simple - one DC and about 50 client computers.
    Thursday, October 18, 2012 10:52 PM
  • I am experiencing a near identical issue.  I am running Server 2012 Standard with AD DS, no AD CS, DHCP, DNS, no IIS.  I cannot get WSUS installed using WID.  I also tried using SQL Server 2008 R2 with no luck.  The same error occurs, stating the server needs a restart.  Any luck with a solution?
    Monday, October 22, 2012 3:09 PM
  • Are you referring to the performance issue it can cause if WSUS installed in certificate server?

    Uh no... I'm referring to the well-documented guidance on how to properly implement Certificate Services, and the potential impact on your CS installation if some other less-critical application (such as WSUS) causes the server to become hosed, or requires an uninstallation/reinstallation that will negatively impact the CS installation. (Hint: Both require the Web Server role.)

    Personally, I would argue that anybody who needs to install DS, CS, DNS, DHCP, IIS, and WSUS on the same server -- probably does not need an Enterprise PKI in the first place. (If you need a certificate, go buy one. The cost of the certificate from a 3rd party will be miniscule compared to the operational costs of maintaining a CS installation.)


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2012)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin

    Wednesday, October 24, 2012 1:00 AM
    Moderator
  • I am experiencing a near identical issue.  I am running Server 2012 Standard with AD DS, no AD CS, DHCP, DNS, no IIS.  I cannot get WSUS installed using WID.  I also tried using SQL Server 2008 R2 with no luck.  The same error occurs, stating the server needs a restart.  Any luck with a solution?

    Not really intending to finger-point here, but getting in the right forum to get the best help will save you lots of time.

    Is your issue that you cannot install *WSUS* with a successfully installed instance of WID? (In which case this is the correct forum to pursue this question.), or

    Is your issue that you cannot install WID on Windows Server 2012? (In which case the correct forum to pursue this question is one of the Windows Server 2012 forums, inasmuch as WSUS isn't even part of the picture until the WID is installed, and those of us in this forum are, generally speaking, not WID experts -- we all work from a successful installation of WID.)


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2012)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin


    Wednesday, October 24, 2012 1:05 AM
    Moderator
  • Thanks Lawrence,

    I have opened a new topic in Windows Server 2012 forum now.

    http://social.technet.microsoft.com/Forums/en-US/winserver8gen/thread/ae88de7d-f69f-4cb1-877f-379151d01899

    Wednesday, October 24, 2012 2:43 AM
  • Edit the "Log on as a service" setting in your User Rights Assignment under Policies, Windows Settings, Security Settings, Local Policies in your default domain policy.  Add IIS_WPG, NETWORK, NETWORK SERVICE, SERVICE to the setting.  Use Gpupdate on your server to sync the policy and then try to install WID.
    • Proposed as answer by Brian_Jones Wednesday, March 6, 2013 9:19 AM
    Friday, January 11, 2013 8:44 PM
  • Thanks everyone!! My issue is now RESOLVED thankfully.
    Wednesday, January 30, 2013 8:26 PM
  • Thanks everyone!! My issue is now RESOLVED thankfully.

    Would you might sharing what it was that resolved your issue for the benefit of others who might read this thread?

    Or put a link to the thread where it was answered?


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    Saturday, February 2, 2013 12:56 AM
    Moderator
  • How did you solve this? I'm having the same issue

    Cheers

    • Proposed as answer by RLAGroup Thursday, February 7, 2013 2:40 PM
    • Unproposed as answer by RLAGroup Thursday, February 7, 2013 2:40 PM
    Thursday, February 7, 2013 12:58 PM
  • I managed to get this working by doing the following:

    - Install and user SQL Express 2012 as the database
    - Install the WSUS role, when on the features screen un-tick the Windows Internal Database (WID) so this isn't installed.

    For me the WID was trying to start a service that didn't exist and asked for the restart each time. By not installing WID and using SQL Express this doesn't happen

    Thursday, February 7, 2013 2:42 PM
  • - Install and user SQL Express 2012 as the database
    - Install the WSUS role, when on the features screen un-tick the Windows Internal Database (WID) so this isn't installed.

    For me the WID was trying to start a service that didn't exist and asked for the restart each time. By not installing WID and using SQL Express this doesn't happen

    Well, that's scary for a number of reasons, and not a solution I'd endorse for others.

    • First, SQL Server 2012 is not a supported platform for installing WSUS (and I made that statement earlier in this thread).
    • Second, if the WID won't install, then there's something wrong with the OS installation. The proper action is to fix what's broken.
    • Third, if the WID was trying to start a service that didn't exist, then the proper action is to find out why that service doesn't exist and fix it.
    • Finally SQL Server Express Edition is a performance-throttled edition of SQL Server, and does not have sufficient performance capacity to properly support a WSUS installation.

    Yes, you've worked around the WID issue, but now you have a totally unsupportable WSUS installation.


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    Friday, February 8, 2013 12:04 AM
    Moderator
  • There is a solution here which may work:

    http://qa.social.technet.microsoft.com/Forums/en/winserver8gen/thread/ae88de7d-f69f-4cb1-877f-379151d01899

    • Edited by RLAGroup Friday, February 8, 2013 9:17 AM
    Friday, February 8, 2013 9:02 AM
  • This worked for me, thanks Del

    MCP, MCDST, MCTS x 6, MCITP x 3

    Please don't forget to mark this post as an answer if it is the solution to your problem!

    If you like trance music, please subscribe to my podcast Trancendance Podcast

    View my MCP Certifications

    Follow me on Twitter

    Wednesday, March 6, 2013 9:19 AM
  • Edit the Default Domain Policy" in the section "log on as a service" add parameter "NT SERVICE\ALL SERVICES"
    Wednesday, May 1, 2013 7:00 AM
  • Hi there,

    Please ensure your domain admin account / account with the privilege to start services added to your Local Administrators Group. To do so:

    1. Open your Server Manager

    2. Tools --> Computer Management

    3. Local Users & Groups --> Groups

    4. Double-click Administrators

    5. Click Add and add your domain admin account there.

    6. Restart the server and try to reinstall WSUS.

    Hope this helps!


    Regards,

    Thursday, December 5, 2013 3:06 AM
  • Adding IIS_WPG, NETWORK and SERVICE did the trick WID installes (NETWORK SERVICE was already present).

    Saturday, January 18, 2014 9:33 PM
  • Adding IIS_WPG, NETWORK and SERVICE did the trick WID installes (NETWORK SERVICE was already present).

    My system didn't have an IIS_WPG account to add. However, adding the rest to the appropriate GPO setting did the trick for me.
    Thursday, November 6, 2014 4:15 PM
  • Where do I find this

    Saturday, February 14, 2015 4:51 AM
  • Edit the "Log on as a service" setting in your User Rights Assignment under Policies, Windows Settings, Security Settings, Local Policies in your default domain policy.  Add IIS_WPG, NETWORK, NETWORK SERVICE, SERVICE to the setting.  Use Gpupdate on your server to sync the policy and then try to install WID.
    For server 2012 R2 the "IIS_WPG" isn't necessary  :) great tip helped me a lot!
    Friday, May 6, 2016 6:38 PM
  • Edit the "Log on as a service" setting in your User Rights Assignment under Policies, Windows Settings, Security Settings, Local Policies in your default domain policy.  Add IIS_WPG, NETWORK, NETWORK SERVICE, SERVICE to the setting.  Use Gpupdate on your server to sync the policy and then try to install WID.

    This worked for my issue with WID; adding it alone failed until I added to "log on as service"

    Thank you Del177.  Your a genius;)

    • Proposed as answer by DougTCA Sunday, May 7, 2017 8:57 PM
    Sunday, May 7, 2017 8:57 PM
  • Thanks a tonne Brian,

    My issue got resolved with combination of above fix and another error message that i was getting while setting up.

    This message came (every time) just when i started the adfs config wizard.

    "Group Managed Service Accounts are not available because the KDS Root Key has not been set. Use the following PowerShell command to create the key: "Add-KdsRootKey -EffectiveTime (Get-Date).AddHours(-10)"

    I ran the above powershell command and a reboot later it started to work.

    -Nitish



    Wednesday, May 10, 2017 6:44 PM
  • Edit the "Log on as a service" setting in your User Rights Assignment under Policies, Windows Settings, Security Settings, Local Policies in your default domain policy.  Add IIS_WPG, NETWORK, NETWORK SERVICE, SERVICE to the setting.  Use Gpupdate on your server to sync the policy and then try to install WID.

    This worked for me, thanks!

    • Edited by Natham5000 Saturday, May 5, 2018 3:35 PM
    Saturday, May 5, 2018 3:33 PM